Question about Weller WES51 SOLDERING STATION

Open Question

Can i connect Weller WMRP iron or even the tweezers for smt desoldering on wes51?? cable connector is the same 5 pin

Can I interchange weller iron from newer smt tech pens for wes51?

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 202 Answers

SOURCE: Hi!

Bill, i would use a connector with the correct number of ends made for a radio. you could probally find them at radio shack. be sure to connect the right wire to the right pin on each. you would need male and female. then the next question is yes four screws under the rubber feet

Posted on Jul 07, 2009

  • 33 Answers

SOURCE: I have a Weller 1002B soldering station. Haven't

Hi, I'm not sure the tip is defective. Check that the tip is screwed in tight. If it is not good and tight the tip will not get a good heat transfer from the solder wand. Hope this helps. If the wand will heat then the tip should.

Posted on Aug 30, 2010

  • 1267 Answers

SOURCE: Hi, I have a

See: http://www.amazon.com/s/ref=nb_sb_noss?url=search-alias%3Daps&field-keywords=weller+WM17D+soldering+tips&x=15&y=19

Also Radio shack may have the tip at a larger price, but you don't have to pay shipping

Posted on Dec 10, 2010

  • 185 Answers

SOURCE: The tip of my weller

This happens quite frequently. On the tip there are two nuts that hold the tip to the gun. Tighten them a bit. The tip is made of copper and as this heats, it causes the connection where the nuts are to become a higher resistance and thus lower heat. When you tighten them, it "cuts" through the copper oxidation (caused by the heat) and lowers the resistance, hence more heat.

Posted on Jan 12, 2011

  • 185 Answers

SOURCE: soldering tip is not getting

I had a similar problem. I found that the cable from the transformer to the iron had an open in it. There are two spots where this mainly happens. At the transformer connector, or and probably this is it, at the iron entrance, You can remove the heater on the iron and take a voltmeter and see if you have power there. I found on mine that there was an open. I removed my cable, cut off the end at the iron and re-installed it. It was not easy but I managed to get it repaired. This is a kinda trial and error thing, mostly cables fail at the strain reliefs, this is where there is the most play in the system, and the constant flexing eventually breaks a wire. There are a number of places to get replacement cables, etc. Here is the one I use www. eaesales.com . Please let me know if this has helped.

Posted on Jan 28, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have Weller EC1002, WES51, and WTCPS all with base, cord, and handpieces (complete). On shelf for years. Can you test, quote and do repairs as needed?


yes but shipping alone would eat a lot of $$$
they r pretty basic - u should be able to do that urself.
a multimeter may be necessary
it is either
broken wire in cables
bad connection inside case
thermal cutout
bad tip
switch.

Jun 30, 2014 | Weller WES51 SOLDERING STATION

1 Answer

Weller WES51 does not heat up unless I turn to 700 degrees or higher


You may have a broken wire in the temp sensor in the tip of the iron or near where the iron connects to the base.

Jan 24, 2014 | Weller WES51 SOLDERING STATION

1 Answer

I have a weller EC1201A iron connected to an EC2100D base unit. It is a UK 240V model with digital temp set and display. The iron does not heat up. You can set the desired temp but the display just...


its my be the controler
http://cgi.ebay.com/New-weller-control-Board-EC1002-soldering-stations-/390286420305?pt=LH_DefaultDomain_0&hash=item5adee22951
good luck...

Feb 25, 2011 | Weller Welding Tools

1 Answer

Soldering tip is not getting heated up as well as led is not glowing .i am getting 26 V AC at the output of Transformer for my weller WES51


I had a similar problem. I found that the cable from the transformer to the iron had an open in it. There are two spots where this mainly happens. At the transformer connector, or and probably this is it, at the iron entrance, You can remove the heater on the iron and take a voltmeter and see if you have power there. I found on mine that there was an open. I removed my cable, cut off the end at the iron and re-installed it. It was not easy but I managed to get it repaired. This is a kinda trial and error thing, mostly cables fail at the strain reliefs, this is where there is the most play in the system, and the constant flexing eventually breaks a wire. There are a number of places to get replacement cables, etc. Here is the one I use www. eaesales.com . Please let me know if this has helped.

Jan 28, 2011 | Weller WES51 SOLDERING STATION

1 Answer

Unit does not heat up to temp and green light blinks


hi, i have faced the same problem with my station also. the issue will be only with your 6 pin connector, check whether all the pins are getting connected properly. some times when u apply force the connector's pin may go inside. check up with that.

Nov 04, 2010 | Weller WES51 SOLDERING STATION

1 Answer

I have two WU81 Weller soldering irons and their are both showing the same fault. When we turn the irons on in the morning, the 500mA fuse that can be found in the base unit is blowing. Is this a common...


Perhaps this fuse should be a "T" type or delayed acting (antisurge fuse) . If the fuse has been replaced by an "F" fast acting fuse then this could explain why they are blowing.

Aug 10, 2010 | Cooper Industries Weller Soldering Iron,...

1 Answer

NEED MANUAL FOR Weller soldering station WESD51 POWER UNIT


You can download the manual from here: http://www.weller-toolsus.com/MagentoShare/media/mannuals/WES51_OI_PL.pdf

Jan 19, 2010 | Weller WES51 SOLDERING STATION

2 Answers

Weller WMRP soldering iron faling prematurely.


I suggest that you set the "Auto Time Off" much longer or turn it off by setting it to 0, and use a standby of 400 degrees after 10 minutes instead.

The reason is that every time this soldering iron has to turn on, it's trying to heat up in about 5-10 seconds. When it does that, it applies full wattage to the heating element, and putting full wattage on them a lot of times is what's burning them out. If the soldering iron maintains the same temperature while not soldering, it only uses 20-30% of the full wattage to keep it at the set temp. This isn't nearly as hard on the heating element.

Aug 04, 2009 | Welding Tools

Not finding what you are looking for?
Weller WES51 SOLDERING STATION Logo

Related Topics:

32 people viewed this question

Ask a Question

Usually answered in minutes!

Top Weller Welding Tools Experts

Cindy Wells

Level 3 Expert

5101 Answers

Lawrence Oravetz

Level 3 Expert

9587 Answers

Mike

Level 3 Expert

4336 Answers

Are you a Weller Welding Tool Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...