Question about Manual Units Sphygmomanometer Pressure Monitoring MDS9125LF Medline

Open Question

TOA Amplifier TA958 HUMM

Loud hum in output?

Posted by Anonymous on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My toa a-912mk2 amp does not work and the red protect light stays on


• Check for shorted power transistors, and extract in pairs.

If it powers up, without protect..


• Check again for possible additional components before replacing

the bad ones.


A good amp never produce an over of 0.7V on its output.

Sep 06, 2012 | TOA Electronics A912MK2 Amplifier

1 Answer

Loud hum


hi,
Sorry, a load humm is indicatrive of blown output transistors. If it is still playing, but have a load humm, there is a PSU problem. Haver it fixed or the probem will get MUCH bigger!

Sep 04, 2011 | Koss KS3151 System

1 Answer

I have a TOA 301 15W amp and a Bose 151 environmental speaker(40w 4 ohms). I do not have a manual for the amp and wish to connect the speaker as a small PA . My concern is that the output I think I should...


Don't worry about the 7.7 volts. Just connect between COM and 4 ohms and you'll be fine. I didn't find a 301 part number related to a 15w amplifier, but I did find a BG series (115 130) of 15 watt amps manual http://www.toa-products.com/international/download/manual/bg115_mt1e.pdf

Carl

May 08, 2011 | TOA Electronics Audio Players & Recorders

2 Answers

Loud humm when the drive channel is on


I suspect the power supply has an issue. Most likely bad filter capacitors. This could cause "motorboating" where power is drawn and supply voltage collapses and then recovers repeatedly.

Time for the repair shop. The parts cost should be nominal... labor... well...

Mar 15, 2010 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

Bad Humm out


First disconnect all inputs. If hum is still there, PROBABLY the filter capacitors have gone bad. Replacement is the cure.

IF there is no hum without any inpout cable connected, there is a ground loop and either the ground at the inout connector is broken, or your cables and guitar may have a problem.

Nov 15, 2009 | Marshall Amplification Marshall MG250DFX...

1 Answer

I have a loud humm in my bose lifestyle 28 system


Turn on your bose so you can hear it hum. Go to the back of your cable box and remove the co ax cable connected to "cable in". If the humming stops, the sheilding on your cable is no longer grounded. Purchase MPAV800 or similar surge protector to run cable line through it and get it grounded.

Feb 02, 2009 | Bose Lifestyle 28 System

1 Answer

Velodyne subwoofer


First make sure that the cables are properly connected up. Make sure that the output of the amplifier feeding the sub is working properly and has no faults.

If the above is okay, it is possible that the power supply in the sub, and or the output stage has a failure. In this case the sub will require shop service to have it working again.

Jerry G.

Jun 12, 2008 | Velodyne DPS-12 Subwoofer

1 Answer

Connecting input & output on my TOA 900 series amp


http://www.toaelectronics.com/Manuals/P-906_12_24MK2.pdf.

Jan 07, 2008 | TOA Electronics P-924MK2 Amplifier

1 Answer

Maytag Netune Mah4000AWW


Makes a loud humming noise. Does the machine go thru its cycles ? Is the humm ther all the time ?

Jan 06, 2008 | Maytag MAH6500 Neptune Front Loading...

Not finding what you are looking for?
Manual Units Sphygmomanometer Pressure Monitoring MDS9125LF Medline Logo

Related Topics:

46 people viewed this question

Ask a Question

Usually answered in minutes!

Top Medline Vehicle Parts & Accessories Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14378 Answers

Brad Brown

Level 3 Expert

15937 Answers

Are you a Medline Vehicle Part and Accessory Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...