Question about Toshiba 43HX70 43" Rear Projection Television

2 Answers

Toshiba 43HX70 convergence fix - now no video

Hi! I've done the old tried and true replacement of the convergence STK ICs and the blue would not adjust horizontally so I also replaced all the resistors. No Help.  I then replaced the two ICs again with new ones. Now I have audio but no video at all.

The service manual mentions the 6 resistors are 1.2 Ohms but I've noticed the 2 on the outside edges appear to be a different color code than the other 4. The video still worked after changing resistors but didn't work after changing out the ICs again. Any idea what could be causing my 'no video' issue now?

I suspect I could've also blown a fuse (high voltage?) and if that causes no video, any idea where the fuse(s) are?


Thanks in advance!

Posted by on

  • 1 more comment 
  • bman63 Nov 06, 2007

    Thanks T!

    Was out of town for a bit but ready to start back in on it.

    Any idea if the Pwr Supply is mounted on the main board (the big board on the left when facing the back on the set) or a separate unit? (as with PCs). I read a similar post about (2) 6.3 Amp fuses on the front edge of the pwr supply board causing the 'No Video' issue (after replacing convergence chips).

    Is safety a big concern with removing this main board? The convergence board was no big deal but no power cord running to that one :)

    Any other tips regarding this pwr supply/fuse issue greatly appreciated!


  • bman63 Nov 24, 2007

    Got my parts and tried them...Sure enough - F850/851 were blown. Also shorted the convergence chips and blew one resistor, so replaced them again. Good call!

    Now I have video again but none of the remote controls will power up the set (remotes themselves have new batteries and are working fine). As a result I can't go into service mode and reset convergence...looks like I blew something on the remote sensor.

    I know the infra-red sensor is behind the screen on this model; any idea what I blew and where it's located? I figure if I'm lucky maybe it's a removable fuse, although I don't know where the sensor runs to on the board...Thanks for the help!!

  • Rom-30 Jan 29, 2008

    I have the same exact problem!!!

    My tv wasnt bad at all.... I had a little bit of red bleeding off on the right and a little blue bleeding off on the left.... really not a big deal at all.... at most, it just made the sides of the screen a LITTLE blurry.... anyway, Im super picky so I decided to replace the IC's....

    apperantly I bought them from a site that I later found out was the #1 place not to buy the ICs from (electronix - or something like that)

    After installing the ICs, I put everything back to how it was.... and Yes, I have experience in soldering. and I power it on. and I hear the Static sound coming from the power lines.... the Led is solid.... .I hear sound................ but no Video...(Pwned)

    I opened her up... Checked her out, re-touched everything up (my own work) and tried again... .and again... and again. I musta opened her up 4 times or so.... I checked the fuses(while connected) they all seemed fine... Then i thought of just putting back the old ICs... the ones that were working anyway.. and Tried that.... still no video!!!

    Im really loosing hope... I started to call service shops in the area... there talking about $300 plus the price of the ICs which they wanna charge $100 for each.

    My game-plan for tonight is to open her up, de-solder the fuses, check them out while outside of the board... if there good, put them back in... and hope for a miracle.... :'(

    I'll try and keep researching, and i'll post a result soon.... This is a good website so I hope what I find out will help others.




2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

How do i test the IC chips?...

Posted on Jan 29, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert who has answered 1,000 questions.

  • Master
  • 1,694 Answers

I think the hardest to solve problems are those I installed!!
Where do we start==no lecture,but I never change a resistor
unless it has changed (in value!) Use a digital meter and check
the value of each resistor.Toshiba is a bit confusing as to values
of each resistor and location in relation to the IC's.Go over your own work first.Check micro fuses in power supply=F851,F852,
etc. Carefully resolder steel jumper wires at board edge,they feed
B+ to convergence amp circuit.Be sure to verify no shorts in pins
of IC's.(use your meter).........T

Posted on Oct 25, 2007

  • Vista Electronics Nov 07, 2007

    Locate on the power board ( the one the AC cord goes into) any

    and all fuses. F850,F851 for example. They are along the board

    edge-- the symptom should be " blinking LED " if a fuse is open.

    Check them all with meter...Also,solder jumper wires on signal

    board = 008,010,017,048 and 600 or you might blow fuses again.............................................................................T.



1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

2 Answers

Focus Error I am getting double picture and the colors are off. When trying to auto focus the blue lines are wavy.

Replace Convergence ICs ,Big black ICs will have PN# on them example STK 392-110
Mats has ICs 1-800-628-1118

Jun 05, 2011 | Toshiba 42H82 42" Rear Projection...

1 Answer

The picture is warped red & blues distorted

Your Convergence ICs have failed. It is very common on rear projections. The solution is to replace the STK chips, check fuses and the resistors next to the STK chips. Replace as necessary and re-align via the service menu. It is about a $300 repair at a tv service center. You will need the service manual if you decide to do this yourself.

Try This:
When you notice the symptons Use this simple test to verify.
Go to the users menu on the tv.
Look for the converge option probably under setup or video setting. Converge is short for convergence to align the red and blue colors to the green color.

If you cannot move the red either horizontal or vertical, then the STK chip has failed for red section.
If you cannot move the blue either horizontal or vertical, then the STK chip has failed for the blue section.

If you can move both in each direction then the problem is something else.

Note if one STK chip fails, you replace both regardless. They will be right next to each other.

Feb 20, 2011 | Toshiba 57H81 57" Rear Projection...

1 Answer

Convergence function reads error

Check the 1.8 ohm resistors in the convergence circuit there will be 6 all 1.8ohms, They will be where your STK ICs are
STK392-110s which are Big Black ICs,You may need to replace ICs They are Big Black ICs with STK392-110 printed on them Mats has them 1-800-628-1118

May 30, 2010 | Toshiba 51H83 51" Rear Projection...

1 Answer

Convergence problem w/55h70. red is ok but can't fix blue. Is there a component or board that is easily replaced?

Yes,U have some basic machanicals skills?The Toshiba Tv convergence board,it call a Hyper board.Try website to buy a refurbish board.This board no longer produced by Toshiba,if can't find it.The Convergence 2 STK ICS,and some or all it resistors,must replaced manually.Must have tools,and knowing how to do basic soldering,to do this.

Apr 06, 2010 | Toshiba 55H70 55" Rear Projection...

1 Answer

Toshiba 43HX70 convergence problem

One or both of the STK convergence chips have probably failed.

I can give you guidance on this if you are confident to do the repair. I had the same problem with my Tosh 40WH08B and after replacing these chips it works like new.

May 21, 2009 | Toshiba Televison & Video

1 Answer

Toshiba 43HX70 convergence problem

Yes its actually a very easy repair. You need two STK392-110 Convergence ICs and six 1.2 ohm 2watt resistors. You can get the replacement parts and instructions at the following link.

Apr 27, 2009 | Toshiba 53H71 53 in. Rear Projection...

1 Answer

Blue halo on bottom 1/3 - Convergence issue with my 43HX70


Aug 13, 2008 | Toshiba 43HX70 43" Rear Projection...

1 Answer

Convergence problem?

you need to replace both convergence ICs STK392-110 you can get replacement ICs at the following link and they provide free instalation instructions with pictures so you can do the job yourself. Heres the link.

May 25, 2008 | Toshiba 43HX70 43" Rear Projection...

Not finding what you are looking for?
Toshiba 43HX70 43" Rear Projection Television Logo

Related Topics:

217 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toshiba Televison & Video Experts

The Knight
The Knight

Level 3 Expert

74990 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Jaime Hernandez

Level 3 Expert

2326 Answers

Are you a Toshiba Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides