Question about Hoshizaki Commercial Freezer KM-500MAH

1 Answer

We have an older manitowoc icemachine model ey 040a that we can't get make ice. It has a new compressor and the water semms to be fine too

Posted by on

  • Robert Moller
    Robert Moller May 11, 2010

    What symptoms are you experiencing, also when compressor was changed was a leak test
    performed ?

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

The EY0404A was manufactured in the mid to late 80's and and uses R-502 Refrigerant. Best bet would be to upgrade to a new energy efficient unit using an environmentally friendly refrigerant. The average life of that EY0404A was about six years. Hoshizaki makes the best.

Posted on Jun 25, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

All cycles work except harvest manitowac ice machine


Ice thickness probe on Manitowoc and float switch may be dirty or stuck if hoshi. Manitowoc sometime the thickness probe can get dirty and a film of algae and not sense ice properly but rare

Oct 06, 2011 | Hoshizaki Freezer Commercial Ice Machines...

1 Answer

I have a manitowoc commercial ice machine.It has stoped making Ice and just seems to keep running water and not freezing


Hi,

Check to see if the compressor is running... if it is running and not cooling then it may have a refrigerant leak...
If the plate is getting cold but the water is not freezing then check to make sure that the float is not stuck on and the the water just keeps running in... that will keep the water warm enough so that it does not freeze...

heatman101

Mar 10, 2011 | Freezers

1 Answer

Sub Zero 5065 Under Counter Ice Maker


We have a sub zero 5065 in our storage, still unused and in the box. You may want to just buy it at a good deal. Make an offer, it has to go as we are cleaning out the storage are. 360-695-3238 Brian

Mar 18, 2010 | Freezers

1 Answer

Help! my manitowoc! leaking!


I'm having a little trouble finding that model but if you contact them or can find a better or different number it may help. You can also contact them and order parts or order from one of their suppliers. Here is their link to home page. With the correct model number you can find your service manual and part number. Hope this helps. Manitowoc is pretty good about helping out. Sea Breeze

http://www.manitowocice.com/index.asp

Jul 18, 2009 | Freezers

1 Answer

Manitowoc SD 0852A ice maker compressor will not kick-in


Here's my thoughts, I hope it helps. I'm going on foggy memory here, so I may not be entirely correct.
I worked on something like this a few years ago. The icemold (plate) is vertical, there is a circulating pump that runs water over the mold, with the water freezing as it passes. The sealed system is a heat-pump scheme, it freezes the mold to form the cubes, and reverses to heat for release. And when it works, it makes ice fast. It runs constantly until the ice hopper is detected to be full. (there should be a bail to detect the ice level) The system will not run in the event that it thinks the hopper is full (bail up) but the pump motor runs continuous to avoid it freezing. There is probably either a false detection of "full" or there may be a leak in the sealed system and the system will therefore not run.

Jun 28, 2009 | Freezers

5 Answers

Ice Cubes won't drop


Something is holding your Ice Slab at the bottom from your description.
Some causes are
1 Dirty - scaled up evap, or just dirty w muddy covering,
2 the vacuum breaking holes are stopped up If it is making a sla whith the evaporator warm no ice take a flashlight and hold it where its shining to the back of the evap and look for the light on th cube forming slots next to the ones your shining the light into Upper corners of each hole must be open.
3 The slab is freezing uneve most like cause is a stopped up distributor tube at the top thats feeding the water down the evaporator.
4 On some models thay had a closer fitting water curtian (the cover in front of the slab) and the top of the sheet touched this and caused the slab to stay uprite and continue the "slide" forward.If your curtian is of the older style and has metal hooks on it with verticle slots n the curtian look at the slots and see if the slots are worn making the whole curtian slide down ward I have seen this several times.4B On some older models there is also a plactic coated wire diverter on the bottom infront of the evaporator. If the palstic coating is gone or the bottom or is not even, the slab could hang up there. 4C If you have the newer plastic pins make sure thay are seated in the mounting properly.
5 Nickel plating could be comming off (any copper color on the lower 1/3 of the evaporator?).
6 I have seen some of the horizontal plates them selves be loose and not in flush try pushing and pulling on them especially the ones at the bottom. ANy that are loose and comming out is your problem.
This lengthy extrapolation is by no means all of the possibilities but most of the common ones. If this helps you solve your proble please rate me accordingly. If it leads you to the correct and completed repair WOULDNT WE MAKE A TEAM?? And Good luck to you.

Feb 13, 2009 | Hoshizaki Commercial Freezer KM-500MAH

1 Answer

Ice cube cycle time very high


i suspect a defective liquid line or pump down seleonid coil. just make sure you hear the "click" when it starts up if not the selenoid coils could be defective. also verify that the condenser fan is running,because if not you are short-cycling on high head pressure. please contact if you need any additional info

Jun 11, 2008 | Hoshizaki Commercial Freezer KM-500MAH

Not finding what you are looking for?
Hoshizaki Commercial Freezer KM-500MAH Logo

Related Topics:

269 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoshizaki Freezers Experts

Dennis Boxerman

Level 3 Expert

1165 Answers

Charles T Nevin
Charles T Nevin

Level 3 Expert

4070 Answers

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

Are you a Hoshizaki Freezer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...