Question about Jamo DMR 60 DVD Player/Receiver

Open Question

Subwoofer thumps away for no reason.

My Jamo 7 Series Sub plays up occasionally. It starts thumping away for no reason. I don't know if it get wrong signals from my amp (Onkyo 905). I have never had it happen to me while listening to music from PS3, but it has happened when watching Foxtell.
I took the plug out of the wall and put it in the surge protetion board, and straight away it played up again. After repeating this process it was fine again. I cant figure it out, and cant get it to play up on comand.

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 238 Answers

SOURCE: Jamo 250

hi, there must be this LINE IN socket (ur so called Hole), then on the onkyo, there must be this sub-line out socket, plug one end of the RC socket to the sub out of onkyo , and other to the line in of the sub, its all to do wirth its appropriate inputs and outputs,let me know

Posted on Jan 12, 2008

sanjin
  • 56 Answers

SOURCE: I have no amp for jamo 1060 sub

Dual Voice-Coil
The unique Dual Voice-Coil design allows both left and right channel sound from just one speaker. Simply hook up both the left and the right channels to the special terminals on the speaker. Hook up one channel only, if the speaker is to be used in a conventional stereo set-up.
I found this on jamo site hope that will help you

Posted on Mar 18, 2008

  • 1 Answer

SOURCE: jamo subwoofer issues

hai iam hans i had also a problem with the sub
turned out jamo denmark didnt had the spare parts to fix it?
can u believe that
so i wait 6 weeks and after 100 phone calls to denmark and my local dealer they deside to take the part out of another sub ?.
but i really had to make a a lot of effort to achive this
but for the price the jamo set is exellent
a shame about the service .

Posted on May 17, 2008

  • 2976 Answers

SOURCE: Jamo i300 speakers are dead.

There is peobably a fuse located on the back. Your speaekers are probably okay. If anything fried inside, it is probably the output transistors.

Posted on Feb 02, 2009

  • 127 Answers

SOURCE: my jamo sub 200 & pioneer vsx517 receiver is not working properly

What do you mean that it sometimes doesn't work? It doesn't power on automatically?
Check settings of your receiver - if it has subwoofer output enables and if low frequencies from all channels are directed also to the SUB. By default only the LFE channel (.1) of 5.1 signal input is fed to the subwoofer. So Sub will work in this case only when you listen to 5.1 signal (DVD movie for example), but for radio or stereo music, only front speakers are used. By configuring this bass redirect, you can use subwoofer for all signal types.

Posted on Mar 03, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The subwoofer starts to make a loud thumping sound


Remove the signal source and power it on to see if the problem occurs without any input signal. The problem could be in the receiver and not the sub

Dec 08, 2013 | Cerwin Vega Avs-sub8 150 Watt Amplified...

1 Answer

Subwoofer thumps with like a feed back when switching sources or settngs?


This is not abnormal, and normally not harmful to your sub. Just temporarily lower the volume setting on the back while switching things I guess is the easiest thing to do.

Jun 03, 2012 | Mission M5AS Subwoofer

2 Answers

I bouht my boston pv350 subwoofer from binglee at beresfield a bit over 12 months ago . i have hardly used it and now it wont work . It has power thats all could you please let me know what i can do with...


call customer service and request info on warranty service period. second ; unplug the sub..for 10 minutes and you should hear a thump when plugging it back to the wall socket. check that the volume is turned up-maximum and finally pull the RCA plugs out- then back into the sub. again you should hear a thump. If no thump. and customer service does not assist, it is a job for a audio repair tech.hope you see something during the steps above.

Mar 04, 2010 | Boston Acoustics PV350 Subwoofer

2 Answers

Humming sound in subwoofer after it's been playing for a while


It sounds like you are describing an earth loop problem. I won't go into detail in this post, but try an isolation test first. disconnect everything from the reciever except the sub and try connecting say a BATTERY powered mp3 player or cd player to minimise connections to the electrical mains earth. you could also isolate things by taking your sub to a friend's house and trying it on their system.
If it is an earth loop use a process of elimination to find out which two pieces of equipment causes the earth loop. then apply filtering.
you can buy earth loop isolation transformers for about AU$26 and I've used one on my sub myself. Theyhave RCA (phono)plugs on each end and they connect inline with the signal cable to the sub amp.

as for the thumping sound it might be the speaker protection circuitry cutting off the amp to protect the subwoofer speaker from damaged. This might be triggered if the earth loop sound is causing the sub amp to overload and clip.

Failing this there might be a dried out overheated electro capacitor in the amp circuit causing the hum. Hav a chat to your local electronics person, who should be able to spot it!
Hope this puts you on the right track
Happy Hunting!

Jan 07, 2010 | Sunfire Audio Players & Recorders

1 Answer

Only one thump when car is turned on. problem in amp strength or subwoofer?


try pluging in a diff, speaker to the amp see if u get sound.try powering the sub with a home radio just to see if u get sound at all if ur getting sound from the sub then its the amp but u could of damaged it when the amp over heated

May 03, 2009 | Kicker SoloX S10X2 Car Subwoofer

2 Answers

Sunfire True Sub Constant Hum & Thump on Initial Signal


IF THE SUB HAS AUTO SIGNAL SWITCH THIS OFF BUT TO BE HONEST IT SOUNDS LIKE YOU HAVE A SPLIT VOICE COIL.

Jun 20, 2008 | Sunfire True Sub Signature Subwoofer

7 Answers

Subwoofer "thumping" w. no audio feed


You need to check your ground connection. If there is a bad ground there will be feedback to the amp and it will just sit there and loop back with the Thump, Thump, Thump sound. I had to wire my amp's ground all the way back to the negative battery terminal. It was a pain but I have never had a problem since :)

Feb 12, 2008 | JBL SCS125A System

2 Answers

Thumping Subwoofer


Ive seen this problem in alot of audio setups in vehicles but most peeps dont know this is not a good thing and will cause damage to your woofers or amp. 99% of the time it turns out to be as you said that bad boy muting circuit. alot of these curcuits do use separate transitors or diodes as mute switches but most of them are directly from the Microproccessor. Only way to trouble shoot this is with a schematic and a good car stereo tech. Good luck

May 25, 2006 | Yamaha RX-V2200 Receiver

Not finding what you are looking for?
Jamo DMR 60 DVD Player/Receiver Logo

Related Topics:

297 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jamo Televison & Video Experts

Greg Cann
Greg Cann

Level 3 Expert

1114 Answers

The Knight
The Knight

Level 3 Expert

74106 Answers

Stan Skaggs
Stan Skaggs

Level 2 Expert

239 Answers

Are you a Jamo Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...