Question about Craftsman 42 in. Deck 19.5hp Lawn Tractor

1 Answer

Crafsman 19.5 opposed cylinders full throttle only

Starts fine, runs ok but only runs at full throttle. Linkage appears to be working ok. Will a sticking float cause this? Or a hole in float? Anyone else ever have this problem? Butterfly valve in carb appears to work ok.

Posted by on

  • Dwain Pippen May 11, 2010

    Sounds like a linkage problem on your opposed twin. Is you throttle cable working properly? I would check to see if your throttle is actually moving the linkage going to the carb. Neither a sticking float or hole in float would cause this problem. The fuel filter has nothing to do with this.

  • bilalinmd
    bilalinmd May 11, 2010

    What engine? Kohler Command or B&S V-Twin? Also, when was the fuel filter replaced? It is possible that your engine is generating enough vacuum to get past a fuel filter obstruction at full throttle, but is being choked off at low / part throttle.



    Bilal Hassan

    Clarksville, MD

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 61 Answers

Govrernor out adjustment or fly weights broken.

Posted on Sep 06, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1994 Chevy Camaro, 6 Cylinder, stalling problem


Try cleaning the throttle body and the idle speed control valve, they get full of sludge and this causes stalling. Use a product called CRC Throttle valve cleaner on both parts, DO NOT USE CARB CLEANER IT WILL RUIN THE PARTS.

Aug 18, 2016 | 1994 Chevrolet Camaro

1 Answer

How can I get full throttle out of 1978 115 hp evinrude


That is a wide open question. Has it ever run full throttle or is this a new install? Check linkage for full travel. If OK, could be wrong prop, clogged carb, blown cylinder. 1977 was a bad year for OMC pistons. some 78's could have the same problem.Lots more info needed.

Aug 20, 2015 | Boating

1 Answer

I can't get my Chevy sm 400 to rev past 2,400 rpm.


you didn't say if it starts and runs fine and idles fine. Check the throttle cable/linkage to make sure it has full free travel. Check the firing order and make sure all wires go to correct cylinder. Make sure you have good gas, no water in it etc. Contact the rebuilder for ideas, before you do damage.

Sep 28, 2014 | Cars & Trucks

1 Answer

No power


Did you check the throttle cable linkage to the carburetor? There is a retainer for the throttle cable near the carburetor. This will sometimes come loose and even though you move the throttle lever forward it may not be moving the throttle cable at the carburetor.

Mar 24, 2014 | Garden

1 Answer

Have 115 Hp mercury outboard motor missing at full throttle and on idle. At mid throttle it is running fine. Any Idea what the problem could be. Thanks, Milton


Have your spark plugs changed AND carbs cleaned and adjusted.
Usually that can also be caused by a seized advance system ( plate under the flywheel, commanded to turn with the throttle linkage... )

Aug 16, 2013 | Seloc Mercury Outboard Repair Manual, 1965...

1 Answer

Need help with cub cadet lt 1045 engine running erratic after a minute on full throttle Engine starts fine and idles fine. once you put it in full throttle after about a minute or five minutes it starts...


Anthony, this could be from the governer linkage which is intended for maintaining a specified top rotation per minute speed ( R.P.M ) is a possability im not sure of your specific adjustment procedure allthough most are a simple lossening of the linkage mounting to the shaft bolt while this bolt is loose you push the linkage to full throttle travel activation allowing the control linkage that was lossened to turn in its mount ( pivot) and keeping the threw the block mounting at full activation range ( travel ) in its farthest position re tighten the arms securing bolt,to secure it at its proper activation range ( at the pivoting point) I hope this helps if your unfamiliar with this type of governer control linkage, i would seek to locate a diagram on line that you can view to assist in your specific engine's linkage adjustment , and another possability is your carbuerator's High speed needle valve is to lean or to rich hope you analysis the problem Steve

Aug 01, 2010 | Cub Cadet Garden

1 Answer

What regulates fuel air mixture. my fuel rail


the oxygen sensors trim and richen the fuel air mixture and they will not always set a code in obd1 vehicles. could be a stopped up cat though if the exaust smells like rotten eggs

May 10, 2010 | 1988 Ford F 250

1 Answer

Only runs on full throttle


Are you saying full throttle, or full choke? if full throttle, you should be able to set the idle up. the idle screw will be the one when you give it gas, it will be the screw on you'r throttle linkage. If full choke, maybe the spark arrestor is plugged. You can remove it by removing the muffler.It would be between the muffler and cylinder head. You don't need this to run.I hope any thing I posted will help.

Jun 19, 2009 | Poulan 25cc 2-Cycle Gas Powered String...

2 Answers

Sputters & quits at proper RPM for engaging trans or mowing deck


If the choke has an adjustment point, then adjust the choke to a good overall working powerband. If it still doesn't act correctly, look for vacuum leaks. If it is an option, you may want to install a manually operated choke lever.

Nov 23, 2008 | Garden

2 Answers

Transmission won't engage


My Craftsman 24 hp twin 42in cut motor runs ok as well as the lawn mower. However will not move forward or backwards something is not connecting.

Sep 21, 2008 | Craftsman 24 Hp 48" Deck Yard Tractor

Not finding what you are looking for?
Craftsman 42 in. Deck 19.5hp Lawn Tractor Logo

Related Topics:

160 people viewed this question

Ask a Question

Usually answered in minutes!

Top Craftsman Garden Experts

Wade Mobley
Wade Mobley

Level 3 Expert

462 Answers

Dean Gruber

Level 2 Expert

110 Answers

Roland W VanLue
Roland W VanLue

Level 3 Expert

486 Answers

Are you a Craftsman Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...