Question about Lightning Audio Bolt B2.150.2 Car Audio Amplifier

1 Answer

Amp runs but then will just turn off and red light comes on

My lightning audio amp will run fine for a few minutes but then just shut off and the green light will turn off and red one goes on. If i take out the fuse and put it back in it will start working for a minutes again then turn off. Sometimes it will work for a while but in the end it always ends up turning off. Any ideas? i just got a 15'' kicker L7 and i also have a audio tek amp its a 2400 watt mono channel amp that i tried to hook up to my sub i hooked everything up and the light on my amp will turn green and then a few seconds later it turns red my sub makes no sound at all the light will go back and forth from green to red.... is it a bad amp? or do you think i did something wrong when i was wiring up my amp? i have no clue what is wrong

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 77 Answers

You may have fried the amp pre outs in the head deck, try the amps on another stereo

Posted on Jun 01, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a lightning audio amp a B4.320.4 and Protect Lght stays on


the amp probably got to hot and had a thermal shut down witch will have to be fixed by a professional.

Mar 06, 2010 | Lightning Audio Car Audio & Video

1 Answer

My amp wont even turn on or red light or nothing so what do i do


check ground cable, check fuse on amp, and check the fuse under the hood, on the positive cable should be about 12' from the battery, if all is well and theres no light, check the blue wire coming from your deck use a tester,if bad you can run one of your fuse box ,place a 12volt switch and hook it to the amp you should be good to go

Jul 09, 2009 | Lightning Audio B4.250.2 Car Amp

1 Answer

Amplifier keeps running overcurrent


sounds to me like you are overheating the amp, try down tuning the peak level of the amp, and also if there is anything around the amp clear it away, check if the fan is turning on, you may need to replace it,

May 20, 2009 | Sony XM-2150GSX Car Audio Amplifier

2 Answers

Jh202 amp works for a few minutes stops for a few minutes any ideas


Sounds like the amp is going into Protection Mode. Does yours have green LED light then RED LED on it? The green is power and the red is Protection. You will need to either change the OHMS wiring or Put A Fan on it to Keep it Cool Inside.

May 11, 2009 | MTX JackHammer JH202 Car Audio Amplifier

1 Answer

Amp won't turn on


disconnect audio inputs and outputs and see if one of those are causing it , if it still does it with all audio inputs and outputs disconnected then there is a problem with the power amp

Oct 08, 2008 | Lightning Audio B2.300.2 Car Audio...

2 Answers

Subwoofer problem


take a look at the amp is there a light on with the car running and stereo on? if no check the big black ground wire that connects to bare metal somewhere near the amp , also check the big red wire for 12 volts and the small wire for 12 volts let me know -jeff

Sep 12, 2008 | Lightning Audio B1.10.4 Car Subwoofer

1 Answer

Amp problem


Are you sure that the terminal isn't shorted to the case of the amp?

If it's not, the amp probably has a shorted output transistor.

If you want to repair it yourself, read through the following page. It explains the basics. Let me know if you have any questions.

Basic car amp repair primer

May 15, 2008 | Lightning Audio b2.250.1 Car Audio...

1 Answer

Red light


It sounds like the output transistors have failed. Disconnect everything from the amp except for the B+, ground and remote and turn the amp on. If it goes into protect, the amp is in need of repair. If you want to repair it yourself, email power acoustic for the schematic.

Oct 02, 2007 | Power Acoustik LT-980/2 Car Audio...

2 Answers

Overhaul light (red) stays on!


This is not a ovehaul light. It is called the protect indicator. It kicks in when the amp detects a fault on it's output. Disconnect the speaker / sub. Power up the amp and see if the light goes out. If it does you Sub is toast and needs to be replaced. If it stays on then the amp is done.

Jun 22, 2007 | Lightning Audio LA1.300.2 Car Audio...

1 Answer

Amp runs but then will just turn off and red light comes on


you need to get a fan for it because it does not come wit one and when you get the fan you have to hook it up from the inside by taking the torture tested/bolt sign off and look for a small white pug to attach it to

Dec 08, 2006 | Lightning Audio Bolt B2.150.2 Car Audio...

Not finding what you are looking for?
Lightning Audio Bolt B2.150.2 Car Audio Amplifier Logo

456 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lightning Audio Car Audio & Video Experts

80stech

Level 2 Expert

100 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Professor_V
Professor_V

Level 2 Expert

92 Answers

Are you a Lightning Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...