Question about Olympus FE-20 Digital Camera

1 Answer

Cant capture photos as the screen does not display image.

The camera is relatively new, i can swith it on perfectly and view previous photos.

however if i want to take a photo the screen does not display the given area i want to take. The lense comes out and the zoom in/out function perfectly. but the screen is blank so icant take a photo. if i take a photo it displays the photo as just a blank screen.

hope someone can help me out.

thanks

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Guru:

    An expert who has written 7 tips or uploaded 3 video tips

    Mentor:

    An expert who has written 3 tips or uploaded 2 video tips.

  • Expert
  • 93 Answers

May be issue is with Display LED..Please contact nearest service center...Check for the Warranty for free service
Thanks

Posted on May 31, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

SONY DSC-T1 CAMERA WHEN TURNED ON PREVIOS PICTURE SHOW UP FINE ON THE VIEW SCREEN BUT WHEN THE THE SELECT MODE SWITCH IS MOVED TO EITHER TAKE A NEW PICTURE OR TO MOVIE MODE THE VIEW SCREEN IS MOSTALLY...


Hi,

Based on the information you've provided it seems that the CCD Image Sensor of the Camera is affected. If the CCD Image Sensor is affected, the images captured may be discolored or with lines on it. Even if the CCD is affected, the previously captured images and icons of the Camera will display normally. You may try power resetting the Camera.

Turn off the camera.

Remove the battery pack.

Press and hold the power button for 30 seconds.

Allow the camera to remain without power for 60 seconds.

Reinsert the battery pack.

Turn on the camera.
Also try resetting the Camera back to factory default: The RESET button is located at the lower right side of the control button. To reset the camera just press the RESET button using a sharp-pointed object.
If the issue remains the same, then service may be required.

Thanks for using FixYa.

Mar 01, 2011 | Cameras

1 Answer

I have sony v1, unfortunately it was dropped, now the problem arises that you can see previous stored pics in lcd but when you want to capture the image, nothing is displayed and if you take the picture it...


Hi,

Based on the information you've provided it seems that the CCD Image Sensor of the Camera is affected which displays the live view of the Camera and the image which get captured. If the Image Sensor is affected, the previous views of the images and the icons will get displayed as normally, but the live view and the captured images will be distorted or blacked out. You may try power resetting to check if the issue can be resolved.

Performing a manual power reset

Turn off the camera.

Remove the battery pack.

Press and hold the power button for 30 seconds.

Allow the camera to remain without power for 60 seconds.

Reinsert the battery pack.

Turn on the camera.


If the issue persists, service may be required.


Thanks for contacting FixYa.

Feb 24, 2011 | Sony Cyber-Shot DSC-V1 Digital Camera

1 Answer

Camera not displaying images as seen through viewfinder. The screen is black. Image controls and info can be seen but the picture is just black. Takes photos which are also black; but previous photos...


A stuck shutter is another common failure mode for digital cameras, particularly for the SD1000. The symptoms of a stuck or "sticky" shutter are very similar to CCD image sensor failure. The camera may take black pictures (for shutter stuck closed), or the pictures may be very bright and overexposed, sometimes with lines, especially when taken outdoors (for shutter stuck open). To confirm a stuck shutter, put the camera in any mode other than "Auto", and turn the flash OFF (you don't want to blind yourself for the next step). Next look down the lens and take a picture. You should see a tiny flicker in the center of the lens as the shutter opens and closes. If no movement is seen, then you likely have a stuck shutter. If so, please see this link for further info and a simple fix that may help.


By the way, my wife's SD1000 also has this problem every once in a while. I easily fix it by using the following steps from the link: powering on the camera, opening and closing the battery door, and flicking the end of the lens barrel with my fingertip (or you can tap it with a pencil as discussed in the link).

Feb 06, 2011 | Canon PowerShot SD1000 Digital Camera

1 Answer

All of the icons are still visible, but otherwise, the screen of my t99 is showing up blank. The camera still takes pictures, but the photos are black and so is the display. Please help! No temperature...


Hi,

This may be due to the CCD Image Sensor failure in the Camera.
To confirm the issue, please check if the previously captured images are displaying normally. The previously captured images and icons will get displayed normally if the CCD image sensor issue is there in the Camera.
If this happens only with the live view, then try Initializing the Camera.

The Initialize option can be done only if the Menu of the Camera is accessible. To access Initialize select MENU-->SETTINGS-->MAIN SETTINGS-->INITIALIZE-->OK.

You may also try power resetting the camera. To power reset the Camera, remove the batteries from the Camera and then press and hold the POWER BUTTON of the Camera for 15 seconds and then reinsert the batteries after 1 minute and check if the Camera works normally.

If the issue is not resolved after resetting, service may be required.


Thanks for using FixYa.

Jan 18, 2011 | Sony DSCT99 Digital Camera

1 Answer

The images apprear purple on the screen, and dark in patches. New photo's taken, come out purple. But existing photo's appear on the screen as, normal.


Hi,

If the previously captured images are appearing fine in the Camera, then the issue is with the CCD Image Sensor unit only. Check if the display icons are appearing normally on the Camera screen.

Try power resetting and Factory resetting the Camera to check if the issue can be resolved:
Power reset:
Remove the batteries from the Camera.
Press and hold the POWER BUTTON of the Camera for 15 seconds.
Then, reinsert the batteries after 1 minute.
Factory reset;
To reset the Camera back to factory default, select the INITIALIZE Option from the Main Settings 1 Menu of the Camera to OK.

Home-->Settings-->Main Settings 1-->Initialize-->OK

Aug 06, 2010 | Sony Cyber-shot DSC-T100 Digital Camera

2 Answers

I cant see the person im taking a picture of on the LCD, its black.


This is due to the CCD Image Sensor failure in the Camera.
To confirm the issue, please check if the previously captured images are displaying normally. The previously captured images and icons will get displayed normally if the CCD issue is there in the Camera.
If this happens only with the live view, then try resetting the Camera.

The RESET button is located at the lower right side of the control button. To reset the camera, press the RESET button using a sharp-pointed object.

You may also try power resetting the camera. To power reset the Camera, remove the batteries from the Camera and then press and hold the POWER BUTTON of the Camera for 15 seconds and then reinsert the batteries after 1 minute and check if the Camera works normally.

If the issue is not resolved after resetting, service may be required.

Jul 24, 2010 | Sony Cyber-Shot DSC-T1 Digital Camera

1 Answer

When I turn the camera on, the image that I am shooting does not show on the LCD monitor. When I switch the camera mode to view images I have taken previously, they show up but the new images are not...


there are many point you may want to look at.

first, if the LCD does not display the picture you just capture, there is a possibility that the digital module of the device is broken and that it does not show or save the pictures you have recently captured.

if the pictures you recently captured can be viewed on a computer, there is a possibility that the connection between the LCD and the camera is loose. we canot say that tha issue is the LCD since it displays previoulsy captured image.

to work around the issue, it is best if you visit a local repair shop or a technician to have a look at the unit and have it repaired.

as per the cost, it will actually depend on the damage of the device. you may want to put a new camera as one of your options.

Aug 17, 2008 | Cameras

1 Answer

Black screen, not capturing photos


have the same problem...
it happened about a month ago and i pressed the display button and it worked, but now that doesn't work either!

Jul 22, 2008 | Canon PowerShot SD1000 Digital Camera

1 Answer

Canon A85 - Can't take Pics


This sounds like it might be a defective CCD imager. If so, Canon should fix this for you for free, including free shipping both ways. This is regardless of your camera's warranty status. Please check the following two links for more info:

http://camerarepair.blogspot.com/2007/11/canon-digital-cameras-showing-black.html

http://www.usa.canon.com/consumer/controller?act=PgComSmModDisplayAct&fcategoryid=225&modelid=13390&keycode=2112&id=29819

Applicable cameras include:
A40, A60, A70, A75, A80, A85, A95, A300, A310, S1 IS, S60, S200, S230, S330, S400, S410, S500, SD100, SD110, IXUS V2/300/400/430/500, IXY Digital 200a/300a/400/450/500

Jan 01, 2008 | Canon PowerShot A85 Digital Camera

1 Answer

Camera will take picture, but when viewed they are a strange colour.


This sounds like the first signs of CCD sensor malfunction. If this is correct it will get worse and pretty shortly you will have no image at all in capture mode. Have a new sensor installed and camera will work fine.( btw this is a common fault effecting all makes of digital cameras and v-cams ).

Aug 20, 2007 | Olympus FE-170 Digital Camera

Not finding what you are looking for?
Olympus FE-20 Digital Camera Logo

Related Topics:

253 people viewed this question

Ask a Question

Usually answered in minutes!

Top Olympus Cameras Experts

kakima

Level 3 Expert

102366 Answers

Willem.
Willem.

Level 2 Expert

359 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you an Olympus Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...