Dacor ECS130 Epicure Electric Single Oven Logo
Posted on May 29, 2009

Dacor range (oven)does not work

After using the self clean mode the oven will not work. It happened before and the tech said he hit a reset. I would like to know where it is. I took back off and front and did not see anything that looked like a reset button. Thanks

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  • Posted on Jun 14, 2009
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I have had the same problem for ten years. After a few years of the tech coming out everytime
I self cleaned, I had him show me how to reset, and he also gave me a new reset gizmo in
case that doesn't work. As for resetting, the top plate on top needs to come off and then you'll
see the gizmo with a dark red reset button that is attatched to the floor of that top compartment, which I leave unattatched for easier access. Push button down, of course turn off the electrical power to oven before doing all this. Works everytime.

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Hi,
Before you go working too hard to get you oven to go into the self clean mode....check out this tip...


http://www.fixya.com/support/r3969401-self_cleaning_oven_problem

heatman101

" Wish I had read this first. I never would have used the self cleaning option. Thanks for the info!! "
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What has happened is IF the temp gets to hot in the electronic controls area, an in line fuse/limit burns out and shuts down everything.
I have a DACOR tech sheet HERE

So what I think is happening is the in line fuse in the wiring harness could be blown. You won't know till you or someone checks.


If you need further help, reach me via phone at https://www.6ya.com/expert/dan_73bbd84fe1d95b61

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15
problem
8. door will not open.
9. oven will not heat after Self cleaning.
possible Cause
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time of day is not set due to power failure.
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remedy
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Important:
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Oven Failure Codes
Clock Display Cause
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befOre yOU Call fOr servICe
No maintenance, other than the Care anD CleanInG
InstruCtIons identified in this use & Care manual, should
be attempted by the owner/operator. all other maintenance and
service must be performed by a qualified appliance technician.
first, review the recommended checks listed in the preceding
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been installed properly and is being operated correctly. familiarize
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if the above checks have been completed and the problem has
not yet been remedied, call your local authorized dacoR®
service representative. your dealer can normally provide the name
and telephone number of the nearest service company.
prOdUCT maInTenanCe
If yOU need servICe...
dacoR® works diligently to ensure your satisfaction when
service is necessary. However, if you are not completely satisfied
with the service provided, contact the company that performed the
service and express why you are not pleased. Normally, they will
be willing and able to resolve the problem.
if the service agency is not able to respond effectively, call or
write the dacoR® customer Service department. the phone
number and address of this department are listed on the inside
front cover of this manual. Please include your telephone number
if you choose to write. we will then do our utmost to assure your
happiness and satisfaction.
Here is a snipet from www.dacor.com
You can view the manual there by enter ing your oven model number.
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