Question about MTX Audio TC6004 Multi-Channel Amp - 300W 4-Channel with "Smart Engage" 600 Watts Bridged ThunderE... Car Audio Amplifier

1 Answer

Car electronics kenwood amp power light turns off and on.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 93 Answers

Mke Sure The Wires R Tightly Grounded And The Use A Higher Fuse

Posted on Jun 14, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

On my kenwood KAC-8105D mono 1000watt amp, the blue light is out and my subs are not getting any power? What does this mean? what does the blue light mean??


Well normally a light near the controls and or where you put the wires for subs is the continuous power. There is a wire from the back of your stereo that need to be ran to the amp. It tells the amp when to turn on and off so it doesnt drain your battery.

Jun 06, 2011 | Kenwood KAC8105D Car Amp

1 Answer

My kenwood amp doesn't light up, fuse is good


your amplifier has a power supply problem,contact Eric @ Capital Audio & Electronics Repair 850-339-1130 email poppa1puff@aol.com

Feb 01, 2010 | Kenwood KAC-529S Car Audio Amplifier

1 Answer

Amp lights up, but no power to outputs.


channels mey be burned....does the amp smell like burnt electronics

Nov 07, 2009 | Kenwood KAC-8104D Car Audio Amplifier

1 Answer

My kenwood kac-929 1000w amplifier is not powering my sub


unless you are a technician do not mess with the amplifier.
it takes years of school to learn electronics. unless it is a blown fuse or something simple,you will never fix it.
i did kenwood warranty for 8 years and the amplifiers are difficult to repair.

Aug 19, 2009 | Visonik V117SX Car Audio Amplifier

1 Answer

Kenwood KAC-8103D Power Amplifier wont turn on


it sounds to me like its burnt.but with some amps the screws that hold it in place have to be screwed into the car chassisfor grounding. be careful not to srewe into hidden wires.

Apr 14, 2009 | Kenwood Car Audio & Video

1 Answer

Kenwood KAC 7202 amp not powering on


First you should test to be sure the amps main power feed is supplying 12+ volts to the amp. and that the other connections (head unit remote lead - input & output signal leads) are properly secured, if all is well then there maybe an internal issue with the amp.

It is not recommended to affix an amp directly to a speaker/kicker box, hence the vibration that may cause wire connections and/or internal electronic components to become loose or faulty.

As far as "should i take the amp apart and look at its guts"

NO, sorry but given the way you phrased your question I can assume that your electronic troubleshooting knowledge is not up to par, and that task would be a waste of your time.

Good luck
Aduz

Mar 26, 2009 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

My kenwood amp wont turn on


What kind of "Clips" did you put on? They may be causing too much resistance and preventing the amp from getting the current it needs. Double-check with a voltmeter that you are getting at least 12 volts at the amp power connections and make sure your ground lead is as short as possible and connected to solid metal of the vehicle's chassis.

Aug 10, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

My 800 watt kenwood


Sounds like you shorted out the main power wire somewhere and killed the amp. Is the amp on the fuse intact or blown? Do you have 12 volts at the amp? check you connections and see if it helps.

Jun 03, 2008 | Kenwood KAC-7201 Car Audio Amplifier

1 Answer

My kenwood kac7201 amp wont turn on but it has power to it


Recheck the voltage precisely like this:

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

Jan 22, 2008 | Kenwood KAC-7201 Car Audio Amplifier

1 Answer

Kenwood GE-3i


1 wire might be a remote turn on 4 the lost amp. connect a light tester to the ground wire turn on and off the pre amp and see if the light goes on and off 1 might also be a floating ground wire .

Oct 30, 2007 | Kenwood KSC-WA100 Car Subwoofer

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

44 people viewed this question

Ask a Question

Usually answered in minutes!

Top MTX Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

yadayada
yadayada

Level 3 Expert

76848 Answers

Are you a MTX Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...