Question about Cerwin Vega XL 600.1 Car Audio Amplifier

1 Answer

Protection light turn on with sound

When i connect the rca cables to the amp the protection light comes on whenever bass hits and it does it even when no speakers are connected

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers
Re: protection light turn on with sound

It's likely that the amp is defective but you should check the shield ground of the RCA signal cables before sending the amp off for repair.


Disconnect the RCA cables from the amp.


With your multimeter set to ohms, measure the resistance from the outer shield of the RCA cable to chassis ground. If it's more than a few ohms, that could be causing your problem.


If this is higher than a few ohms, short the meter's leads together to make sure the meter will go down to 0 ohms.


To check the shield ground of the head unit (assuming that the head unit is driving the amp directly), disconnect the RCA cables from the head unit and measure the resistance from the RCA output shield to the case of the head unit. It should essentially read 0 ohms.



Posted on Oct 22, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

2 Answers

The red protect light is coming on

It is possible that your amp is going over the threshold limit of draining current to give out the protect signal. What could be done is to first checkout if your speakers are loading the amplifier, check the rating of the speakers and the impedance, must not be too low.below 2 ohms. Now check the source signal if this is bringing in any transcient signals to power out the outputs particularily high/low freq. So decrease off your bass and treble to mid position and test again. see if there is any improvement, if so there could be a filter problem with your set. Connect an external source and see if the amp powers better , in such case check for fault in cables, input lines and ground with in the set. Repeat this and check. Hope this helps you out. Good day

Jul 19, 2010 | Verge VGA285 Car Audio Amplifier

2 Answers


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty . Send to Rockford Fosgate for repair .A thumbs up would be greatly appreciated if this answer is helpful to you. protect-zb4bomd1rt4qms0dqd12kkt2-3-0.jpg

Jan 29, 2010 | Rockford Fosgate Power 1001BD Car Audio...

1 Answer

My infinity reference 7540a amp cuts in and out with heavy bass when the ''loud'' feature is on. I redid my ground, remote wire, shortened my power cable, and double checked all speaker connections. I dont...

sounds like ur gains are set to high and is going into protect mode

also what ive seen happen before is the speakers (if mounted in metal shelf or door and arnt bolted down correctly can flex under bass notes and flex the speaker that much the termanls short onto the metal and amp hits protect mode
(rare but worth a look if you think u have elimanted most other things Had a dude come to me when i was working in sydney with this problem )

also could be things like clipping protection , overheat protection ,amp drawing to much current from the alternator

do your lights dim when you hit the bass notes ?

get back to me and im sure we could solve this problem

Jan 22, 2010 | Infinity Reference 7541a Car Audio...

2 Answers

Protection light comes on

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Dou .A thumbs up would be greatly appreciated if this answer is helpful to you. protection-light-comes-lv2kkrmxrai4iihdvw4m3np2-2-0.jpg

Jun 14, 2009 | Nitro BMW-482 Car Audio Amplifier

1 Answer

Unwanted bass coming out of my subs

there has to be sumthn hooked up wrong bc i have had same problem with my 12' subs but it was simply a matter of my rca jacks but sense you have checked them try rewiring the speakers if that does not work then your rca module may be burned out within the amp..iso then check the amp by taking the cover off and making sure nuthn is burned on the inside.or if any wires are loose or touching.

Feb 24, 2009 | Kenwood eXcelon KAC-X812D Car Audio...

1 Answer

No sound no protection light no obvious problem...

there is a wiring issue in your truck and i would get rid of the preamp

Dec 12, 2008 | Rockford Fosgate T10001 bd Car Audio...

2 Answers

Bass sounds flat when volume is increased

probably your power is too short, increase your gauge wire, and your ground wire of the amplifier has to be shortly as possible, and the positive has to be enough to support peak power, you can also put a big capacitor on the positive wire to give some more power while the bass peak.

Apr 26, 2008 | Earthquake Sound PH-D2 Car Audio Amplifier

1 Answer

Amp went into protect, but front speakers sound distorted too

If the amp still goes into protect mode, the easiest thing to do is disconnect the RCA cables from the amp and see if still goes into protect mode (after turning off/on). If it does, the issue lies in the amp or the wiring to/from the amp (most likely case). Check to make sure no speaker wires came loose and touched +12V or ground (car body). From the sound of it, my guess is something internal to the amp died and will need repair.

Mar 22, 2008 | Car Amplifiers

1 Answer

Protection Light Is Coming On

You say the protection mode only occurs when you plug the RCA's in. Does it have to be both RCAs or just one?

The other end of the RCA cable is plugged into the HU?

It possible the RCAs have too much DC voltage on them, causing the amp to go into protection.

Is there a short in the RCA cable?

I would definitely check out the RCA connection at the back of the HU, as it sounds like there could be other issues there. Make sure the RCA connectors aren't touching any other metal (especially +12V).

Mar 14, 2008 | Car Amplifiers

2 Answers

Amp in protection mode

Disconnect all speaker wires and signal cables from the amp. If it powers up normally (doesn't go into protection), the wiring needs to be checked. If it still shuts down, the amp likely has blown output transistors.

Nov 11, 2007 | AudioBahn A4401Q Car Audio Amplifier

Not finding what you are looking for?
Cerwin Vega XL 600.1 Car Audio Amplifier Logo

Related Topics:

117 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cerwin Vega Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Cerwin Vega Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides