Question about Kicker (ZX750.1) Car Audio Amplifier

2 Answers

Let our Experts solve your "My amp lights up like normal then protection light red comes on and turns the amp off resets and tries again. What would be my course of action

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 15,935 Answers

Disconnect all wires (including RCAs)
reconnect positive, ground, and remote.
Turn amplifier (car) on.
If it goes into protect mode again - there is an internal fault that requires professional repair.
If the amplifier idles as normal - turn off the car. Plug in RCAs & re-try
Failure? - replace RCAs as they may be pinched or faulty.

Lastly if all connections are made and amplifier idles without going into protection - you need to concentrate on your load (subwoofers).
Be sure they are wired properly into a resistance that amplifier is rated.
The lowest impedence that amplifier is rated is 2ohm.
That is possible with (2) 4 ohm subwoofers wired in parallel....
(4) 8 ohm subwoofers wires in parallel...
(1) Quad 1 ohm subwoofer...
or (1) Dual 4 ohm voicecoil subwoofer.

Any other combination will result in an impedence too low for your amplifier.

Next:
Using an OhmMeter (Digital multimeter set to Ohms 20) test each voicecoil against its advertised resistance. It should be CLOSE +/- .5 Ohms.

Any other reading means the voicecoil is blown.


Thanks for using FixYa - a FixYa rating is appreciated for answering your FREE question.

Posted on May 27, 2009

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 115 Answers

Is it hooked to any speakers, crossovers etc?
Is it bi-amp ed? What inputs are you using (RCA or Hi powered)?

My guess is it is going into protection mode.
If it is hooked up.
Try it w/ the 12v + and - only.

You MUST have a good Ground. As good as the 12v+. Make sure the ground is no longer then 18 inches. and the power is at least 11.5 Volts.

On the inputs tier is + - and 1 in the middle.
Run a wire from the small terminal between the + and - power terminals. You want to connect the 12v+ to the accessory terminal on the amp.
+------0 +
You would be connecting the two terminals that are right next to each other with a piece of copper wire.

DO NOT CONNECT THE -negative terminal to the middle terminal. OR let the wire from the middle terminal touch the -negative terminal.

Hook it up with the battery not connected

Posted on May 27, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a kicker 500.2 red protection light is on and red light on top of amp flashes every couple seconds. Have checked all connections and other amp in truck works good. I bought two of these amps and...


Disconnect all the wires except the three main power wires, ground, 12v battery and remote. Now, turn on your radio, if the protect light is still on then there's an internal short in the amp. If the light turns green, then there's a short in either the auxiliary cables or the speaker outs. If it turns green, then troubleshoot the other wires that plug into the amp by connecting them one at a time until the protect light comes on, which will tell you that there's a problem with that speaker/aux wire.

Jul 25, 2011 | Kicker KX500.2 Car Audio Amplifier

2 Answers

The red protect light is coming on


It is possible that your amp is going over the threshold limit of draining current to give out the protect signal. What could be done is to first checkout if your speakers are loading the amplifier, check the rating of the speakers and the impedance, must not be too low.below 2 ohms. Now check the source signal if this is bringing in any transcient signals to power out the outputs particularily high/low freq. So decrease off your bass and treble to mid position and test again. see if there is any improvement, if so there could be a filter problem with your set. Connect an external source and see if the amp powers better , in such case check for fault in cables, input lines and ground with in the set. Repeat this and check. Hope this helps you out. Good day

Jul 19, 2010 | Verge VGA285 Car Audio Amplifier

3 Answers

The saftey red light keeps coming on


It means that the subwoofer is blown. The red light is called the Protect light. Disconnect the speaker wire from the amp and then turn the amp on and see if the red light goes away. But if as soon as you hook the speaker wires back to the amp and the red light turns on that DEFINATELY means the sub is blown.

Apr 04, 2010 | Cadence TXA 1000D High Power Mono...

2 Answers

Ok so my Nitro BMW - 481 2000w amp was working and then i came back the next day and the red protect light was on its been working for weeks but now it has the red light.


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. D .A thumbs up would be greatly appreciated if this answer is helpful to you. ok-nitro-bmw-481-2000w-amp-working-lv2kkrmxrai4iihdvw4m3np2-2-0.jpg http://www.nitrobmw.com/

Mar 17, 2010 | Nitro BMW-481 Car Audio Amplifier

2 Answers

I have a Lanzar Vibe 235 amp. the green power light is not coming on, but the red "protect" light is. how do i solve this problem??


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Time to purchase an old school Lanzar Opti Drive. Any of them. The 50 will kill some 12" subs .A thumbs up would be greatly appreciated if this answer is helpful to you. lanzar-vibe-235-amp-green-power-shonxoarcym4awy4zl1imx4o-2-0.jpg Lanzar

Mar 11, 2010 | Lanzar Vibe 235 Car Audio Amplifier

2 Answers

I blew a pair of speakers on my 6000 watt lanzar amp the red light protection is on on the amp what does this mean


I believe it means your fuse has blown on the amp, and the light is telling you its not safe to operate the amp because it has no short protection. Check the fuse and replace if necesary, disconnect the battery for a time to reset and try again.

Feb 17, 2010 | Car Audio & Video

1 Answer

What does it mean when the red protection light illuminates


Hi the protection light comes on when there is a problem within the amps. circuitry. Generally speaking the protection light normally comes on when powered up while the amp checks all of its voltage rails so that they all lie within a specific tolerance, when all have been verified to be in spec. then the protect light goes out & the power light comes on. If the protect light stays on then a fault exists within it's circuitry. Cheers, acbva.

Nov 14, 2009 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

1 Answer

I have an older red sony xplod 500w 4ch amp. the power/protection light is glowing red. what does that mean and how do i fix it? I have no sound.


The protection light comes on if the amp overheats or if the speaker outputs are shorted.

Turn everything off and check all of your speaker wires for shorts. When you locate and repair the short, the protection light should go out and your amp will work normally again.

Hope this helps!

Mar 26, 2009 | Car Audio & Video

1 Answer

My sony xplod 1000w xm-1652z doesnt work anymore


First off, according to the manual, the protect light should be green. That's normal operation. If it is red, that's a problem.

If it does go red, disconnect all of the wiring to the amp except the +12V and ground. Short the remote connection to the +12V to force the amp on. If the protect light still lights red, the issue is inside the amp and will need repair. If the issue goes away, try reconnecting one wire at a time until the protect light goes red again.

Mar 23, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

283 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kicker Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

yadayada
yadayada

Level 3 Expert

76691 Answers

Are you a Kicker Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...