Question about Alpine PDX-1.600 Car Audio Amplifier

1 Answer

Alpine pdx 1.000 keeps cutting out

I have a mono alpine pdx 1.600, When is on low, its good, But when you turn up the volume, and keep it high, it will cut out after a a couble seconds, The sub can hold 500 watts, and the amp is capable of seding 600 watts. The mono is hooked up to a capacitor whitch is hooked up to a four channel amp, Could the ground be the problem? thank you chuck I have a mono alpine pdx 1.1000, When is on low, its good, But when you turn up the volume, and keep it high, it will cut out after a a couble seconds, The sub is alpine type X 1000w rms, and the amp is capable of seding 1000 watts.what is the problem?thanks

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 149 Answers

You are going to want to make sure all your power wires and grounds are 4 gauge as well as the wire leads to and from the capacitor-4 gauge also. make sure you have a very good ground - the power wire from the battery should hit a distribution block-from the dist. block a 4 gauge should go to the capacitor another 4 gauge to the mono amp and another to the 4 channel amp -every component should have a good solid ground even if you have to bust out a grinder and a drill and some self tapping sheet metal screws and go nuts on it- see if that helps you

Posted on May 27, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Amp will play at low volumn but not when turned up


probably.
almost sounds like your speakers are worn out, and when you turn the volume up, they clip n no sound comes out.

Jul 31, 2010 | Alpine PDX-4.100 Car Audio Amplifier

1 Answer

My alpine clips out at high volume I took the subs out and hooked um up outside of the car and it was working fine. do I just have a short in a ire or is this the pdx 1000 safe mode. How can I get it fixed


Go to rockfordfosgate.com they have a woolfer wiring wizard that can help you make sure your amp is under the correct ohm load, if your woolfers are wiring up on a 1 ohm stable load the amp will overheat and go into protection mode and cut out.. Need the woolfers on a 2 or 4 ohm stable load, and the amp should run fine with a capacitor, and some good 0 to 2 guage cable, plus a good battery and alternator to feed it

Oct 09, 2009 | Alpine PDX-1.1000 1000W x 1 Car Amplifier...

1 Answer

I have 2 6x9 speakers up front 4 6 1/2 3-ways


Hello rjmiller4039,

Although amps with 5 channels are pretty rare, you can get one. Alpine, Boston Acoustics, Infinity, JL audio, MTX, and Polk all have 5-channels ranging in price from around $350 up to around $1,000. The Alpine PDX-5 will output 75X4 watts RMS for the front and rear stereo channels and 300 watts to the mono sub channel. It is priced at $599.99 at Crutchfield.

Hope this helps.


Sep 18, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Pdx 4.150 amp suddenly cuts all sound from the amp when music is played loud/normal for me, unknown reason it just started doing it, I didnt change or add anything to cause this issue. All power and ground...


ALL THAT IS NOT YOUR PROBLEM CHECK ALL YOU POWER SOURCE AND IF ALL OK CHECK TO SEE IF ANY SPEAKER IS BAD OR GROUNDING OUT'' THE CAN COURSE THAT TO HAPPEN AND CHECK MAKE SURE RCA IS NOT PINCH ANY WHERE

Aug 05, 2009 | Alpine PDX-4.150 150W x 4 Car Amplifier...

1 Answer

Alpine PDX1.600 amp cuts off


Make sure there's no missmatched impedance. If your sub running 2 ohms then your amp has to be 2 ohms stable. Does the amp blow fuses or get really hot? If it does it can be a fire hazard and I would recommend taking it out of your car. It could be that you don't have sufficient grounding. The grounding needs to be very close to the amp and the paint needs to be thoroughly scratched off. Otherwise could be a blown transistor within the amplifier, you can check this by opening up the amp, running a multimeter and testing the transistors for resistance.

Aug 04, 2009 | Alpine PDX-1.600 Car Audio Amplifier

1 Answer

Alpine pdx 1.600keeps cutting out


you need more batt, more amps, try new batt, capacitors are paperweights, spend on good batt.

May 14, 2009 | Alpine PDX-1.600 Car Audio Amplifier

1 Answer

Alpine PDX 1.1000 low power output - sub not loud


system not configurate properly go to a pro and let them do for you you have good equipment just need to put together rite.for wht you have you can get better sound than that,,good luck

Mar 30, 2009 | Alpine PDX-1.1000 1000W x 1 Car Amplifier...

1 Answer

My subwoofer stops when volume is increased


have u check the radio out do u have an eq

May 19, 2008 | Kicker CVR12 Car Subwoofer

2 Answers

PDX 4.100 In Protect Mode..


According to the manual, the issue could be:
  • Internal issue with the amp circuitry.
  • A short on the speaker output(s).
  • Power source voltage is too high (aka above 14.5V).
  • Overheating.
The easiest thing to do is to try removing the connections to the speakers at the amp and see if the issue disappears after each set has been disconnected. Keep removing wires until both LEDs stay blue.

Mar 15, 2008 | Alpine PDX-4.100 Car Audio Amplifier

1 Answer

Alpine PDX-4.100 3ch operation


use channel 1 and 2 as normal, use the positive from channel 3 and the negative for channel 4 as mono 1ch, your bridged output on the mono chan should be around 200watts at 4ohms.

Nov 25, 2007 | Alpine PDX-4.100 Car Audio Amplifier

Not finding what you are looking for?
Alpine PDX-1.600 Car Audio Amplifier Logo

592 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4874 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Jaime Hernandez

Level 3 Expert

2318 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...