Question about Rockford Fosgate P3001 Car Audio Amplifier

1 Answer

Rockford P3001 amp not working

I replaced both fuses for my Rockford P3001 amp but it still does not work. The light does not come on, what is wrong?

Posted by on

  • sweet_like_j May 27, 2009

    Thanks Hoyzee, I hope it ain't blown.

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 149 Answers

Peel the cover completely off the amp and give it some power- if the amp is blown there will be a tiny light lit up on the circiut board that quite simply says "SHORT"-If its blown then theres nothing you can do unless you are a badass of course- but if the amp is dear to you and you want to spend a little money on it to get it up and running again- go to rockfords website and get into the forums and ask the question-where do i get my fosgate fixed and it will pull up some mumbo jumbo but it tells you about a place called LANDIS TECHNICAL that bought up all the parts to their amps and is in the business of restoring the amplifiers to their factory specs and even sends you a new power certificate to go with your new and improved amp.hope that helps you-

Posted on May 27, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where's the fuse located in a Fosgate p300-1 amp?


It is just to the right on the rear of the amp next to the 12 V + - RTO +

Here is a link to a picture:

http://www.crutchfield.com/S-mj0Klw5sfLm/p_575P3001/Rockford-Fosgate-Punch-P3001.html

Feb 14, 2012 | Rockford Fosgate Car Audio & Video

2 Answers

I was using bridge on a Rockford P300 and blew my cheap speakers but now my bridge doesnt work. Bought new speakers and want to run in bridge mode is there a fuse inside maybe or did I blow it up?


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Your amp is clipping.
No internal fuses. Your mosfets are toast. A thumbs up would be greatly appreciated if this answer is helpful to you. using-bridge-rockford-p300-blew-peeu4x5nsxvd53n2rwetiqa4-3-0.jpg

Apr 07, 2011 | Rockford Fosgate P3001 Car Audio Amplifier

1 Answer

P3001 problem


if amp is mounted to back of the box try and move to in front of box near subs or port. the air movement of the sub will help keep the amp cooled. or you can orer some 12v cooling fans and take back plate of the amp and cool it that way. or you can buy higher quality audio, your choice

Feb 20, 2010 | Rockford Fosgate P3001 Car Audio Amplifier

1 Answer

No sound


Interchange with a known working amp, if work check your wiring and speakers.

Aug 23, 2009 | Rockford Fosgate Punch 300S Car Audio...

1 Answer

My amp wont give me any power


all the p series amps were discontinued for similar problems, they have a newer model out now. they have very weak boards internally and failed faster when mounted to the sub enclosure or very close to it from subsonic vibration. i would guess the amp is toasted.

Dec 17, 2008 | Rockford Fosgate P3001 Car Audio Amplifier

1 Answer

No power


You need to confirm that you have voltage on the B+ and remote terminals and that you have a good ground. Do you have a multimeter?

Apr 12, 2008 | Rockford Fosgate P3001 Car Audio Amplifier

1 Answer

P3001 amp may be fried


Check this out: http://www.techlore.com/article/14696/

Aug 06, 2006 | Rockford Fosgate P3001 Car Audio Amplifier

Not finding what you are looking for?
Rockford Fosgate P3001 Car Audio Amplifier Logo

Related Topics:

419 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Professor_V
Professor_V

Level 2 Expert

92 Answers

Robert Rankin

Level 2 Expert

341 Answers

Are you a Rockford Fosgate Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...