Question about Car Audio & Video

1 Answer

Unit displays radio tuning but does not lock on

Have installed a sony CDX-4800x can't seem to get radio to work, display works ok, can you help?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 26 Answers

Is sounds like the antenna cable is not plugged into the head unit. Pull it out and check.

Posted on Jun 07, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No tp for sony cdx-c5000r


hi shawn, try deselecting the TA feature of your unit and then try tuning for stations. before doing this i assume your antenna is in good working condition. if this does not solve your problem, then "reset" the unit and retry tuning for radio stations. reset switch will be found on main unit behind the face. cheers.

Jun 10, 2012 | Sony Car Audio & Video

1 Answer

I have power going to the unit yet there is no display,a sony cdx-gt220,i know i have power because it is loading and ejecting cds yet no display.please help,its doing my nut in!!!!


I have a Sony CDX GT 530U. I had a problem with no display and I thought no power period. I did not try to install a CD, so maybe I did have power to the CD motor but no display. This was frustrating because I could get the old factory Nissan radio to power up and work so I thought I had a dead Sony unit. After a lot of monkeying around, I discovered I had blown a fuse while installing the unit (you should disconnect the negative terminal of the battery when installing the radio... which I thought I skip, that was a no no.). I had checked the auto fuses, those cheap little plastic fuses behind a panel below the stearing column inside most cars, at least all the fuses I thought went to the car stereo. Turns out I missed one that was labeled "Batt" or something like that, which was the constant power wire to the car stereo. There was another fuse for the Accessory power to the car stereo (the main juice went the key is tuned to ACC or Start position). Turns out the Sony unit display runs off the constant power, or at least the unit on/off button runs off the constant power wire, so even though the ACC power wire was live, the Constant power wire had a blown fuse and the unit would not turn on. Check all your fuses inside the car, I bet that's your problem. Constant power on my Nissan Sentra was a 7.5A fuse, while the ACC power ran off a 15A fuse, but your vehicle may vary. Good luck.

Jul 16, 2009 | Sony Xplod Car Audio CDX-F7810 - CD/MP3...

1 Answer

Operation buttons and sub display are failing


go to ebay and type in the model number of the unit and it will bring up some part that can fix the problem. i had the same problem and i just ordered the part. its actually a ribbon connector. im sure you just open up the radio and take the old one out and connect the new one up. this seems to be a common problem with this unit. the ribbon just starts to tear, and as it tears, you will start to lose functions on the stereo. i happen to like this stereo, so i decided to repair it. good luck with yours.
david

May 31, 2009 | Sony CDX-M630 CD Player

1 Answer

Sony cdx-gt200 no power


its knackered either send it in for repair or buy another amp at wholesale cost here:
www.godspeedaudioheaven.com

Dec 09, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Just installed cd player the radio work but not the cd it say on display E-04 what does it mean ?


connect solid blue wire in harness to the blue/white wirh and problem is over

Nov 05, 2008 | Sony CDX-GT300 CD Player

1 Answer

Storing channels and time display


* Connect Yellow wire to continues power ( it is back-up power to memory circuit)
* Connect Red wire to switched power
You can download User Manual and Installation Guide for CDX-S2000 from Sony Support for more information.

Oct 23, 2008 | Sony CDX-S2000 CD Player

1 Answer

No Display


il buy it 4 a 5a as it is now scrap

Dec 16, 2007 | Sony CDX-M800 CD Player

1 Answer

No display on Sony CDX-M800


JUST PRESS THE RESET BUTTON
IF THIS DOSNT WORK CHECK THAT THE PLUG WIRES ARE SECURE I HAD THIS PROBLEM LAST YEAR AND IT TURNED OUT THAT ID UNPLUGGED THE STEREO BUT AS I RECONNECTED IT THE PIN HAD PUSHED THE CONNECTOR AWAY SO SOMETIMES IT WORKED OTHER TIMES IT DIDNT WHEN I HIT A BUMP IT WOULD MAKE THE CONNECTION BREAK

Nov 08, 2007 | Sony CDX-M800 CD Player

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

51 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4874 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...