Question about Sony Xplod 500W Bridgeable Multichannel Amplifier

1 Answer

The power protection kicks in when I turn up my radio volume

I have just installed a Sony Xplode amp and it is working until I turn up the volume then the power protection kicks in and cuts out the amp. What are the possible causes for this?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 15 Answers

Ground wire connection or possibly amp is turned up to high when an amp is turned up all the way it starts pushin dc voltage also it could burn out the internal battery check all connections and settings after that make sure subs arent begining to blow a sub that starts to blow kicks of the amp hope this helps

Posted on May 22, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Amp slow to kick bass in.


it sounds like you havnt got the memory live conected on your hea duit or it is conected to an ignition live this is no good it needs to be conected to a permenent live to ensure the memory has power at all ties of it coulb be that the amp needs adjusting for low volume use
to set up a sub you turn up the volume to the required level then adjust the amp acordingly hope this helps ben

Oct 11, 2009 | Alpine MRP-M650 Car Audio Amplifier

1 Answer

It turns off when in high volume


a few things...your speakers may not be a perfect match for the unit. at high volume where the radio starts to distort there is an internal protection circuit that protects the radio...it's kicking in.
solution.  Buy a power amp and take the load off of the radio.

Apr 01, 2009 | Kenwood KDC-MP4032 CD Player

1 Answer

Sony xplode cd player sub problems


Switch your blue wires around.

You have put the remote antenna wire to the remote turn on of the amplifier. The radio cuts off the power to the "power antenna" when you switch to a different mode... so your amplifier is now losing the turn on signal it requires to stay on.

Simple 2 minute fix.

Thanks for using FixYa - a FixYa rating is appreciated!!

Feb 19, 2009 | Sony XPlod CD Player w/MP3 Playback...

1 Answer

Music stops 30 seconds into the song


does the music stop? or do the sub(s) kick out. your amp might be to big for the sub rating , try turning down the gain

Jan 19, 2009 | Sony Xplode P5 Turbo Subwoofers Car...

2 Answers

Sony xplode 1000w amp has green light puts out no power to subs


may haveto turn sub on through the stereo itself if rca cables are good.

Jan 08, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Speakers cut off when bass goes up...


sounds like you hava a load problem.if your'e running your woofers at 1ohm,make shure your amp is 1ohm stable.....

Jul 03, 2008 | Car Audio & Video

2 Answers

Sony xplode 1000 watt amp


Make sure you don't have a short circuit somewhere. Make sure the wiring is all intact.

Also look at this link:

http://www.fixya.com/support/t132850-sony_xplod_1000_watt_car_amp_quit

Mike

Nov 07, 2007 | Sony Xplod XM-1652Z Car Audio Amplifier

6 Answers

Speakers cut off when bass goes up...


it might be that your wires from your amp to your subs are too thin. since they were relatively new the first three months, they were probably undamaged, but after pushing them too much, they probably have broken wires, and can't get enough power to the subs when turned up, i suggest getting thicker wires before investing in a capacitor, it could save you money.

Mar 21, 2007 | Sony Xplod 1100 Watt Max 10" Subwoofer,...

Not finding what you are looking for?
Sony Xplod 500W Bridgeable Multichannel Amplifier Logo

347 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5113 Answers

The Knight
The Knight

Level 3 Expert

74185 Answers

Are you a Sony Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...