Question about Vacuums

1 Answer

Hoover telios full bag indidcator

Loss of suction, hoover says the bag is full, but it is not??? filters and hose seem to be clear?

Posted by on

  • blackcorries Jan 02, 2014

    ps, its a bagged cylinder.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 55 Answers

Could be a hole or torn bag

Posted on Jan 02, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

reddevil6
  • 1673 Answers

SOURCE: Sudden loss of suction.

Check the inlet down by the brush roll to see if it is clogged. Also check the belt to be sure it is ok. Is there suction at the hose? If not then it is still clogged.

Posted on Feb 13, 2008

reddevil6
  • 1673 Answers

SOURCE: loss of suction and bag full

Sounds like you still have a clog, either in the hose, drop something down it to see if it comes out the other side. The other place is the dirt inlet by the brush roll. Take off either the top cover or the bottom plate and you can check it out.

Posted on Feb 19, 2008

  • 71 Answers

SOURCE: poor suction (new bag, clean filter, clear hose)

check the impeller on the moter it may be missing a fin or two (question does it make any unusual noise or vibration ?)

Posted on May 02, 2009

  • 4088 Answers

SOURCE: brush spin,good suction at hose, no suction at

Air passage from back of brush head, through the joint, and up to bag, may be blocked.

Posted on Jul 12, 2009

  • 8 Answers

SOURCE: my eureka smartvac 4870 has no suction at hose or

your eureka has no suction kuz the vacum hose needs cleaning

Posted on Nov 29, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Doesn't seem to have much suction when I put my hand under the head. Have cleaned both the filter and the mesh screen


Check the suction from the hose for rge tools see if there is suction

also check to see if there is a obstruction on the short hose to the nozzle

May 16, 2016 | Hoover U5140-900 Widepath Bagged Upright...

1 Answer

Why does metallic cover keep blowing off when operating?


Hey there! It sounds like your vacuum may be clogged causing it to redirect the air flow which may be causing the cover to blow off. To check the vacuum for clogs disconnect the hose from the cleaner and the wand, use a broom stick to gently loosen and remove any clogs from hose. Also check the wand and the nozzle for blockages. If it is the filter cover that is coming off and there are no clogs, the tabs on the filter cover may be broken. Contact a local service center for information on replacing the filter cover. Reference part 59135033. Or you may contact Hoover Customer Service at 1-800-944-9200. Hope this helps!

Aug 27, 2014 | Hoover S3330 / S3332 Straight Suction...

1 Answer

Miele Vacuum Cat and Dog Upright S7260 Loss of Suction


could be a couple things first make sure the hose is clear check real good the other is make sure your bag is good and tight and clean and make sure you have no holes or tears in the hose

Mar 07, 2014 | Miele Vacuums

1 Answer

The hose constantly falls out of the metal tube. Is there any remedy other than taping or glueing it in place?


the complete hose can be bought here for 20.00

http://www.bizrate.com/vacuum-accessories/oid1370892338.html

Feb 16, 2011 | Hoover S3330 / S3332 Straight Suction...

1 Answer

Telios 2000


This is normally caused by restricted airflow, causing the heat sensor switch to trip. Please make sure the hose and bag are not clogged, verifying you have good suction and airflow to the hose end when you initially turn it on. The heat sensor switch is intended to shut off the motor if sufficient cooling air is not present.

Mar 09, 2010 | Hoover Vacuums

1 Answer

Loss of suction and very noisy


The most obvious and first fix would be to clean the filter. The noise is the tip-off. If your vacuum is noisier than usual the most common issue is a clogged filter, hose or bag. Check all of these. UNPLUGGED, use a straightened wire coat hanger to fish out any hoses and entry from the bag or bagless housing.

Foriegn obstruction is the main cause of noise coupled with loss of suction.

Dec 04, 2009 | Hoover Encore Supreme Energy U4293-930...

1 Answer

Poor suction (new bag, clean filter, clear hose)


check the impeller on the moter it may be missing a fin or two (question does it make any unusual noise or vibration ?)

May 01, 2009 | Vacuums

1 Answer

The hoover keeps switching on and off automatically.


Sounds to me like there is either a loose wiring in the pedal or mains power cord. Check that the plug is secure. Check both filters though - one behind the bag (usually square and slides out) as well as the main exhaust filter at the back between the power on and cord rewind button. I used to own many Telios models but they are known to have cheap shearing cords which can only be replaced by a Hoover repairer. Sometimes the On pedal can be affected as well particularly if it has been stamped on heavily.
Dont forget to rate, ty.

Mar 28, 2009 | Hoover S3330 / S3332 Straight Suction...

1 Answer

My Hoover is picking dust , very poorly


The Telios has a bad design on the handle and it sounds like something has definately got stuck. Unfortunately the nature of the cheap European design means the handle can only be removed by someone who owns a vice in their garage without breaking the removal points. Alternatively find a long bamboo stick or pole to put inside the hose mount which connects normally from the main bin of the Telios (not the other way around up the handle) which has no sharp edges and push up and down vigourously to dislodge any clogged dirt which may have inadverntely got stuck either by the handle or in the hose itself.

Another thing to do is to check the suction from the Telios itself by removing the hose. If there is suction coming from the main dirt bag/bin door with the hose removed then there is no problem other than a clogged hose and handle. Hoover updated the handle and hose in 1999 and spares can be found by looking on Ebay.co.uk for cheaper prices.

Aug 12, 2007 | Hoover S3330 / S3332 Straight Suction...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

49 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18387 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...