Question about Archos AV 500 Digital Media Player

6 Answers

MASSIVE problems, need urgent help!

Hey guys

I bought my AV500 3months ago, brand new, in the box.

Just recently it wasnt being recognised by any computer i would plug it into. It then saw it, but i couldnt access it.

We hadnt gotten around to sorting that problem, but then- literally JUST now I went to charge it up (as it turned off on me today when it shouldnt have and wouldnt turn on again)

Its been skipping a bit, which i over looked.

But when Ive got, say one song on from that bands album, within a playlist, it would then start playing all the songs in that album, instead of continuing on to playing the different songs i'd entered into the playlist.

So thats been happening a lot which has annoyed me

But it turned off today as i said, when it wasnt flat.

So ive just now gone to charge it, and as soon as ive plugged it in the screens come on (the normal blue Archos start up screen) but it doesnt go off. The green "on" light is on but not the charge one.

Ok, i thought, thats fine. I'll take out the charger and try to turn it back on.

Nope, it just comes up but then turns straight off again

Even with the charger in, it keeps the intro screen on permanently and i cant turn it on via the "on" button to run/use the device.

As soon as i pull out the charger it switches off.

Its SO damn new, NEVER EVER been dropped, miss-used, miss treated, infact its hardly seen ANY use till recently.

Im SO angry about this!!

It was so expensive, even though i bought it on ebay, it was still brand new.

I bought it from the UK, had it sent to me back in Australia to try to put on all the songs etc i wanted before travelling, and now im living in the UK


It was a mission trying to get any data on this stupid thing also. Absolute friggin nightmare and zero back up support or updates/downloads/after care from Archos. Theyre useless.

I REALLY need help guys please!





Posted by on

6 Answers

Re: MASSIVE problems, need urgent help!

I dont think i have that anymore unfortunately.
Looks like im gonna have to pay for it.
Sucks, coz mines only 3months old when it happened and yours is 2 years and youre getting it fixed for free. Murphys Law hey.

I cant see it being a massive cost though. Seems like something simple and may have even been a manufacturers error/problem with circuitry.
I like how they expect you to send it in THEN they give you a cost after. Nice one.
Id rather a total, worst-case-scenario cost so they cant then jack it up as high as they want once its fixed.

Posted on Dec 08, 2007

Re: MASSIVE problems, need urgent help!

Did you have to prove purchase?
I bought mine on ebay from someone here. It was brand new, sealed in factory box. Unwanted gift
I registered the serial numbers and no problems with all that.
Ive tried chasing up the lady i bought it from in the UK for a receipt but she's not there

Posted on Dec 08, 2007

Re: MASSIVE problems, need urgent help!

Cheers mate, yeah let me know what they say!
Where are they located in the UK?
And how much are they likely to charge you for it


Posted on Dec 08, 2007

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: MASSIVE problems, need urgent help!

Here is their support number mate: 020 79490115

Like I said a minute ago (in the guest post) they were good on the phone, tried to fix it but in the end told me to send it in. Took it to the Post Office yesterday so I'll let you know how it goes on.

Posted on Dec 08, 2007

Re: MASSIVE problems, need urgent help!

Youre the first people to even reply to this post.
I emailed Archos months and months ago now, infact, on the same day as posting here on Oct 18th.
Havent heard anything back, and im even registered as a purchaser of their products with serial number etc.
I cant find any phone numbers to call in the UK to try to get ANYone to fix it. I dont give a crap about warranty, i just want it fixed. Im thinking its something to do with the electronics of the charging circuit

Posted on Dec 08, 2007

Re: MASSIVE problems, need urgent help!

To keep people updated. I have sent my AV500 to Archos Repair Dept. Their phone support seemed fine. Hopefully their turn around time will be as good too.

Posted on Dec 08, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Can't power on

that happened when i first got my mp4. i just left it on charge for a few hours and eventually it turned on. it should tell you when its fully charged.

theres two ways mine can turn on; (its most likely very different to yours though)
theres a little switch on the top of the player and you flick that to the left side. or if its been turned on recently, you can hold the play button. does the instructions say to press the ok button?

Jul 03, 2013 | Archos 2 Vision MP3 Player

1 Answer

I bought the Zen mozaic 11 days ago. have had it connected to the computer today to charge it up the picture was on the screen of the mozaic showing that it was charging. i tried to download a song from...

Thanks but i solved it . paid 20 dollars to you guys , got told to return it , which seemed logical actually. But then i went on to another site and they said to start it and hold the start button down and stick a pin in the little hole , which i did , and now it works. was actually trying to answer to the guy who helped me so he can add that onto his list of remedies.
thanks anyway , your sincerely Ja

Aug 22, 2009 | MP3 & Digital Media Players

1 Answer

Connecting Problem

Unplug your Sansa. Uninstall all the Sansa software from your computer, and reinstall the clean version from the Sandisk website. Then, replug the Sansa.

-Tha Mp3 Doctor

Nov 15, 2008 | SanDisk Sansa Clip MP3 Player

1 Answer

Smashed LCD

a crack is not covered
you can get a used on on ebay or repair here

Jan 23, 2008 | Creative Labs Zen Digital Media Player

1 Answer

Ipod nano 1GB Silver

maybe the you either need two get a new verison of itunes my ipod once wasnt regomize and it was because i needed 2 upgrade the itunes

Jan 13, 2008 | Apple iPod nano

7 Answers

T.sonic 610 MP3... Problem:

Please check whether your set has been locked.

if yes then slide the lock button towards upward. then starts it will work.

otherwise please charge the set fully and switch on.

this will work.

A. Ganesan

Nov 19, 2007 | Transcend T.sonic 610 MP3 Player

2 Answers

Converting movies to ipod

the file needs to be converted to a .mp4 file. go to this website and you can download a free program and it has all the directions right on the page.

Nov 06, 2007 | SanDisk Sansa Fuze MP3 Player

1 Answer

Black screen

i dont know what the problem might be but u should try calling sandisk they should know what to do. hope it helps

Jul 11, 2007 | SanDisk Sansa e250 MP3 Player

1 Answer

Backlight wont work?

Check the backlight settings in the menu - yes, cracked screen would definitely cause such a problem

May 30, 2007 | SanDisk Sansa e260 MP3 Player

Not finding what you are looking for?
Archos AV 500 Digital Media Player Logo

291 people viewed this question

Ask a Question

Usually answered in minutes!

Top Archos MP3 & Digital Media Players Experts


Level 3 Expert

2072 Answers

 Mike M
Mike M

Level 3 Expert

3320 Answers

George Hoggarth

Level 1 Expert

33 Answers

Are you an Archos MP3 and Digital Media Player Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides