Question about Sony KDF-E55A20 55 in. LCD Television

1 Answer

Crackling noise at turn on

We have a 55" Sony Wega TV and we started getting a curved purple line at the bottom of our screen a week or two ago. It starts about 12" in from the left and right sides and humps up like a sunrise would be. Then we started losing picture and a horizontal block of the picture would move up the screen and then it would correct itself. Today we tried to turn on the TV and it makes a horrible sound like the guts of the TV are being electricuted. What in the world could be causing this problem.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 285 Answers

Maybe you have a really, really bad cable.
What signal are you using when this happens?
If it happens with just one signal (normal tv, dvd player, PC), try replacing the corresponding cable.
If this happens with multiple signals, I would contact my manufacturer and request a new tv, because this one is broken.

I hope you can get a new tv,
Yannick.

Posted on May 20, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 55" Sony Wega HDTV rear projection television and it has developed purple pin size spots on the screen. It started with just one spot and quickly grew to hundreds of spots over a couple weeks....


You should do a regular cleaning maintenance to the air filter and exchange it regularly. Small dust particules may get into the internal projection module and those spots became visible.

Oct 06, 2013 | Sony Grand WEGA KF50WE610 50" Rear...

1 Answer

When I turn on grand WEGA KDF-55xs955 55 in. projection tv it does nothing but make a crackling noise from the left speaker. The screen stays black, I get no picture at all, and it also starts to smell...


Have you checked the lamp? I would start there if you haven't. Take the lamp out and look down in it to see if the filament is cracked or broken. That is definately what it sounds like. I have seen many of these at shop.

Jul 29, 2010 | Sony Grand WEGA KDF-55XS955 55" Rear...

1 Answer

Red Vertical bars cover the right 1/4 of the screen. They starting appearing sporadically several weeks ago and would go away, now they stay on the screen, regardless of video input ..


Try resetting the TV to the factory settings. If the issue persists, try power resetting the TV. Turn Off the TV and remove the power plug from the wall outlet for 1 minute and reconnect it and check the operation. If the issue still persists, then the TV requires service.

Jul 25, 2010 | Sony Grand WEGA KDF-55XS955 55" Rear...

1 Answer

I have more and more tiny bright blue dots


hello it may be the light engine that's faulty

shaun

Sep 19, 2009 | Sony Grand WEGA KDF-50WE655 50" Rear...

1 Answer

Sony Wega 42" LCD w/Bright Blue haze at bottom corner of screen


hello it sound like convergance may need setting go in to the menu click on convergance you should be able reset the picture
good luck

shaun

May 14, 2009 | Sony Grand WEGA KF-42SX300 42" LCD TV

1 Answer

I have a Sony Grand wega im getting fuzy purple diagnol lines


Try changing the component cable to your Video 6 and see if you have the same problem. I tried this and figured out that the set top box from Verizon component connections may be bad. I also tried changing to a different set of component cables to troubleshoot. I figure its the box not my TV.

Mar 15, 2009 | Sony Grand WEGA KDF-42WE655 42" Rear...

1 Answer

Sony wega kdf-50we655 went off and thier is a buzzing noise


Anything that sounds like electrical crackling will be coming from either the lamp or lamp driver/ballast boards or their interconnections. The lamp should be examined first as this is the most likely cause.

michtech

Feb 11, 2009 | Sony Grand WEGA KDF-50WE655 50" Rear...

2 Answers

Hello im having problems with my sony wega


It sounds like you have a loss of green. This could be caused by the green gun in the picture tube opening up or the drive circuit for the green gun gone bad. Stargazer

Aug 10, 2007 | Sony FD Trinitron WEGA KV-27FS100 27" TV

1 Answer

Sony Wega model # KV-36FS12 it doesn't work can u help me?


This is due to humidity in your area. Due to moisture content screen control section getting corrosion. cleanit and adjust the screen control to get the normal picture.

Aug 10, 2007 | Sony FD Trinitron WEGA KV-27FS100 27" TV

Not finding what you are looking for?
Sony KDF-E55A20 55 in. LCD Television Logo

174 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Televison & Video Experts

kakima

Level 3 Expert

102366 Answers

The Knight
The Knight

Level 3 Expert

73665 Answers

Jerry Greenberg
Jerry Greenberg

Level 3 Expert

1667 Answers

Are you a Sony Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...