Question about Campbell Hausfeld 1,350 Psi Electric Pressure Washer With Auto Detail Kit #PW1350

3 Answers

Campbell Hausfeld PW1380 Pump won't run when water hose is connec

I set up washer as required, turned on pump, pulled trigger with no action. Recycled switch with no luck. With pump power on, I disconnected the water coupler and the pump came on. I coupled hose up and pump immediately stopped again. Can anyone help please????

Posted by on

Ad

3 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Http://www.ppe-pressure-washer-parts.com/campbell-hausfeld-pw138000-pressure-washer-parts
Hope this helps. I have the same problem. It's not the switch but the mechanism that slides inside the switch, which activates the switch to go on and off. I fnally found it so hopefully they have the part in stock. It's not a clogged wand trust me I have torn it completley apart and found out it is the mechanism in the switch is plastic and breaks.

Posted on Aug 09, 2010

  • 1 more comment 
  • jbair19 Aug 27, 2010

    The switch is at the bottom of the motor, yes the motor not the plastic housing. You will have to tear the whole thing completely apar, and pull the motor out. It's white with a black plastic nut (That's what mine looks like). And a wire harness attached to it. Don't fret you can do it. The mechanism inside the white switch housing, I believe is called the uploader needs to come out. remove Black Plastic Nut, and Ta Da.

  • jbair19 Aug 27, 2010

    It should have 2 small springs around the mechanism that turns the switch on or off. My springs were rusted also.

  • gospelgearin Oct 28, 2010

    gospelgearin 34 seconds ago Have same unit with similar problem. Take wand apart and clean valve. Then take motor and pump out of case. It's held in by two plastic holders. Locate micro switch on side of pump,it's a white plastic box with wire leads going to it. It's basically an on/off switch. Make sure plunger inside it goes in and out as you operate the wand. If the pump stops and doesn't restart get a small screwdriver and push in the switch, the plunger isn't pulling it in all the way. Provided the off/on switch tests good you can solve the travel problem by putting a small o ring on the plunger rod. It worked for me

×

Ad
  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 4 Answers

It sounds as if you have a clogged wand. The same thing happened to me. If the tip of the wand (it has a very small nozzle) gets clogged with calcium or anything like that, the pump will pressurize the water, and then turn off (like it's designed to. -- it's only supposed to pump when the trigger is pulled). Because the water is not coming out (and relieving the pressure) the pump will never turn on. If you remove the wand from the pressure hose, you should be able to turn the pump on and see the water come out of the hose. If so, then you know the wand is clogged. Get a long, thin piece of wire and run it through the end of the wand toward the handle a few times, and then try to blow it out with compressed air. Then hook it up and see if it works. Hope this helps!

Posted on Jun 11, 2010

Ad
  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 3 Answers

Pressure switch
I have the same problem and can't find the switch

Posted on May 31, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What do i do to get it to start working?


i assume you put gas and pulled the rope an its running
and have water connected and running

if all is running an water is on an the pumps not pulling then the pump is frozen

May 03, 2015 | Garden

1 Answer

I have a 3000 psi campbell hausfeld gas pressure washer and it has no pressue how can i fix it


Small stream sounds like your pump is not working at all - you are getting house pressure only. First check the intake fitting where you attach the hose for debris that may be clogging the water flow. Same for the pressure hose and quick connect fittings. Remove the tip from the wand and see how much flow you get. If it's still only a small amount, with the motor running, you probably have a bad pump. This can be caused by bad seals inside the pump, or by running the motor without maintaining water supply to the pump, which can melt the seals or even seize the pump if allowed for too long. Repairing the pump is typically more work and expense than replacing it, assuming you can locate a replacement pump.

Aug 03, 2014 | Garden

1 Answer

My electric Campbell hausfeld 1750 psi won,t always start when I pull the trigger .sometimes it will quit while running. the motor and pump seem to be free. it works good while it is running. CR


Hi , i'm not familiar with the machine so without model numbers it is hard to diagnose.
if it is a trapped pressure unloader valve, ie the motor turns off when you let go of the trigger , then it is possible for it to be a pressure switch causing problems. the pressure switch may turn it off immediately you let go of the trigger or it may have a delay stop on it, where it will turn it off after a predetermined time interval. it is quite common for springs to break or microswitches to fail in these switches.

Oct 15, 2013 | Garden

1 Answer

Motor quits when pull trigger


It's the spark plug more than likely. If engine turns but won't stay running its more than likely spark plug. If that doesn't fix its the gas. Empty gas out get some fresh gas.

Jul 13, 2013 | Campbell Hausfeld PW2102 Gas Pressure...

1 Answer

Hookup


For the Campbell Hausfeld 1800 PSI model (PW182500AV), the garden hose connects to the pump inlet on the lower back of the pressure washer. The high pressure hose connects to the high pressure outlet on the lower front of the pressure washer. Here is the operator's manual that will show both connections. http://www.mowersatjacks.com/images/campbell-hausfeld/manuals/pw1825.pdf

May 18, 2013 | Campbell Hausfeld 1800 PSI Electric...

1 Answer

I have a C/H mod. PW1380- worked trouble free for many years, however, today, hooked up, powered up, worked fine until I released trigger, would not restart unless I shut off water supply while squezzing...


Bud The internal seals have blown just enough to cause this to malfunction, whilst it is only a small cost for the seals themselves the overall cost is $200 to repair as it has to be tested and servicd as a company policy ( just had my own done for the same reason)

It is not DIY as the tech showed me some of the pitfalls in self attempted fix and I am glad i didn't fiddle. The case is easily broken if you dont know how to open it and that;s just for starters.

Please rate my help++++Thanks for using FIXYA

Jul 31, 2010 | Campbell Hausfeld 1,350 Psi Electric...

2 Answers

My 2100 will not pull up the cleaner solution. Hose is not kinked, I have primed it, and nipple does not appear to be plugged.


THE DETERGENT HOSE USES THE VACUME FROM THE WATER MOVING THRU THE PUMP TO DRAW THE SOAP INTO THE PUMP.
CHECK THE AREA WHERE THE HOSE CONNECTS TO THE PUMP THERE SHOULD BE A SMALL BALL CHECK THAT MAY BE STUCK AND NOT LETTING THE VACUME PULL THE SOAP

Sep 16, 2009 | Campbell Hausfeld PW2102 Gas Pressure...

1 Answer

Pressure washer stalls out when wand nozzle is released


common for not starting unless trigger engaged as you are turning the pump as well as engine creating pressure,as for stalling pump has unloader valve which is probably in need of grease(use good silicone grease)this allows water to ciculate when trigger released.

Apr 19, 2009 | Campbell Hausfeld Garden

1 Answer

Builds up to much pressure in hose and stalls engine


Sounds like the unloader is not working. try replacing it and see if that helps.

Mar 16, 2009 | Campbell Hausfeld PW2102 Gas Pressure...

Not finding what you are looking for?
Campbell Hausfeld 1,350 Psi Electric Pressure Washer With Auto Detail Kit #PW1350 Logo

1,815 people viewed this question

Ask a Question

Usually answered in minutes!

Top Campbell Hausfeld Garden Experts

John Trevino

Level 3 Expert

1388 Answers

Doctor PC
Doctor PC

Level 3 Expert

7733 Answers

Mike Squire

Level 2 Expert

420 Answers

Are you a Campbell Hausfeld Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...