Question about Wharfedale Topaz SW-10 Subwoofer

Open Question

Blowing fuse Gday guys just a question with my Wharfedale topaz sw10, when you plug it in to the power and turn on main power switch the green light comes on, then the speaker pulses then it blows the fuse which is just behind the wires for the green power light and the sub wont turn on, but the red light on the back panel stays on. Just wondering if you could help me out to try and work out the problem so i can get it running again thanks

Posted by Anonymous on

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SOURCE: Wharfedale Moviestar 60+...

witch company your sub woofer. aleredy company has given user manuval see connections in manuval okkk

Posted on Mar 15, 2008

  • 1 Answer

SOURCE: Wharfedale Powercube uncontrollable loud noise

Change the 2 elco's in the supply
6800µF 63Volt

Posted on Mar 02, 2010

  • 23 Answers

SOURCE: Ok..... I have some Wharfedale

Dunno how old they are, but I just had an 11-year old pair of woofers re-edged because the foam surround and the adhesive had deteriorated. Upon close inspection the foam surround was noticeably pulled away from the cone in a few spots. Unfortunately, if there is an age-related issue with materials beneath the surface that you can't see, you'd have to pull the driver to check it out.

It wasn't until I turned my bass up loud that anything sounded wrong, which precipitated looking for the culprit (quickly found).

Posted on Nov 09, 2010

dunnbiker
  • 8546 Answers

SOURCE: i just brought some wharfedale one-three speakers

Do you mean "Modus 13"?

See picture 6...

http://www.freeads.co.uk/uk/av/audio/hi-fi/speakers/8402337/wharfedale-modus-one-three-speakers-black-rare-bi-wire-quality/view

Put the jumpers back in as shown. Hook your speaker leads to either top or bottom. The entire array of drivers will be active.

Make your receiver aware they are LARGE for the purposes of bass reproduction so some bass will get out to them. FYI, many AVR's will only allow Large Rear speaker selection if you also have Large Fronts. Refer to the manual(s).



Posted on Mar 07, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why will my hp officejet 6100 turn on it keeps blowing main fuses from mains plug


Short circuited component/s at it main power regulator board. Your printer needs service. If you wish to get some details; check the site linked here. Pull up older posts. Surf the site with patience. http://electronicshelponline.blogspot.com/

Jul 17, 2015 | HP Hewlett-Packard - CB863AB1 Officejet...

4 Answers

No Picture


since how long are you facing the problem

Oct 29, 2008 | Vizio P42HD Television

1 Answer

Ignition wiring for 1996 Geo tracker


old posts.

are you saying the Head lights are dead too?

the main fuse box (fender right) to cab box is bollixed.

fubar, hosed, mangled. ok.



10 points for getting the wire color... good going.

the whole wiring , is documented in section 8 (army code for crazy, lol)

10-8

cover this.

on the first page.



http://www.acksfaq.com/trackerfsm.htm



and this page, shows what crappy Geo\'s do on salted roads.





the Green-white runs the whole ignition switch power feed.

from the 60amp main. fuse. is the fuse blow

or this?



fuse good, and still bad.

the green death?





http://www.fixkick.com/electrical-failure.html

Apr 17, 2014 | 1996 Geo Tracker 2 Door

1 Answer

Wharfedale problems


Take it to a repair shop. You have a short circuit or too small a fuse. Have an expert check it before you try to use it again.

Apr 05, 2014 | Wharfedale Titan 12 ACTIVE 12" 2-Way...

1 Answer

Brack lights wont light up on my 1988 ford ranger we keep blowing fuse and put in new brake switch


If you keep blowing the brake fuse than you have a short in the system. Unplug the brake switch. Install a new fuse. If it did not blow than the problem is after the brake switch. Next unplug the turn signal switch, then plug the stop light switch back in and press the brake pedal. Did the fuse blow. If not than the wiring is good in between the two switches. With the turn signal switch disconnected use a jumper wire in between the light green wire (power from the brake switch) and the orange with light blue wire (power to the right brake lamp). If the fuse blows than there is a short in the right side brake circuit between the plug in and the rear socket assembly. If the fuse does not blow than jump from the light green wire to the Light green with orange wire (power to the left brake lamp). If the fuse blows than the problem is in the left hand brake wiring circuit.

Sep 04, 2013 | Cars & Trucks

1 Answer

My 2002 ford ranger running lights and instrument panel dont work


12V power passes through 15A fuse 33 (the one that keeps blowing?) in the battery junction box and on to the main light switch. When the main light switch is set to PARK, 12 volts is routed via the BRN lead to the park filaments of the dual park/turn lamps. These lights remain on when the headlight switch is turned to HEAD.

The main light switch gets its 12V input from 7.5A fuse 11 in the central junction box and the same 15A fuse (33) identified above. When the main light switch is set to PARK, 12 volts is routed via the BRN lead to the instrument panel dimming module and module output is applied to the panel illuminating lamps.These lights remain on when the headlight switch is turned to HEAD.

The input to fuse 33 is hot all the time so should read 12V. If you read 12V at the TAN/WHT connection with the fuse out, something is definitely not right. I'm sure you have noted that the fuse is common to the non-functioning circuits you mentioned.

Sep 14, 2012 | Cars & Trucks

2 Answers

I need user manual of Wharfedale topaz SW-12. Where I find it. thaks


WHARFEDALE Topaz SW-12 Subwoofe
connected to Sony STR-DE975 at the sub-
woofer out-put only hums, ??

thanks

Sep 06, 2010 | Wharfedale Topaz SW-12 Subwoofer

1 Answer

LG WASHER WON'T Power on


Hello. If the lid switch is defective, your washer may not function at all. The switch is inside the washing machine main housing near the door frame. Often you have to raise or open the top or front of the washer to get to the switch. If it's defective, you need to replace it. Some machines have a special lid-switch fuse near the lid switch, inside the control panel. If this fuse blows, the unit won't fill with water until you replace the fuse.

May 24, 2010 | LG WM1814CW Front Load Washer

1 Answer

Westinghouse 33001 won't turn on power pack has green light could it be a fuse or a switch that needs to be reset?


The green light means the 5v standby circuit is working, yes it can be a fuse for the main power supply section that gets the control signal from the main board to turn on, so it can be the main power supply or the main control board.

Nov 03, 2009 | Westinghouse W33001 30 in. HD-Ready LCD...

1 Answer

NO POWER


if there is no indication of flashing or green light when you plug and try to turn it in this indicates no power to processor. the main fuse is more than likely blown. now this fuse is on a small board that is in front of the green board. just follow the plug in... NOW this board that the fuse is on is known as mains input board. WARNING THIS BOARD CAN AND DOES GENERATE 340 VOLTS DC. AND THIS VOLTAGE CAN BE THERE AFTER U UNPLUG IT. i repair alot of these and parts on this board short causeing fuse to blow. problems can range from plug up to standby my recomendation is if you put qa 6.2 amp fuse in and it blows again ...seek a technician

Sep 30, 2008 | RCA HD61W66 61" Projection HDTV

Not finding what you are looking for?
Wharfedale Topaz SW-10 Subwoofer Logo

Related Topics:

22 people viewed this question

Ask a Question

Usually answered in minutes!

Top Wharfedale Audio Players & Recorders Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

The Knight
The Knight

Level 3 Expert

73691 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Wharfedale Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...