Question about Lexicon LX-7 7-Channel Amplifier

2 Answers

Crate gtx 65 guitar amp mains hum

Crate gtx 65 guitar amp
lots of mains hum on all channels even when all volumes / gains at zero. seems to be from the pre amp stage because if pre amp disconnected from power amp then no hum ! otherwise seems to function normally. looking for circuit diagram and or any tips for locating fault

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I had the same problem on my VTX65. I noticed it would oscillate with different effects so I removed the effects module. Problem solved. Now it's dead quiet. I use a Digitech RP500 so removing the effects module was a non issue.

Posted on Dec 27, 2012

  •  Jerry
    Jerry Dec 27, 2012

    I had the same problem on my VTX65. I noticed it would oscillate with different effects so I removed the effects module. Problem solved. Now it's dead quiet. I use a Digitech RP500 so removing the effects module was a non issue.

  • Erik Ackermann
    Erik Ackermann May 20, 2014

    Same issue, unplugging dsp board power fixes the hum, but disables all effects.. Anyone figured out how to fix this with keeping the dsp board??

×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Hi,

I just fixed the same problem. The orange wires from the power transformer (AC10V) are recitfied but not filtered at all. I installed a 4400uF cap from the rectified + (11,5VDC) to ground.
That did the trick.

Greetings!
Tilman

Posted on Jul 08, 2009

  • Earl Buice Nov 05, 2012

    Adding this cap seems like a good idea but it did not help my hum problem. It sounds like 60hz hum. does anyone else have an idea how to fix this?

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Frying sound from amp intermittantly


then the problen is in the power amp section after the preamp stage. Contact Crate for your nearest service center.
http://www.crateamps.com/support/index.php

Mar 03, 2014 | Crate Ca6110dg Gunnison 60 Watt Acoustic...

1 Answer

Zener diode and hum in guitar amp


It could be the diodes, but whatever is the cause it's before the pre-amp section. Generally a loud hum such as that with no effect by volume control, is mostly caused by the filter capacitor in the power supply. And that hum is the 50HZ mains hum getting into your system!

Feb 26, 2013 | Audio Players & Recorders

1 Answer

Crate GTX-30 Guitar Amp Schematic... The thing blew, and I need to replace two components...


Hi. use this link to check for the schematics.


crateamps.com/support/discontinued.php

or

music-electronics-forum.com/sitemap/f-60.html.

take care.

May 31, 2010 | Crate FlexWave FW15 Guitar Amp Combo, 15...

1 Answer

I have the all tube Crate TV-120. When I turn it on it fires up fine. When I switch the standby on I get a loud whistle sound and can hear a humming from the speakers. I can also get a low guitar volume...


This is a guess: I suspect the bypass switch on that effects loop jack is causing a problem. These jacks cause a lot of problems. The switch passes the signal through if there is no plug for an effects in the jack.

You can SOMETIMES tighten up the contact to restore the jack. You have to disassemble teh unit to get at it of course.

Jan 23, 2010 | Crate SPA1600 Power Amplifier - SPA Series...

1 Answer

Crate bass amp bt220 limit led is flashing with the volume only at half


You can reach the limiting IRRESPECTIVE of where the volume control is set when you have a guitar or other source that has HIGH output.

Guitars that have battery in them with internal amplifiers are an example of a high output guitar. Plain inductive pickups may require the volume control to be set at say 70% to reach limiting.

Please NOTE that the volume control is NOT linear, but is an "audio taper".

Limiting means you are probably driving it too hard. Many learn the hard way when speakers and thee power amp fail.

When the cone is driven too far beyond the pole pieces of the magnet, then the IMPEDANCE of the speaker becomes relatively low and can damage the power amp. The limiter tries to prevent this by sensing the current and or voltage and will back off the gain internally. This causes distortion when it happens.

Dec 14, 2009 | Crate Music

1 Answer

High pitched squeal when the input jack is used.


Sounds like your master volume is turned up too much. The channel volume will make the squealing go away(caused by high gain and humbuckers). The best thing to do is dial in your favorite presets and change the channel volume to the correct level with the master volume where you usually keep it. I use my Spider Valve at master volume at about noon and the channel volume between nine o'clock and noon. Let me know if this does not solve the problem......

Aug 22, 2009 | Line 6 Spider Iii 15 Modeling Guitar...

1 Answer

Intermittent shorts in a Crate Limo TX50DE Guitar


turn that ****** on and get a can of freeze spray. coming and going type issues is usually related to a failing electrolytic capacitor. there may also be a bad mosfet, rectifier, diode, etc. i would be suspect to caps. schematics probably only available thru crate and you have to pay a couple bucks, but trust me its worth the couple bucks spent and having it on its way than wasting hours online not getting anywhere. by the way i checked my sources and came up with nada.
yostamplifier.com

Feb 20, 2009 | Crate SPA1600 Power Amplifier - SPA Series...

1 Answer

Crate BT50 Bass amp cutting out with high input.


Sometimes an amplifier's preamp can't handle certain signals/frequencies at a high gain, so they cut out. Bass guitars are especially prone to giving such a strong signal.
I bought an older, nonworking bass amp recently and fixed it just to find it had the same problem. Best solution is to put a low ohm resistor at the amps input, but if you turn your guitar down to half volume it'll have the same effect: should prevent it from cutting out.

Nov 01, 2007 | Crate SPA1600 Power Amplifier - SPA Series...

Not finding what you are looking for?
Lexicon LX-7 7-Channel Amplifier Logo

1,058 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lexicon Audio Players & Recorders Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

yadayada
yadayada

Level 3 Expert

75814 Answers

Electric Dime
Electric Dime

Level 3 Expert

434 Answers

Are you a Lexicon Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...