Question about Kenwood KAC-9102D Car Audio Amplifier

1 Answer

Amp goes dirctly into protect

My kenwood kac-9152d amplifier goes right into protect when hooked up i didnt even hook up the speakers which are a 2ohm load please help me

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Governor:

    An expert whose answer got voted for 20 times.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 4 Answers

Ok well it could be two thing wrong your amp dont have a good ground or your amp is a smar amp and your subs must have to be hooked up so the power from the amp cn go to the subs so the amp can see that you do have subs hooked up to take it out of protect o and look at your fuses to to smal or to big will send it to protect to

Posted on May 19, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a KAC 9152d with a red light on. what is the protect light and normal operating light colors? with the red light on the sound doesnt sound as full as it shoudl be. its running 2 12" alpine type R's...


your ampifier is in protect mode, try to dettache the speaker and turn on it.if the green ligh on ,one of your speaker is deffective but still the red light on theres something wrong with your amp.

Mar 03, 2010 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

My amp is a kenwood kac-9152d it goes in to protection mode soon as you hook up the power


In protection mode do you mean the light comes on and it plays music and stuff? If that's the case, that's what the amp is supposed to do. Protect itself from a power surge

Feb 21, 2010 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

I have a kenwood kac-9152d running a 10 inch rockford fosgate power t1 and the amp keeps going into protect but i have a smaller kenwood kac-8102d running on another t1 and i have no issues with it why...


either the wiring your running is short circuting,or the amp is shot, or the subwoofer is shot, try hooking the same speaker up to the other amp. along with the other speaker to the other amp, see if the same thing happens.

Feb 04, 2010 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Protection light keeps flashing on and off


try hooking up only the power ground and remote see what happens if protection light is on then u have a problem with amp if it goes off then hook up rca if still off then hook up speaker wire if it turns on then u have a prob with speakers

Feb 02, 2010 | Kicker ZX10001 Car Audio Amplifier

2 Answers

The amp goes right into protect when hooked up. how do i get it to work properly?


Does it have a antenna connector to turn it on. this sometimes is a blue wire that comes from the radio. This normally turns the amp on when the radio is turned on. you should have a power (red) ground (green or black) and a power control wire they are right next to each other on the amp

May 19, 2009 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Can i kook up 4ohm dvc sub to a kac-x810d amp?


No, the sub is dual 4ohms...meaning if you parallel the positive speaker terminals and the negative speaker terminals you will have a 2ohm sub. Conversely, if you series the pos and neg you will have an 8ohm sub. if you wirte to just one set of terminals on the sub you will have a 4ohm sub.

Apr 12, 2009 | Kenwood KAC-8101D Car Audio Amplifier

1 Answer

I need help


Most of the time if the red light is on the amp is no blown but some times it does this cause the subs are hooked up in the wrong way. If the amp is only 2ohm stable and you hook the subs up to it at 1 ohm than the amp will not work so I would check this frist.

Oct 17, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Kenwood KAC-9152D Car Audio amp


There could be several problems. The following page should help you determine if you have a problem with the amp or something connected to the amp.

Amplifier in Protection Mode - Troubleshooting

Let me know if you have any other questions.

Sep 17, 2008 | Kenwood KAC-9152D Car Audio Amplifier

3 Answers

Kenwood kac 9152D


Usually, protection mode is caused by one of these conditions:
  • Shorted speaker outputs.
  • Speaker output shorted to ground.
  • There is an internal issue, causing DC voltage to be present on the speaker outputs.
  • Amp overheats.
  • Ground connection is insufficient for amp or HU.
I'm not sure of the history or symptoms of your amp, but those are the reasons why the amp could go into protection mode.

Mar 13, 2008 | Kenwood KAC-9152D Car Audio Amplifier

Not finding what you are looking for?
Kenwood KAC-9102D Car Audio Amplifier Logo

Related Topics:

495 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4834 Answers

yadayada
yadayada

Level 3 Expert

75066 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7754 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...