Question about Kenwood KAC-9152D Car Audio Amplifier

2 Answers

The amp goes right into protect when hooked up. how do i get it to work properly?

The amplifier goes right into protect.

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 36 Answers

Check to see if your overall resistance of your speakers are less than 2 ohms ....example of less than 2 ohms would be more than 2 ,4 ohms speakers on one channel OR putting anything lower than 4 ohms in bridged mode .... other than that if any one of your speaker wires are touching the chassis or grounding off to the body of the car it will bring on the protectection of the amp .... I'm assuming that the amp never worked since you installed it into you car as opposed to it working and all on a sudden the protection started coming on ....

Posted on May 19, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 331 Answers

Does it have a antenna connector to turn it on. this sometimes is a blue wire that comes from the radio. This normally turns the amp on when the radio is turned on. you should have a power (red) ground (green or black) and a power control wire they are right next to each other on the amp

Posted on May 19, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

As soon as I hook the amp up it goes into protection mode. But in about 10 seconds it flashes off protection mode but them goes right back into protection mode. And it keeps doing this as long as the amp...


If you disconnect your speakers and input and the problems remain it means you've blown your end-stage and the amp needs repair.

if the problem disappears when disconnecting the speakers you may want to check if the impedance of your speakers is within tolerance of the amp.

Dec 23, 2010 | Rockford Fosgate Punch P5002 Car Audio...

1 Answer

Amp goes straight to protecting


bad power supply or out put i hat to say it but spl is note a good company i would replace the amp

Jul 07, 2010 | SPL Dynamics CRM1200-2 Car Audio Amplifier

1 Answer

My amp keeps going into some safe mode and red light blinks and stops base to my sub. I have it hooked up to 1 15.4 Orion HCCA.


The "safe mode" on your amp usually kicks in for two reasons - the ohm load on the sub is too low for the amp (presenting a "short" to the amp), or it's going into thermal protection because the amp is too hot. From your description, it sounds like there's a short in the wire, the sub's ohm load is too low, or the sub is partially blown.

If you have another sub or speaker, connect it to the amp's output and see if the amp still goes into protection mode. If the amp goes into protection with a known-good speaker, then there may be something wrong with the amp's power supplies. If the amp works properly with another speaker or sub, then I would check the sub that's causing it to short out.

You may also want to check whether or not the amp is over heating by just touching the amp when it goes into protection. If it's just warm, that should be ok - if it's hot, then it might be working too hard. In this case, you may need to check the input voltage (12-14VDC) and the size of the power and ground cables. If your ground isn't properly connected, it can cause weird problems like over heating, shorts, erratic behavior, etc...

Mar 04, 2010 | Orion HCCA-D5000 Car Audio Amplifier

1 Answer

No bass


could be the speaker its hooked up to . try to disconnect the sub and see if the protect light goes out

Feb 06, 2010 | Competition INTERFIRE BIG BOY 2CH...

1 Answer

Amp 7541a amp was working fine, Took it out of one


REMOVE THE RCA INPUTS AND DISCONNECT THE SPEAKERS, THEN POWER THE AMPLIFIER UP WITH THIS NO INPUT, NO SPEAKER LOAD CONDITION. IF IT STILL GOES INTO PROTECTION AND YOU HAVE VERIFIED THAT THE POSITIVE AND ESPECIALLY THE GROUND CONNECTIONS, ALONG WITH THE REMOTE CONNECTIONS ARE 100%, THEN THE AMPLIFIER WILL NEED TO BE SERVICED. KEEP IN MIND, THAT DURING THE INITIAL TURN ON OF THE AMPLIFIER, THEY SOMETIMES WILL ILLUMINATE THE PROTECTION LIGHT WHILE STABILIZING THE POWER SUPPLY AND OUTPUTS, BUT AFTER THAT THEY SHOULD SHOW NORMAL POWER UP. IF YOU GET IT TO POWER UP FINE, THEN RECONNECT THE SPEAKERS AND IF STILL OK, THE RECONNECT THE RCA'S. IF IT IS STILL POWERED UP, THEN START TO TURN UP THE MUSIC. IF IT IS STILL POWERED UP AND NO MUSIC, THEN CHECK THAT YOU DEFINITELY HAVE A PROPER SIGNAL COMING FROM THE RADIO. LET ME KNOW IF YOU NEED FURTHER ASSISTANCE.....V

Nov 18, 2009 | Infinity Reference 7541a Car Audio...

1 Answer

Protect light comes on, no power


Hello patrick_h_mi,

You'll also need a remote turn-on source for the amp to operate. Normally, this is a blue or blue/white wire from your head unit, but for test purposes, you just need 12V to the "remote" terminal on the amp. The amp should power up without speaker inputs or speaker connections, but it is not recommended.

Hope this helps.

May 28, 2009 | Infinity 7540A Car Audio Amplifier

1 Answer

Amp goes dirctly into protect


ok well it could be two thing wrong your amp dont have a good ground or your amp is a smar amp and your subs must have to be hooked up so the power from the amp cn go to the subs so the amp can see that you do have subs hooked up to take it out of protect o and look at your fuses to to smal or to big will send it to protect to

May 19, 2009 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

Amp Not working!


If the amp goes into protect mode, it's likely due to shorted output transistors. To eliminate other possible problems, read through the following page:

Amp in Protect Mode - Troubleshooting

If the problems are not with the wiring, follow the link at the bottom of the page to the Amplifier Repair Primer page.

Let me know if you have any other questions.

Sep 20, 2008 | Power Acoustik TS620-2 Synchronized...

1 Answer

My Amp


sounds like the sub that throws it into protect mode is cross wired pull sub out and make sure they are wired right make sure ground from sub goes to ground on box and do same for power wire

Jun 11, 2008 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

Not finding what you are looking for?
Kenwood KAC-9152D Car Audio Amplifier Logo

Related Topics:

108 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4848 Answers

yadayada
yadayada

Level 3 Expert

75817 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8180 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...