Question about Canon Rebel Cameras

1 Answer

I have a canon rebel xsi and sigma 100-300 zoom lens. I get an error Err01 when shooting. It says communications error and clean contacts which I have done. Is there an incompatibility issue?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Canon Master
  • 6,702 Answers

I don't think there will be an incompatibility issue. If your other lens(es) work well, your camera must be ok. But not only dirty contacts can cause trouble. If a very small dent is in one of the contacts of the camera, or one of the contacts from the lens is a bit to far pressed in, you also have a bad or not existing contact with the same error.
In the lens also something can be wrong. I strongly suggest to try the lens on an other camera and see what that brings.If the error goos with the lens to the other camera, you know where to look. But I think only professionals can repair you lens if it is defect.

Posted on Jan 07, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

DRebel
  • 19 Answers

SOURCE: I have a canon rebel

For sports (or any fast moving occasion) you must be very particular about your settings. The Rebel Xsi takes great shots, but some tweaking needs to be done on your end, to make sure you don't get the "blur" and low quality that you may be experiencing.

On the settings dial, turn the mode wheel to "Tv". This is shutter priority, meaning you are controlling how fast the "shutter" closes. You need to have it set higher because you are trying to "freeze" a fast moving object.

After setting the selector to "Tv", you can change the speed by moving the "control wheel" left and right. (It's located above the ISO button, below the shutter button". If you look at your LCD screen while turning the wheel to the right (it makes a clicky sound), you will see the speed increase.

By default, it is set at 1/125th of a second. Increase it (1/200th of a second for example) and try that setting. You should freeze your target without blur.

If you are indoors and need a flash, the speed will max out at 1/200th of a second. Of course, if you need the flash, you will manually have to pop it up yourself by pressing the flash button when in "Tv" mode. It has a "lightning bolt" and is located near the "EOS" sticker on the front.

Hopefully this helps you. Let me know!

Posted on Apr 03, 2009

  • 11967 Answers

SOURCE: Have a brand new EOS 100D with Canon image

Have you actually cleaned the contacts or are you just looking at them and they "look" clean? Clean them with a cotton swab lightly dampened in rubbing alcohol.

Posted on Feb 28, 2010

  • 11967 Answers

SOURCE: 0.25 m/0.8 ft canon lens

Have you cleaned the lens contacts where they meet the body with a cotton swab lightly dampened with rubbing alcohol?

Posted on Aug 13, 2010

welcomejee
  • 10594 Answers

SOURCE: bought new Canon Rebel 2Ti. want to attach Sigma

Hi,
If you are sure that Sigma DL 75-300 mm zoom lens is fine and have tested on another camera then firmware update of Rebel 2Ti might fix its issue.
Required firmware update is available, click at Canon Support link and click on EOS Rebel T2i Firmware Update Version 1.0.8 to download it.

CAUTION: Follow Canon instructions strictly that you will see at download page to avoid any damage to camera during firmware update.


Hope these info will help you.
Thanks.

Posted on Oct 16, 2010

ginko
  • 19396 Answers

SOURCE: I have a Canon EOS

Hi.

Problem is either the well known firmware bug, or a real problem in communication between lens and camera.

Do a firmware update ensuring that you read and follow all the indications in the page linked below. If you fail the firmware update the camera may not start anymore.

Here Canon firmwar update for EOS Rebel XS / 1000D

That will usually fix the problem, if it doesnt; check lens connector contacts and test using different lens.

Regards.

Ginko.

Posted on Oct 20, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Canon T3i Compatibility


The older Sigma lens will not work on the new EOS digital cameras...I've go two of them that will only work zoomed in at F4 and zoomed out at f5.6..... I shoot aperture priority with my Rebel XT and works out fine.... depth of field often shallow but, still nice shots.
There is a ton of info on the internet about "re-chipping" the lens....but, looks like too much to gain little.

Sep 28, 2013 | Sigma Cameras

1 Answer

My canon rebel xsi won't take a picture with the .18-55m lens zoomed in


Clean the contacts on the lens? Your lens maybe defective need service?

Apr 08, 2012 | Canon EOS Rebel XSi Digital Camera

2 Answers

I have a Sigma DL Zoom 75-300 mm lens that I would like to use on my new Canon Rebel T3i SLR camera. Part of the time when I try to use it, an error message comes up saying, "The lens is having...


Simply clean your camera lens contacts

Here is a tutorial , how to clean your camera lens contacts

http://www.youtube.com/watch?v=wUt-K6w7lc0

Good luck and regards

Sep 29, 2011 | Sigma AF 70-300mm f/4.0-5.6 DL Macro Super...

1 Answer

I am trying to use an older SIGMA 28 - 200 mm f3.5 - 5.6 UC Aspherical AF lens with a Canon Rebel Xsi and am getting a communication error (Err 01).I have already cleaned the lens contacts but still get...


From working with third party lenses in the past what I've found is that Canon doesn't give up the "chip" technology so the older lens can not talk to the newer cameras. I suspect that Canon does this to promote their lenses over the competition. You might be able to send the lens to Sigma and have them re-chip it and have a great lens again.

Dec 26, 2010 | Sigma 28-200mm f/3.5-5.6 DL Aspherical...

1 Answer

Have a brand new EOS 100D with Canon image


Have you actually cleaned the contacts or are you just looking at them and they "look" clean? Clean them with a cotton swab lightly dampened in rubbing alcohol.

Feb 28, 2010 | Canon EOS Digital Rebel XS / 1000D IS...

1 Answer

I am trying to use an older SIGMA 28 - 200 mm f3.5 - 5.6 DL Hyperzoom macro Aspherical AF lens with a Canon Rebel Xsi and am getting a communication error (Err 01).I have already cleaned the lens contacts...


To NOT get that error you need to use in AV mode. It's the only way that old Sigmas work with the new Canons. It's an aperture bug that old Sigma lens have and some the only way to fix it is to rechip it. The problem is that Sigma no longer rechips the lens.

May 19, 2009 | Sigma 28-200mm f/3.5-5.6 DL Aspherical...

1 Answer

Matching 2 brands


Simga makes lenses to fit several different makes of camera bodies including Canon and Nikon. I'm assuming your Sigma lens has a Nikon mount, if so there are some adapters, but they may not work like you want - not all functions may work properly thru the adapter. For best results you should return or sell the lens and get one with the Canon mount.

Dec 26, 2008 | Canon Rebel XT / EOS 350D Digital Camera

3 Answers

Canon digital rebel xt :error 1 message


I agree with dovi. I actually emailed canon and here is what they said and how to do it; Thank you for your inquiry regarding your digital SLRs. We value you asa Canon customer and appreciate the opportunity to assist you, and I'm sorry to hear that you're running into the "error 1" message. From what you mentioned, it sounds like the lens might be having problems communicating with your cameras. One thing you could try is toclean the contact points on your lens and your camera. If you have not done this yet you can do so by turning the camera off, removing the lens, then brushing those copper points on both the lens and the camera body with something like a clean eraser. Should problems continue, I would suggest that you go to a local camera shop and try a different lens. That way you can determine whether the problem is due to the lens or to your cameras. I hope this is helpful Jason

Sep 04, 2007 | Canon Rebel XT / EOS 350D Digital Camera

Not finding what you are looking for?
Cameras Logo

Related Topics:

36 people viewed this question

Ask a Question

Usually answered in minutes!

Top Canon Cameras Experts

kakima

Level 3 Expert

102366 Answers

TC CAMERA REPAIR.Com...

Level 2 Expert

169 Answers

old marine
old marine

Level 3 Expert

1973 Answers

Are you a Canon Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...