Question about Hotpoint RGB745 Gas Kitchen Range

2 Answers

Heating element the lower heating element in our hotpoint stove is not working. had it tested at a repair shop and was told it is ok. changed the fuses and still not working. Any suggestions?

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: heating element

Hot Point Gas Range Model RGB745WEV3WW
Oven does not work properly, will heat to about 200 dergrees, no higher. On rare occaions it will heat properly perhaps for 2 or 3 days, then same heating problem starts again

Posted on Dec 16, 2007

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 473 Answers
Re: heating element

Give me the complete model # from the sticker on the range so I can assist you.

Posted on Oct 18, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Kenmore electric range mod.750.9210,9220,9230,9240 Oven does not come on

Check fuses first. If OK, Unplug from wall, unscrew the bracket that attaches the lower bake element to the wall of the stove..(usually held to wall by a few small screws). Clip VOM test meter leads to the two terminals. Set meter to at least 250V AC. Make sure test leads and screws do not touch any metal anywhere. Best is to put a piece of plastic or cardboard under the test leads to isolate the leads from the bottom of the oven. Once connected and properly isolated, plug stove in, turn stove on to bake 350 degrees and look at the voltage reading. If 250V is there element is bad. If no voltage switch or wiring between switch and element is bad.

Aug 08, 2014 | Kitchen Ranges

1 Answer

Inner 6-inch element on the 12 inch/6 inch Dual Radiant Element cycles off too long

Sounds like the file is corrupted. That doesn't mean the footage is irretrievable. I believe the file type is .mov on that camera? You need to find a .mov repair program, there are lots out there. I don't want to give you a link since I haven't used any of the .mov ones and don't want to accidentally give you malware, so I'll leave that part up to you. But you should be able to get your file repaired, just google ".mov repair."

Nov 15, 2013 | Whirlpool Kitchen Ranges

1 Answer

My older model electric hotpoint selfcleaing range, lower oven self cleaning function is not working. what could be wrong, maybe i didn't set a control knob correctly, don't have a maual for t

Back to the fifties! If the lower oven cooks normally, the heating element probably is OK. For self cleaning the normal temperature setting is bypassed and the heating element is set to a substantially higher level. Your oven may be unable to self clean because operation of the knob may not actually start the cycle. The thermostat could need replacing even though normal cooking is OK.

Sep 02, 2012 | Hotpoint Kitchen Ranges

1 Answer

Hotpoint RB747GJ electric stove. Extremely long preheat cycle

I went to one of my local appliance sales/service dealers and asked the question. They said it sounded like the baking element was starting to go, but would need to test it. They gave me the option of a service call or if I was handy and comfortable working with it, told me to cut the power at the circuit breaker and then remove the screws holding the element in place and bring it in to have the continuity tested. If the element tested bad, I would get a replacement element. When I removed the element, there was only one wire attached. The baking element tested fine and all I had to do was replace the broken wire connector. I had broken the wire connector when I lifted the element up to clean out the ash residue from the cleaning. it was easy to determine which wire went there since it was missing the connector. Total repair was less than $2 !

Dec 01, 2009 | Hotpoint RB757 Electric Kitchen Range

2 Answers

Oven does not get warm, suspect it is a fuses but cant locate it

It is probably due to a broken heating element in the oven. These are relatively easy to replace. You can test it with an ohmmeter. It should measure low ohms. If it is open circuit then it is broken.

Jul 25, 2009 | Stoves 1100DFSID Kitchen Range

1 Answer

Stove top burners and lower baking element not heating up

If all the elements are dead, check for blown fuses/tripped circuit breakers. There may be some in the range unit itself in addition to your electrical service panel. If one element is completely dead on all heat settings, the control is probably bad or there is a broken wire. If it is stuck on high for all control settings or is erratic, the control is bad - replacements are readily available and easily installed.
On ranges with push button heat selection, a pair of heating elements are switched in various combinations across 120 and/or 240. If some heat settings do not work, the most likely cause is that one of the heatings elements is burnt out although a bad switch is also possible. Kill power to the range and test the heating elements for continuity with resistance meter or multimeter.

For the lower baking element:
Again, check for blown fuses in the oven or tripped circuit breakers. The remove any wiring to the bottom element and test for resistance. If you get no reading (or a very high resistance) then your element is dead.

May 09, 2009 | Kitchen Ranges

2 Answers

The inner right front element will not heat up on our Kenmore Elite ceramic stove top. The middle and outer elements on the right front work fine. Why is this happening?

inner element burned out. Either burner needs replacing or control switch is bad. Take out burner and see if coil has a break in it. IF not, then switch is bad. I cannot see your repyl due to some tech issue w/ the site, so it may be a day or so before I can reply again. Please leave feedback for me if appropriate. Thanks

Nov 28, 2008 | Kenmore Kitchen Ranges

1 Answer

Hotpoint ew83 main oven stopprd heating, fan and light ok but no heat from element

Hotpoint EW83

1. Safety Fusible Link Blown (O/C) Do continuity test
2. Temperature Control Module Faulty (Heat Sensor)
3. Main Heating Element Blown (O/C) Do Continuity Test
4. Check for damaged wiring due to arcing etc.
5. Fetch the Proff!

May 04, 2008 | Kitchen Ranges

2 Answers

Stove burner over heating on low setting

the element only does what it's told. more than likely the contacts in the switch are stuck. the switch needs to be replaced.

Nov 01, 2007 | Kitchen Ranges

Not finding what you are looking for?
Hotpoint RGB745 Gas Kitchen Range Logo

256 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hotpoint Kitchen Ranges Experts

Dan Webster
Dan Webster

Level 3 Expert

8147 Answers

Richard Roth
Richard Roth

Level 3 Expert

9472 Answers

John Tripp
John Tripp

Level 3 Expert

4625 Answers

Are you a Hotpoint Kitchen Range Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides