Question about EliteGroup 945GZT-M (V1.0) Motherboard

2 Answers

POST issues Hey all,I recently purchased an EliteGroup 945GZT-M motherboard with a Celeron 420 processor from Microcenter. I'd put everything together (all the drives, fans, etc.) but when I went to power up, nothing happened. No fans, no lights, no beeps, nothing.Assuming it was the power supply (a cheap-o Microcenter brand 300 Watt ATX), I returned it to the store, where they gave me another one. This didn't help either, so I returned it for a 550 Watt PSU. Initially, this was no help, but after following the tips on the Microcenter website telling me to build it outside the case with only the essentials plugged in, the fans spun, and a red light lit up in the case faceplate. I assume the red was because I hadn't plugged in the system fan, or something to that degree.Elated, I re-installed the motherboard within the case where it again worked as promised. I moved the case over to my monitor and keyboard, but found that it wouldn't turn on for me again. I really have no idea what to do here, and any help would be greatly appreciated.

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: POST issues

I had the same prob, but found if you do not fit all 6 screws there is no power. So try fitting all 6 screws.

Posted on Feb 15, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 178 Answers
Re: POST issues

Hello please take the motherboard back to place of purchase. This sounds like a bad board. I have had about 13 of the same board customers would call me on. there is a hairline crack somewhere on the board.

Posted on Feb 10, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

2 Answers

Support dualcore?

That is a socket 478 motherboard. I doubt that one even gets dual core processors in the 478 chipset. Also according to the ECS website, this is a Pentium 4/Celeron board. More info can be found here.

Nov 16, 2010 | EliteGroup ECS P4M800-M Socket...

1 Answer

My all processor ,Ram ok but can not display

If the RAM and the processor are ok , and you have tried booting  to BIOS with all oter devices removed and it has also failed, then the only thing left is the motherboard - it's dead, junk it.

Jul 08, 2010 | EliteGroup 945GZT-M (V1.0) Motherboard

1 Answer

Can dual 2.7 E5400 run on my asus motherboard P5GX-MX

Yes ur motherboard support the processor u can use it

May 22, 2010 | EliteGroup 945GZT-M (V1.0) Motherboard

2 Answers

Eltegroup 945gzt-M(1.0) motherbaord

Yes it can support it. It supports all models of intel dual core processors.

Jan 28, 2010 | EliteGroup 945GZT-M (V1.0) Motherboard

1 Answer

Ecs 945gzt- M(1.0)

Yes it supports all models of dual core processors.
e5400 has the same socket as your motherboard does so they are compatible.

Jan 28, 2010 | EliteGroup 945GZT-M (V1.0) Motherboard

2 Answers

Can intel dual core e5400 work on my motherboard?

Yes you can.
Your motherboard is LGA775 socket and supports the folowing processors:
Core2 Duo / Pentium Dual Core (yours) / Pentium D / Pentium 4 / Celeron 4xx series/ Celeron D.

Jan 28, 2010 | EliteGroup 945GZT-M (V1.0) Motherboard

1 Answer


ecs_buttom_03.gif LGA775 socket for latest Intel® Core™ 2 Duo / Pentium® Dual Core/ Pentium® D / Pentium® 4 / Celeron 4xx series/ Celeron® D processor ecs_buttom_03.gif FSB 1066/800/533 MHz

The above information was taken from their website.

Jul 06, 2008 | EliteGroup ECS 945GCT-M/1333 Motherboard -...

1 Answer

Will not post


Unplug and remove everything from your motherboard, memory, PCI card, Hard disk, CD, etc…

Only leave the processor, its fan and the power supply connectors. Power up and listen for some beep. If you don?t hear any beep there is an issue with the processor or the motherboard. If you hear any beep start installing the memory and try again adding one more component until you discover which one is causing the issue.


Oct 19, 2007 | EliteGroup KN1 Extreme Motherboard

1 Answer


Check that cooler on CPU is turn on (to connector on mobo). If it not connected - CPU will overheated and system shut down.


p.s. Manual

Oct 15, 2007 | EliteGroup 945GZT-M (V1.0) Motherboard

Not finding what you are looking for?
EliteGroup 945GZT-M (V1.0) Motherboard Logo

Related Topics:

60 people viewed this question

Ask a Question

Usually answered in minutes!

Top EliteGroup Motherboards Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Mark Taylor
Mark Taylor

Level 3 Expert

728 Answers

Michael Thomas
Michael Thomas

Level 3 Expert

3051 Answers

Are you an EliteGroup Motherboard Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides