Question about MTX Audio Tna251

Open Question

Tna 251 amp has blinking red lights and subwoofers stopped working, remote for amp also dead

Just installed and all worked fine for about 10 minutes then subwoofers stopped working, remote for amp also dead

Posted by Anonymous on

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SOURCE: Apx stopped working, MTX 702x

maybe the audio amplifiers Ic´s damaged or the power fet

Posted on Mar 06, 2009

jrw4u
  • 62 Answers

SOURCE: Everything works fine but my amp light is red.

if its not coming on it usually means you have a bad ground if it works for a little while then does it then its over heating and you will need to get a fan

Posted on May 01, 2009

timbadger21
  • 64 Answers

SOURCE: one day amp stopped working

it sounds like rca wires or the holder where the rca wires go in to the amp itself . geek squad can fix it for ya

Posted on Jun 22, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Stopped working. Power light is on. Could it be a fuse? Can I change it myself? Is there a lifetime warranty?


Amp has power, but no sound! - ecoustics.com

www.ecoustics.com > ... > Archive through November 13, 2007 Forum
Nov 5, 2007 - The other night my fiance's amp stopped pushing the subwoofers. ....also, it was working fine for however long- and then just stopped working. if that were the case, it wouldn't have worked in the first place. .... lastly before u go saying but the amps power lights on i'm sure the amps ..... Car Speakers Forum WHY DOES MY AMP POWER LIGHT TURNE RED ON PROTECT ...
Sep 11, 2011
Please someone help me! I am dying without my music!!!
Aug 4, 2011
Subwoofer stopped working all the sudden
May 26, 2010
More results from www.ecoustics.com

Jan 18, 2016 | Audio Players & Recorders

1 Answer

My Toshiba 50H81 screen black, no sound & power light blinking


sounds as if your power supply needs to be repaired. the capacitors over heat and crown or leak.

Jan 01, 2010 | Toshiba 50H81 50" Rear Projection...

1 Answer

Amp works for a few minutes


too much power. turn your amp down a bit and let er rip.

Oct 01, 2009 | Sony Xplod 1100 Watt Max 10" Subwoofer,...

1 Answer

Amp is shutting off after 10 min of driving!! please help!!


Does it happen at all volume levels?
What is the gain setting on the sub amp?
Have you checked for 12V @ remote turn on after problem occurs?
Sounds as if the remote turn on relay inside the amplifier is losing signal, or has become damaged. If the protection light does not light up, the problem is not thermal, shorting, or high/low voltage.
The amplifier is in need of repair. This is not an end-user fix. Looking at about $50 to repair.

Thanks for using FixYa- a FixYa rating is appreciated!!

Feb 18, 2009 | Profile BAJA HA700M Car Audio Amplifier

1 Answer

Subwoofer stops working after awhile, but only one


it sounds like u blew them or the voice coils could be messed up here is one way to check take the woofer out of the box and look at the coils it should be ornge and then smell it if it smells like fire it might be going bad thats the reson it is frezzing like that let me no what happens and please rate me

Apr 07, 2008 | Sony Xplod 1100 Watt Max 10" Subwoofer,...

2 Answers

Amp Power LED Display blinks red and no sound


With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. Does the voltage on either the B+ or remote pulse below ~11 volts when the LED flashes?

Jan 26, 2008 | Kicker ZX650.4 Multi-Channel Amp - 480W ZX...

1 Answer

Pt- red light on


mine done that the other day and i took the fuse out of the side of the amp for about a minute put it back in and came on dont know why it worked but it did hope that helps you l

Aug 25, 2007 | Performance Teknique ICBM-9560 Car Audio...

1 Answer

Hifonics 1605d stopped working


the red light blinking because your amplifaier its dead look for the alimentation cabel end replace the calibration protector

Apr 16, 2007 | Hifonics BX1500D Car Audio Amplifier

Not finding what you are looking for?
MTX Audio Tna251 Logo

Related Topics:

30 people viewed this question

Ask a Question

Usually answered in minutes!

Top MTX Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

yadayada
yadayada

Level 3 Expert

75005 Answers

Are you a MTX Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...