Question about Technics Audio Players & Recorders

1 Answer

Technics su-g50 amp powers up but no sound and no click when powered up

Posted by Anonymous on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Habit-Forming:

    Visited the website for 3 consecutive days.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 91 Answers

Greetings
Mostly this happens when power output is damaged
or the power supply circuit has a problem
the amplifier has a voltage detection when its over or under voltage it wont let the unit to start normally.
Hope this helps.

Posted on Jan 02, 2016

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
megatronix
  • 57 Answers

SOURCE: Technics SU-V2 keeps cutting out

An amp will cut out if the output protection circuit kicks in. This circuit compares output power against the preset level. Each channel has it's own, independent protector. There are calculations that can be done, but for a novice the rule of thumb is to "never use a speaker with a power rating less than the amp AND a lower impedance than stated". Typically using a 4 ohm load on a 8 ohm system is inviting disaster. Even if the system does not become a smoke generator, you might notice that though "louder", the sound quality is deteriorated. Many "audiophiles" often hook up some combinations of speakers to have "surround" without really understanding that the collective impedance actually changes (generally lowers).

Posted on Jan 21, 2008

marsrover
  • 682 Answers

SOURCE: Problem with amplifier Technics SU-V500

it is relay control the output you can changed in near electronic service center.

Posted on Mar 10, 2008

  • 4234 Answers

SOURCE: Technics SU-V98 No Sound

If I understand your posting correctly, the amp works using the Aux In connectors but not using the VCR1 even when VCR1 is selected correct? If that is the case, there is an internal electronic switching IC (TA9263 I think) that may be defective. This is not a complex repair and can be confirmed easily by any shop that does audio repair. They will trace the incoming signal with an oscilloscope to the IC and see nothing come out when VCR1 is selected. The IC costs less than $10.

Dan

Posted on Feb 06, 2009

  • 1 Answer

SOURCE: Technics SU-G75

I had the same problem. The solution to me was presoldering transistor Q708. http://www.flickr.com/photos/37147023@N03/3511227679/?edited=1

Posted on May 08, 2009

  • 1 Answer

SOURCE: su-v55a technics amp cuts off when volume up to 2

I got a problem for su-v55a technics one speaker is not playing

Posted on Mar 03, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Are st-k50 and su-g50 amplifiers compatable


Yes they are, they are from the same Technics series , just connect them with RCA connectors , and enjoy

Sep 30, 2014 | Technics Audio Players & Recorders

1 Answer

On my Technics SU-G90 where do I connect the subwoofer


Some amps have a single RCA socket for a powered sub. If it has not got one of these then the amp has no output for a powered sub. If so then you can only use a none powered subwoofer, which will connect via the speakers of the amp, see the subwoofer manual for how to do this.

Feb 18, 2014 | Audio Players & Recorders

1 Answer

Good day i have a Technics amplifier SU-X320. Problem is it powers up up there is no sound. Checked all basic fault finding, suspect it is the volume IC.


"Volume IC" do you mean an IC that is a pre-amp and controls the volume and things like tone? Or do you mean the main power amp IC, which will be on the big heat sink?
If you amp uses the latter and not individual separate devices for the power amp, suspect that over the other IC. But if the amp has separate power amps for both channels, replace the IC.

Oct 09, 2013 | Technics Audio Players & Recorders

1 Answer

Technics Amplifier SU-V4


The clicking sound will be a relay for the protection circuit. That could be faulty, but first check out the main devices on the main amp section. Those attached to the big heat sink. If you see a single IC amp that could well be faulty.

Oct 04, 2013 | Audio Players & Recorders

1 Answer

Hi My name is Randolph, I have a technics SU-G50,how do I know if the main power module is blown? The system lights up but doesnt produce any sound and the relay in the power amp section is shot. Also...


The power amp IC for this is an SVI3206 which is listed as no longer available. You can check with some local service shops that may have some in stock. Realize that this IC is not cheap ($75 or more if available). If the relay does no click, there is a god chance that the IC is defective. I have seen some cases where there was a problem with the voltage regulator circuit that was preventing the amp section from working properly. Without seeing the actual unit and testing it, I can't say for sure.

Dan

Feb 28, 2011 | Technics Audio Players & Recorders

1 Answer

Technics SU-G88. When volume is wide open get small amnount of sound, as sugested I have already replaced the op ic IC602 and this did not help. Is it possible that both audio power modules bolted to the...


problem with electronics is there are so many possibilities! before changing the power amp i suggest u check all the paths from pre-amp to power amp. bad resistors cud be it, faulty capacitor cud be draining power to ground. insufficient power supply to final amp cud also be it. so before making any rash changing pls check all components including the power amp module.

Mar 14, 2010 | Technics Audio Players & Recorders

2 Answers

I need a cooling fan for my su g50 where can I get one web site maby


The fan assembly can be purchased from tritronicsinc,com (use the guest account) for $24.31 using part number SYE1128-4


Dan

Jul 11, 2009 | Technics Audio Players & Recorders

2 Answers

Technics SU-G70 clicks but doesn't display or sound


I just got mine back from repair shop, same symtoms, they replaced power supply, in your case it was hit and miss for a while, so maybe bad power supply connections inside.

Jan 04, 2008 | Audio Players & Recorders

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

239 people viewed this question

Ask a Question

Usually answered in minutes!

Top Technics Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5190 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

T-Comtech Repairs
T-Comtech Repairs

Level 2 Expert

417 Answers

Are you a Technics Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...