Question about Vacuums

1 Answer

I have a Kenmore 11659812991 canister vacuum. The carpet cleaning accessory that has the spinning brush turns off and on - seemingly randomly. I took it apart and did not see any loose connections (I

Floor accessory turns off by itself and then comes back on. Seems to be some correlation with the angle of the wand but I have not conclusively proven that.

Posted by on

  • 2 more comments 
  • Anant Kumar Dec 27, 2013

    the floor accessory is a 'powered' accessory with a brush roller and a light.

  • Anant Kumar Jan 29, 2014

    I checked various contact points - on the accessory, the wand and the hose. Seems like I have something at the top end (where it connects with the wand) that is loose. I tried opening it up and there seems to be some trick to it. Will try again!

  • Thatvacguy.com Jan 29, 2014

    try wiggling, pulling, twisting, etc. gently at each place where the hose, wand, powernozzle, etc. make an electrical connection. Sometimes this helps to narrow down where the circuit is getting broken, sometimes there is more than one bad connection which makes it more difficult to pinpoint the problem or problems.

  • Anant Kumar Feb 15, 2014

    I finally got around to opening up the hose attachment (where it attaches to the wand). one of the wires connecting to the hose was broken. Shaved off a bit of insulation, reclamped it and put everything back together. It works again! Yay!

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Vacuums Master
  • 1,069 Answers

There is an electrical connection at each end of the wand, it could be any of the electrical connections. Could be a bad wire from the lower connection into the vacuum

Posted on Jan 29, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

zeusfaber
  • 247 Answers

SOURCE: my vacuum kenmore canister smells

My guess would be a slightly loose belt - tight enough to spin the roller on a hard floor, but loose enough to slip (then get hot and stink) when the roller is having to work against the pile of a carpet. Worth buying and fitting a new belt without pausing to investigate further, simply because they're so cheap and you'll have to replace it sooner or later anyway. A.

Posted on May 16, 2007

SOURCE: Canister works, vacuum doesnt

There could be a break in the electric from the machine to the hose - or from the hose to the wand - or from the wand to the Power Nozzle - or it could be the motor is bad. 

Wiggle the cord at the Hose with it running- then go to the Wand - then to the Power Nozzle. You may find a break in the wires anywhere along the line.

unplug the Vacuum:

If you have a meter check to see if the reset is working - and last check to see if the motor will work removed from the Nozzle.

 

Ralph

ifix@shentel.net

Posted on Oct 20, 2007

LizDahl
  • 75 Answers

SOURCE: electrolux canister vacuum

The easiest solution would be to call your local Aerus/ Electrolux representative, because the corporation doesnt publish diagrams.

Posted on Jan 12, 2008

  • 1 Answer

SOURCE: Kenmore Progressive Model # 116 25914507

I had the same problem with my vacuum. I called in for technical service and was told to push the "reset button". It turns out that there is a small red button right next to the dirt indicator light. I pushed the button, plugged the vacuum back in and started it up and it worked like a charm! :) Hope this helps!

Posted on Mar 26, 2008

  • 7 Answers

SOURCE: Electrolux Renaissance power nozzle turning on and off, brass pins hot

The deal with the Renny is that it runs off of circuit boards. Usually the problem of the main motor shutting on and off is caused by one of the Triac boards located inside the canister. Another problem could be the thermostat wire located on the inside of your motor itself. It's almost never the thermostat, so the triac board is most likely the issue.

As far as your power nozzle goes, the head eminating from the swivel body is in most cases due to an older design of the power nozzle. I would suggest investing in a new elbow assembly that includes a new swivel body as well as newer style of wiring that is proved to reduce arcing and heat production within the power nozzle.

In some cases, fixing the power nozzle will fix the problems you are experienceing with the main motor as the arcing happening in the power nozzle can in fact turn off your machine. So investing in a new elbow assembly for your power nozzle could in fact solve the problem in its entirety.

Posted on Oct 29, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I received my dyson a few months ago. I have used it regularly and it performed very well. I used the brush bar on all the carpeted surfaces and turned it off when cleaning the linoleum floor. Just...


Hi Joanne, it's Jack at Dyson.

I'm sorry to hear you're having difficulty with your DC39 Multi Floor. If the brush bar only seems to be working intermittently, we should be able to help - and if a replacement part is needed we can confirm if this is covered under our 5-year warranty.

When you have your machine easily to hand, please give our experts a call on 0800 298 0298 (UK), 1-866-693-9766 (US), 1-877-397-6622 (CA) or 1800 239 766 (AU).

We'll look forward to hearing from you.

Oct 13, 2013 | Dyson DC39 Multi floor canister vacuum...

1 Answer

Canister powerhead brush does not seem to spin when the carpet level adjustment is on any level other than "high". Could it be something as simple as needing a new belt and is there a...


The belt is worn/stretched to the point that it cannot take the load on low level setting due to more resistance against the carpet and there is also no signifagant difference between the two belts except for expecting a longer belt life from the whisper belt. While it is apart make sure there is no hair or carpet strands in the rollers and around the belt pulleys

Jan 18, 2011 | Kenmore 25512/ 25513 Progressive Canister...

2 Answers

Can I buy a replacement powerhead for a Kenmore Magic Blue?


Power bar spins, but as soon as it't put on the carpet the beater brush quits spinning

Aug 11, 2009 | Kenmore Magic Blue 24195 Bagged Canister...

4 Answers

Hep! My 3 month old Hoover Mach 5 doesn't pick up!


What is happening is the secondary filters, HEPA and the canister all need to be cleaned. This is vital. What the vacuum repair people are keeping from you is that tidbit of wisdom. This particular vacuum is picky about airflow. Pull the canister, and on the body of the vacuum on top of where the canister sits are the secondary filters. There should be a sticker explaining how to remove them. Clean them throuougly, mine was filthy. Make sure you clean the canister by unlocking it and cleaning out the micro holes and the cone end. Mine was completely plugged. Now brush the dirty side of the HEPA filter with the combo tool. Let the secondary filters dry completely (you can blow dry them on cold) Re-install everything, and the vacuum will run like brand new. I vacuumed the whole house after I completed this maintainence and it works like a champ. Don't return this vac until you clean it completely.

Feb 06, 2008 | Hoover Commercial C1660-900 Bagless...

1 Answer

Kenmore progressive canister


belt could be melted to the motor that spins the brush, try free spinning the brush with your hand to see if the brush spins freely, if it does not the brush bearings could be frozen, or just need a simple new belt...hope this helps

Jan 20, 2008 | Vacuums

2 Answers

Canister works, vacuum doesnt


There could be a break in the electric from the machine to the hose - or from the hose to the wand - or from the wand to the Power Nozzle - or it could be the motor is bad. 

Wiggle the cord at the Hose with it running- then go to the Wand - then to the Power Nozzle. You may find a break in the wires anywhere along the line.

unplug the Vacuum:

If you have a meter check to see if the reset is working - and last check to see if the motor will work removed from the Nozzle.

 

Ralph

ifix@shentel.net

Oct 17, 2007 | Filter Queen Majestic Canister Vacuum

Not finding what you are looking for?
Vacuums Logo

Related Topics:

44 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18389 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...