Question about Cuisinart Blend & Cook Soup Maker

1 Answer

Blades won't spin

There is power to the blender and I can turn it on, but when I try to blend (even with it empty) all I get is a click and the blades won't spin. There is no other sound or smell. The heating plate works just fine. I have taken it apart and put it back together to make sure the blades, seal, and glass were assembled properly. Any ideas? It has only been used a few times, I would hate to have to replace it so soon. Thanks!

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Cuisinart Master
  • 34,170 Answers

The motor may have failed.

Posted on Dec 26, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: cuisinart sealing gasket

The gasket goes between the cutting assembly and the glass. So you slip it on over the top of the blades and then put the glass jar over top of that. Screw the bottom cap on to tighten everything together.

Posted on Nov 02, 2007

SOURCE: Black plastic "ring" that fits over the spindle on the motor base snapped

I just bought a replacement part on ebay. It cost about $11, which included shipping. buy-it-now-store.com

Posted on Feb 26, 2008

ThaMp3Doctor
  • 8596 Answers

SOURCE: connection between the motor and the blender unit

Replace the blade assembly immediately. They are available from Cuisinart's website. Sugars and other stuff can gum up the blade assembly over time, so it will periodically need to be replaced. A quick and easy way to keep the blade assembly clean and working longer is to put water and a drop of dishwashing soap in the blender after use and run the blender at low speed for 15-20 seconds - an old Osterizer trick.

Posted on Sep 29, 2009

  • 16 Answers

SOURCE: Cuisinart Quick Prep is not working properly

I think the ice was too hard for a hand blender. I think the impact has caused the blade to separate from the shaft or caused the shaft to separate internally. If your blender is still under warranty you might be able to get it fixed. Note: none of the "Smoothy" recipes in the manual call for ice. One uses ice-cream. One uses "partially thawed frozen strawberries" and one uses sherbet.

Posted on Oct 11, 2009

radar001
  • 1051 Answers

SOURCE: My Cuisinart blender has worked beautifully for

Make sure the gasket is fully seated and not uneven before you re-assemble the base and blade unit.

Posted on Apr 19, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Ninja blender blade wont turn with food in container.


make sure blade is pressed tightly onto shaft... should click into indent. if not then you need a new blade piece.- stripped

Aug 18, 2012 | Blenders

1 Answer

My wolfgang puck 1.6 hp professional blender will not spin the blades if there is anything in the blender container.


This is not really the solution it is just a better description of the problem that I am also having. This is a great blender however the part where the cup blades conect to the motor is made of plastic.
So what has happened here is that the motor is fine, the cup is fine only the plastic part that makes the motor turn the blades has worn down therefore rendering the blender useless. I would like to know where I could get this small part to change on my blender!!!

Jul 30, 2012 | Wolfgang Puck 1.6 Hp Professional Blender...

1 Answer

My blendtec blender doesn't blend as well as it once did. The motor seems to be running fine, but I am not sure if the blades are spinning properly.


You have already found what is the problem the blades.
The blades after a lot of working hours with ice they have mainly three problems.
One the sharp adjes have created a lot of teeths and are not so sharp any more so the blending is not smooth anymore.
Second problem they have loose a title so they have move from corect place some milimeters and this change the wave motion and again the beleding is not so smooth as before.
Third the blades are secure on an axis which is located in two bearings which have een wearing out so the rotating motion of the blades again is not so smooth as before.
So if you are not able to fix the blades kit or to find someone in your area to do it profetionaly and cheap one good idea is to buy a new blades kid.
Good luck

Aug 17, 2010 | Blendtec ABC Work Top Blender

1 Answer

Seems like motor has lost power


This sounds like the black rubber coupler has broken. The teeth often get knocked off. Have a look at the part shown in hte pictures here:
http://kitchenaidblenders.co.uk/Home/tabid/36/p/Two-%282%29-KitchenAid-Blender-Coupler-%2b-WS-Fitting-Tool-9704230_2plusWS/ProductID/175/Default.aspx

Jan 22, 2010 | KitchenAid Kitchen Aid Kitchenaid 5-speed...

1 Answer

A blade on my immersion blender was bent slightly. The motor still works and the blades spin, but they no longer emulsify. Can I buy just a new blade attachment?


If you have a model with the detachable blades. Otherwise, you'd need to purchase the blending rod from www.wpcookware.com.

Jan 16, 2010 | Wolfgang Puck Immersion Blender

1 Answer

The blades stopped turning in the middle of blending a batch of hummus Its is a Kitchen Aid blender about 10 years old


Does the motor still work if you take the pitcher off of the base? If so, the rod that's in the blade assembly is probably corroded. The blades are connected to a metal rod that passes through a brass tube through to the piece that makes contact with the motor when you put the pitcher on the base. The grease wears down eventually and if you don't pulse and run the motor for a long time at once, the heat can corrode the bar and cause the blade to stop spinning. You can either disassemble the blade unit, or buy a new blade unit online. google blender parts and you can get one for $10

Dec 22, 2009 | KitchenAid Kitchen Aid Kitchenaid 5-speed...

1 Answer

When trying to blend things like frozen fruit or frozen yogurt with the Vitamix, the blade stops moving, but the motor continues running. Even if there's only enough frozen yogurt to cover the blades, it...


Frozen elements are generally not recommended for blenders of any brand. They may cause the blade assembly to stop moving completely, or to "bog down," and this may eventually damage the motor. It is recommended that frozen fruits and/or yogurt be thawed when possible before placing into a blender. If this is not a possibility for you, I would use a "pulse" or "chop ice" function to rapidly spin the blades for just a moment. This will chop the contents in smaller, more manageable parts. This should be done before adding other liquid ingredients.

Jul 09, 2009 | Vitamix Blenders

1 Answer

Krups blender blade stops


well it looks to me there is some thing not tight enough connection to ur blade.....as u say it works when empty but when u put soemting in its stops....this means ur blade is not tight on the shaft to the motor......or u may have done something wrong when u had the blender open........recheck ur work and make sure its tight,,,,,
if so u will have ur ice cold drink....cheers i hope so for ur shake

Jul 03, 2009 | Blenders

1 Answer

Blades won't turn


If the problem is that the blades are jammed and you can't turn them manually, you can let it sit ( and dry out ) for a few days, or you can try adding some oil. I had the same problem and this worked. My problem now is that the blades don't reach to where the motor is turning, so even if they're not jammed the don't turn. If anyone knows and answer to this I'd appreciate it.

Jan 24, 2008 | Oster 6678 14 Speed Blender

Not finding what you are looking for?
Cuisinart Blend & Cook Soup Maker Logo

492 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cuisinart Blenders Experts

eyecam

Level 2 Expert

87 Answers

ray gallant

Level 3 Expert

43003 Answers

richie46

Level 3 Expert

12833 Answers

Are you a Cuisinart Blender Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...