Question about SPL Audio Phantom DK2-1000 Car Amp

1 Answer

No sound My Z2X1200 amp will turn on to protection then it goes off and the green light comes on but its not putting out sound. it will go from protect to green but no sound at all. is it internal? i have good connection, and i have good power supply, and its mounted good. whats the deal

Posted by on

  • albfliiesta May 11, 2010

    check the subs wiring

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 578 Answers

Unplug spkr from amp and leave rca and turn if this dont happen again check you spk
if it does happen again unplug rca and turn on and if this happen your amp may be bad

Posted on Jun 26, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Green light comes on for a sec the red light comes on,1200 watt sony xplod amp 10'' Orion sub,I think the subs right around 3000 watts. What's wrong?:(


Your Sony Xplod amplifier turns on briefly (green light) then possibly senses a mismatch between the nominal output impedance of the amplifier and impedance of your Orion sub and goes into protect mode (red light) to prevent internal damage.

Jul 19, 2014 | Car Audio & Video

1 Answer

Peavey DPC1400x turns on, plays sound for a split second, buzzes, then goes silent. All lights show green though. What could this be?


This sounds like a power supply capacitor leaking causing a dc bias problem and amp protection shuts it down.

May 06, 2014 | Peavey Audio Players & Recorders

2 Answers

Sony kf 50e200a screen goes black and sound turns off for min...


TV has gone into "protect mode" to do just that to protect against the damaging failure that has been detected, you will need a servicer to diagnose the failure. Good luck and Merry Christmas!

Dec 25, 2009 | Televison & Video

1 Answer

Speakercraft DBB12100 Amplifier, Circuit problem


Sounds like its a problem with over heating. open unit clean out all dust and dust bunnies wich compressed air. check that all fans are opperating. (fans on 6x100 amp units or thermal controled). If amp goes into protection prior to fans turning, there is your answer. the @ power supplies will have a green light on the output side. if the light in on power supply is good. or you can check that the output voltage is at 48Vdc on both units.

Sep 18, 2009 | SpeakerCraft DBB12100 12-Channel Amplifier

1 Answer

Green and red light are on my pyramid amp and its not working


It could be even simpler than that, yes an improper impedance rating on an amp will cause it to overheat, but should function temporarily until it reaches peak temp. If the outputs were blown the protect light should not light up being that they would need to work to cause the protect light to come on. I would double check all of your connections, one small little crossed wire would cause an amp to immediately go into a protect mode.

May 29, 2009 | Pyramid PB1217X Car Audio Amplifier

1 Answer

Power light turns from green to red protect mode and then there is no sound coming from my speakers


there are 2 reasons for it to be going into protect mode 1 is heat 2 is the load on it. if it is going into protect mode soon after it starts there is a problem with the speaker. if it is after it has been on for a while it is that the amp itself is overheating. hope this answers your question

Apr 27, 2009 | SPL Audio Phantom DK2-1000 Car Amp

1 Answer

Protection Light Comes on


your amp isnt getting enough power to it you may need to install a compacitor unit

Mar 23, 2009 | Sony NTX-2136 DHD 2Channel Car Amplifier...

1 Answer

Protection Light Comes on


Sounds like you have an ohm problem, Tryy hooking the positive from one speaker to the negative on the other speaker. Then hook the negative from the first speaker to the negative on your amp and the positive from the second to the positive on the amp this will drop your ohm load and the amp should stop going into protection.

Mar 08, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Protection light


double check the blue stereo input wire to amp is this a new amp if not speaker channels in amp might be blown

Nov 08, 2008 | Kicker KX120.2 Car Audio Amplifier

4 Answers

Red light


something is shorted in the circuit, or your subs. unhook the subs first and try it again, if it is still in protect then it is most likely the output transistors.

Feb 22, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

Not finding what you are looking for?
SPL Audio Phantom DK2-1000 Car Amp Logo

Related Topics:

96 people viewed this question

Ask a Question

Usually answered in minutes!

Top SPL Audio Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4844 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

The Knight
The Knight

Level 3 Expert

74106 Answers

Are you a SPL Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...