Question about Sony WEGA KE-37XS910 37 in. HD-Ready Plasma Television

1 Answer

Sony Plasma Wega KE-37XS920 No VideoSignal

My Sony WEGA does not display a picture, either from cable, dvd, or other media.  Had it fixed less than 100 days ago, Repair shop said it was one of the logic boards and claimed they replaced.  When I power the tv on the entire screen is filled with multi-colored pixel like patterns (pink, blue, grey etc...) that are vertical in nature.   I can see the tv menu screen over the top of it if used.

Posted by on

  • hawjim Oct 19, 2007

    the repair place that did the work went out of business....murohy;s law.  thanks for the advice

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

If you still have your receipt for repair...take it back for repair again.
This time, you should have some kind of warranty on the last repair, so you should have to pay minimal (if anything) to get it fixed again.

If it is the logic board, insist that you are given the faulty one....that way you can see that it has been done and you can then dispose of it at your leisure, "knowing" you have not beem conned into paying for services not given.

Hope this helps

Posted on Oct 17, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I need a replacementnbase stand for a sony wega 42" plasma tv


Contact Sony with the model number to see if available or not, other than that Google the model number with base to see what comes up, last resort might be to look on EBAY.

Dec 10, 2012 | Sony WEGA KE-50XBR900 50 in. HDTV-Ready...

1 Answer

Sony ke-32ts2u plasma tv went bang, blueish flash, turned off, then back on.. I smelled burning, so unplugged immediately, and went looking for obvious signs of something fried or melted. No sign, so I...


I doubt there is an easy fix but your situation suggest that you have a bad ground on that outlet and a short in the tv tried to go to ground through your cable itself. Plug in an "outlet analyzer" to both outlets. They are under $10US at supply stores such as Lowes and Home Depot. Through a combination of lights, it will report the status of the outlet

What you described is a failure in the power supply circuits for your display. You would need a wiring diagram and expertise. internal exchangeable fuses are rare anymore. They are usually a set of diodes which must be desoldered.

Sep 17, 2017 | Sony WEGA KE-32TS2 32 in. HD-Ready Plasma...

1 Answer

6 blinks


trying to locate you to ask you if you found out the problem to your sony ke37xs910 plasma 6 blinks. i have the same tv with the same problem. does your tv set have sound but no picture.

May 05, 2010 | Sony WEGA KE-37XS910 37 in. HD-Ready...

1 Answer

Sony wega not displaying HD correctly. All widescreen displays are stretched out.


Press the picture and wide mode buttons at the top of the remote. If that doesn't fix it try a dvd and cable. If only one of the sources " dvd/cable " work correctly the other is the issue.

May 05, 2010 | Sony Grand WEGA KDF-60XS955 60" Rear...

2 Answers

Sony WEGA KE-42M1 sound but no picture.


i have the same problem! did you ever solve the issuE??

Oct 16, 2009 | Sony WEGA KE-42M1 42 in. HD-Ready Plasma...

1 Answer

Thin Black lines going down my screen, sony Wega Ke-42TS2


These sets are common for bad connections on the ribbon cables connecting the screen to the drive printed circuit board. Or the drive circuit could have a bad drive scan IC. I doubt that but possible. Your going to need to call an AUTHORIZED sony repair servicer to trouble shoot this for you cause any other shop may not have a clue of this problem. Good Luck

Aug 08, 2006 | Sony WEGA KE-42TS2 42 in. HD-Ready Plasma...

Not finding what you are looking for?
Sony WEGA KE-37XS910 37 in. HD-Ready Plasma Television Logo

166 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Televison & Video Experts

The Knight
The Knight

Level 3 Expert

75417 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Jerry Greenberg
Jerry Greenberg

Level 3 Expert

1689 Answers

Are you a Sony Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...