Question about Biostar K8M800-M7A Motherboard

1 Answer

Motherboard i need a display of the mother board settings?

Posted by on

  • Anonymous Dec 09, 2007

    there is power but no display and no beep.

  • milsderick Dec 10, 2007

    my problem is when im turning on my pc with new hardware (motherboard p5pe-vm) there is no display when i connect it on a build in video card. i dont know wat to do plz help or there is something else to change in the bios setup thx



1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert whose answer got voted for 2 times.

  • Contributor
  • 4 Answers

This could be several issues. You need to be much more specific on exactly what you done and what you installed. No video boot could be the following:
1)Memory clock speed not compatible- Say board only see clock speeds of 200,266,333mhz but you installed 400mhz CL or the bios is not set to auto mem cl speed and you need to manually change mem clock speed.
2)Your CPU, memory, or video card not fully inserted
3)Memory module of video no good if it has onboard mem cells
4)You forgot to plug in the yellow/black CPU connector on the board sending no power to the cpu
5)CPU pin bent on install or not seated correctly
I could go on and on but there are a few issues that cause no video boot so double check all you cards and connections.

Posted on Jan 27, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

My board is breking the display after xp logo

you may have exceeded the resolution settings for you monitor
check the requirement before install a monitor to a new mother board.
Your display may be at 1600 X 1400 but the motherboard default setting may be at 1900X1080 there fore exceeding the displays criteria settings.

Mar 25, 2010 | MSI G31M3-L V2 Motherboard

1 Answer

No display on mother boards

Are these computers all emachines? this board is normally used in the emachine range of computers and have a problem with the architecture Call me ? chris 07926-106150

Jun 05, 2009 | Intel D845GVSR Motherboard

1 Answer

1. On board display card is not working 2. When we attach external vga card display is working but no BIOS image in mother board and it gives an error that BIOS image is scan. 3.Key board is not working.

who makes the mother board and what bios is it using? can u access the bios at boot up? if so, is the integrated video option on? have you checked for upgrades / updates for the bios ? if you can access the bios, remove all non integrated devices from the mother board, select the option for "default settings" save and exit. then restart. after assuring the keyboard is plugged in the correct port. it should be color coded.

May 19, 2009 | Gigabyte GA-K8VM800M Motherboard

1 Answer

Motherboards is running but no display..

mother board have a problem,if warranty is still now u sent mother board service center,my friend is same problem,he send mother board and now it is ok.

Mar 31, 2009 | EliteGroup ECS P4VMM2 Supports Intel...

1 Answer

I din't have mother board drivers

hallow dude looking for mother baord drivers ,,,,here is a website from where you can get alkl the drivers
all drivers --->

before downloading a drivers ,you need to choose your motherboard company

Jan 12, 2009 | Intel Motherboard

2 Answers

Mother bord not a display

mother board
not display show

Oct 19, 2008 | MSI K8MM-V Motherboard

1 Answer

Display chip in mother board is not functioning

sorry but i dont know where are we going to put another fan in your cabinet......

Jul 19, 2008 | Intel Motherboard

3 Answers


to get bios set up you must press DELETE key or F2 to enter set up...
you do this at the time of the booting ....
if your bios is corrupted then you can restore the bios by changing the bios jumper to restoration mode to do this refer to your motherboard manual...

Feb 22, 2008 | Intel Motherboard

Not finding what you are looking for?
Biostar K8M800-M7A Motherboard Logo

Related Topics:

84 people viewed this question

Ask a Question

Usually answered in minutes!

Top Biostar Computers & Internet Experts


Level 2 Expert

83 Answers


Level 3 Expert

781 Answers

Jerry Umali

Level 3 Expert

979 Answers

Are you a Biostar Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides