Question about Sony Car Audio & Video

1 Answer

Why is the Over Current light lighting up on my Amp?

Why is the ''Over Current'' indacator light lighting up on my Sony Xplod XM 405EQX ?
What can I do to solve it ?

Posted by on

  • Perry Babin May 11, 2010

    Does the OC LED light up red with no speaker wires connected to the speaker terminals of the amp?

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 192 Answers

This means the speakers are trying to draw more current from the amp than it's rated for. Generally this means the speaker wires or terminals have been shorted together. Check your wiring to make sure nothing is shorted.

Posted on May 21, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My sony xplod 1200 whatt amps red light keeps coming on all the wires are good when it gos to hit it gos red


check your ohm load on the sub and see if your amp can do the same, That is why every time it shuts off into protection mode. Check your gain level on the amp to this is not a volume knob for your amp, It is to get both the amp and cd player on the same page. Hope this was helpfull

May 19, 2010 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Xplod XM-554ZR Car Audio Amplifier: powr/protect light comes on red not green...


Hi, disconnect all speakers from unit and try again - if red light still shows then your amp has died.
If the light goes green, then start testing for shorted speaker/wiring. This includes speaker wiring to vehicle shorts - there should be an o/c reading on your meter

May 05, 2010 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Sony xplod amp(XM-1652Z ) power/protect light


if your amp is overheating your sub is needing to much power that the amp doesnt have.
if its cutting out and the red light comes on you need to check the wiring. nothing not even the tinyest speaker wires can be touching.
proper wiring would be your best bet.
but i would upgrade amps.
cheap bang isnt reliable.

Apr 06, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Sony Xplod 1000W workign strangely


need a bigger gauge hot wire going to your amp ,maybe a battery cap. amp isnt getting enough power to perform so it cuting out.

Mar 01, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

How to measure watts


You need a Volt Meter and an Ohm Meter. P = VI & I = V/r, so Power = (Volt^2)/Ohms .

You can get the ohms by hooking them up to the subwoofer input wires, and you get the volts by hooking up to the amp output terminals/wires. Although, amps will put out different voltages for different frequences, this should give you ballpark estimates.

Nov 10, 2008 | Sony Xplod XM-1652Z Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

330 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

xxxxxx xxx

Level 3 Expert

4970 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...