Question about Pioneer DEH-P390MP CD Player

2 Answers

Horrible noise coming from subwoofers

I went to circuit city to have my system installed in my Chevrolet Silverado about a month ago. I had them install a pioneer 390 indash, 2 10" mmats subwoofers, and a panasonic 1200 amp. After about a week of listening to music, i began to hear a weird noise coming from the subs when the volume was at 0. I took it back to circuit city to ask what was wrong, and when they replaced the head unit with a pioneer 590, the problem depleted. The subwoofers were constantly on and always making a small noise. They told me at circuit city that the headunit was "grounding out". Im not sure if that is the solution, but i am open to all answers, please reply to what you think the problem is. Reminder, everything was new a month ago. Thanks

Posted by on

2 Answers

Re: Horrible noise coming from subwoofers

My pioneer cd player was doing the same thing. i took in to a audio store in town and the dude fixed it in like 3 min. i'll ask him wat he did and come back

Posted on Aug 26, 2008

Re: Horrible noise coming from subwoofers

It is not the deck that is a load of crap.... I install radios all the time and never had that problem.. You had some idiot work on your audio and he did something wrong. Now my first question is if you have an amp that was later added or put in at the same time. Allot of the time they wire the rca's and the speaker wires in utilizing the harness adapter. Duh,,,, right... Second, they made their own ground which consisted of them tapping into metal under the dash... now think about this that winding noise is probrably from the stereo being grounded to the same place as everything else in your car when they should have used a factory ground.. My suggestion is you paid for it... Make those **** fix what they did until they get it right if they keep fucking up start demanding free shit.... your time is being wasted on their fuck up take what ever you can from those assholes...

Posted on Feb 20, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

The radio/cd player on my 01 yukon loses the sound randomly. Some times it works fine then othertimes it does it a lot. This all started a month ago. Before then I'd had no problems. I talked to a guy at a...

sounds like the amp is over heating and needs to be replaced
and yes there is most likely an amp in the system and it is eithor over powered or over heating

Jul 29, 2009 | Car Audio Receivers

1 Answer


what model number do you have?

Apr 20, 2008 | Pioneer DEH-P6800MP CD Player

3 Answers

Subwoofer makes a loud bass machine gun noise when powered up

Well, I have the same problem and I would think it has something to do with the RCA-connections. If I power up my head unit while I have my main fuse for the amp's removed and then replace the fuse as the head unit is already playing music (thus putting out a current through the RCA-connections) it works just fine. But if I just power up my stereo with the fuse in, my subs go all crazy. I guess it has something to do with disruptions in the rca cable. Maybe they are drawn too close to some power cables or speaker cables? Good luck!

Feb 12, 2009 | Alpine IDA-X300 Car CD/ MP3 Player

2 Answers

Annoying noise from the screen itself

hi, does the noise come from the screen or speakers?
ie is it an electrical buzz, or an audio buzz?


Nov 25, 2008 | Alpine CDA-9885 CD Player

1 Answer

Zeros on the display

where you bought it should have a record of you buying it as well, make sure to bring all thr proof who you are, and try to remember the date you bought it. all the info you can give will help them locate the sales tag.

Sep 30, 2008 | JVC KD-PDR30 CD Player

1 Answer

Sony CDX-GT310. Installed by Circuit City about 15 months ago. CD works fine. No sound from radio (both AM & FM). I've manually tuned through the range of stations with no reception. Checked...

Called a shop in VA and their opinion was that the tuner section of the unit failed. Cost of the part, $80. Then, labor and shipping. I can buy the new model (GT320) for about $95. I opted for buying a new unit.

Aug 11, 2008 | Sony CDX-GT310 CD Player

1 Answer

JVC Car Stereo Very Noisy

Bought new JVC stereo and installed it. No noise, no cracking. 1st stereo must have been bad.


1 Answer

How to remove MP7610

you can purchase the keys through me for $5.00 plus postage. Email me with any questions or if you would like to make the purchase. . My shop M&M Car Audio is in mishawaka, In

May 18, 2008 | Jensen MP7610 CD Player

2 Answers

DEH-1900MP - lost functionallity after disconect/connect batery

Yes for some radio's if you take away power it has a theft lock and will not let you back in except if you have the code. To reset you must take power away from it. I would suggest if you don't want to take cd player out of car then disconnect battery. then when reconnect eject. May have to set for a moment.

Sep 21, 2007 | Pioneer DEH-1900MP CD Player

1 Answer

Cold Blooded Stereo

Switch the input wires from the sub to the speaker amp and vis versa. See if the problem switches to the other amp. If it does, you know you have a fault in the head unit. If it stays in the same amp, then you know you have a problem in the amp unit. Check with the manuufacturer online about how long the warranty is on each unit. Maybe they are still covered. Good Luck Please do not forget to rate this thread.

Nov 26, 2006 | Alpine CDA-9856 CD Player

Not finding what you are looking for?
Pioneer DEH-P390MP CD Player Logo

84 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pioneer Car Audio Receivers Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

xxxxxx xxx

Level 3 Expert

4679 Answers


Level 3 Expert

56798 Answers

Are you a Pioneer Car Audio Receiver Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides