Question about Blaupunkt PA4100 Car Audio Amplifier

1 Answer

Noise in amp/spreakers

I have a  Blaupunkt PA4100 amp that was installed new in my 1999 Dakota. From the beginning the system made a ticking/popping noise when I turned it on. The level of the noise did not change with volume adjustments. The noise started out fast, higher frequency, 15 or so clicks per second, and slowed down to one or two per second before quitting altogether.  The colder the unit was the longer it took for the clicking to stop. The unit was replaced by the store I bought it from and the new one had the same problem. Twin devices that look like capacitors were wired inline with the amp but had no effect. Any Idea what that was and how to fix it?  The amp has great sound and I want to use it in another system.


Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: Noise in amp/spreakers

Hi there thre is several things it could be . try  a ground loop  iso-latter.   and it could be  a bad ground.  as well ..  and could be a bad altinator  wine is  caused by  signal interferance coming from your altinator  .. try  a  10  0r 20 amp  noise  filter  sold  at  autozone  or radio shack.  sincerly  terry howard  . e-mail is 

Posted on Oct 24, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

I need a radio code for blaupunkt 2003

Post all the letters+numbers on any labels, barcodes or stamped in the metal casing.
Include 14 character Serial Number beginning with GM or BP plus model number beginning 7 *********

Jul 16, 2010 | Blaupunkt Car Amplifiers

1 Answer

I want to no how to tune a blaupunkt gta1350hp amp so it sounds good running 2 earthquack 500 watt rms amps


Feb 07, 2010 | Blaupunkt PCA250 Car Audio Amplifier

1 Answer

My blaupunkt gta 460 goes into protection

Check the speakers wires for a wrong connection,check the speakers maybe they are not support the power of the amplifier,good luck

Jun 05, 2009 | Blaupunkt GTA 460 4 Channel Amplifier 800...

1 Answer

Engine noise is picked by amplifier how to eliminate it is an petrol car ????

if the power cable is running next to the rca leads you will get engine noise, also if you have a bad earth or insufficient joins in the power or earth wires you will get engine noise, hope this helps

Apr 01, 2009 | Blaupunkt PCA465 Car Amp

1 Answer


that is a bad ground clean exsisting ground or find a new spot where the ground is no longer than 18" if possible

Mar 24, 2009 | Car Amplifiers

1 Answer

No Sound out of my speakers

The last Kenwood that I had witnessed with a flashing power light was defective. It also caused the subwoofers to move slowly back and forth. More than likely, you have an internal issue with the amp. Call Kenwood, and see how much they would charge to have you send the amp in for repair. Or pick up a new amp.

May 11, 2008 | Kenwood KAC-959 Car Audio Amplifier

2 Answers

Replacing a Blaupunkt Reno with Florida


This is a PIC mybe can be help you...



Jan 27, 2008 | Blaupunkt PA4100 Car Audio Amplifier

1 Answer

Orion XTR Pro 1000 amp ticking

the amplifier output transistor or ic may be damage, its the relay may be thats ticking, or if not the output going to the speaker may be shorted or overloaded with low impedance, you may remove some speaker and try again.

May 18, 2007 | Orion XTR Pro 1000 Car Audio Amplifier

Not finding what you are looking for?
Blaupunkt PA4100 Car Audio Amplifier Logo

77 people viewed this question

Ask a Question

Usually answered in minutes!

Top Blaupunkt Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Blaupunkt Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides