Question about Kicker SX650.1 650W Mono-Block Amplifier w/Remote '04 Series

Open Question

I cant get power to the amp, everything is hooked up right, i replaced the power cord fuse... what else could be wrong,...???

Posted by on

  • Tyson Strickland
    Tyson Strickland May 11, 2010

    have you checked the cable for power?

×

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 87 Answers

SOURCE: I cant get power to the amp, everything is hooked

Check in this order:

  1. Battery connection
  2. Fuse at battery
  3. Ground wire at vehicle
  4. Bat. and ground at amp
  5. Remote turn on lead should read 12v
If you have no power at the turn on lead pull deck and see if it cam disconnected, should be blue w/ white strip.

Posted on Jun 02, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kenwoood kac-7202 redlight/no output


you blew the output Ic's (amps one or more ) you can fix this by replacing the output IC's

Jan 29, 2014 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

Cant get the fuse out


The fuse is in a "boat" right next to where the power cord plugs. Pry outward on the tab of plastic where the power cord plugs in. The tabe is about 1/4 inch wide.

IF THE FUSE HAS BLOWN, better find out why as replacing it MAY cause further damage to internal components. If you do replace it and it blows again, take amp in for servicing.

Mar 06, 2011 | Ibanez Tbx150h Tone Blaster Xtreme Guitar...

1 Answer

I have a visonik 800watt amp and i got it from a friend for free and i hooked it up right and as soon as i turned it on the 2 fuses blew then i replaced them and tryed it again and it stoped again so i...


Its the amp, do not put any more fuses in it
you need to get it checked out by a technician.

Its probably a power supply fault or blown output devices.

Hope this helps
Thanks for using FixYa

Aug 02, 2010 | Visonik V2508 2-Channel Amplifier

1 Answer

My amp is flashing in and out of protect


you must likey just fryed the wires, try putting in bigger fuses, and unhooking everything and re hooking it up

Jun 13, 2009 | Power Acoustik GOTHIC OV2-1800 Car Amp

1 Answer

Cant find a replacement fuse for the power cord


the fuse is located in the cigarette lighter plug, at the end you will see a silver cap and then the disk that goes over the top of it, that will turn and then you will have the front open to replace the glass fuse that is in it... to find the fuse size, after the fuse is out look at the silver ends it will have the size stamped on it... it might be a 40 amp fuse. or 20 amp. just look at the silver sides on the fuse you will find that there... hope this helps you out

Jun 03, 2009 | XRS-757 Radar Detector

1 Answer

I cant get power to the amp, everything is hooked up right, i replaced the power cord fuse... what else could be wrong,...??? the green led light is off and i tested to volts on the remote terminal and it...


Check in this order:
  1. Battery connection
  2. Fuse at battery
  3. Ground wire at vehicle
  4. Bat. and ground at amp
  5. Remote turn on lead should read 12v
If you have no power at the turn on lead pull deck and see if it cam disconnected, should be blue w/ white strip.

Jun 01, 2009 | Kicker SX650.1 650W Mono-Block Amplifier...

1 Answer

JVC KD-s34


and the speakers are hooked up right ?
then it should be working..

did you check the fuses ?
did you check if it comes on with the car started?
are the wires the correct amp ?
try connecting both wires directly to the battery ?

if all that is correct then by all means you got everything hooked up corectly and it should work, return it to the store and have them check if its working correctly

Jul 12, 2008 | Car Audio & Video

1 Answer

Dont know whats wrong


You can check the fuses if it has more than one. Or another thing that might be wrong is that you might have to big of a speaker hooked up. Or your power wire might be to small because if its two small then the amp cant get enough power to power a big speaker.

Jan 25, 2008 | Earthquake Sound PH-D3 Car Audio Amplifier

Not finding what you are looking for?
Kicker SX650.1 650W Mono-Block Amplifier w/Remote '04 Series Logo

Related Topics:

66 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kicker Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

yadayada
yadayada

Level 3 Expert

75066 Answers

Are you a Kicker Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...