Question about MTX JackHammer JH202 Car Audio Amplifier

2 Answers

Jh202 amp works for a few minutes stops for a few minutes any ideas

Posted by on

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 149 Answers

Hard to say without more info. Lets just be optimistic and figure that you have installed the amp with a good 8 gauge power supply at the least and you have checked all connections at the battery the ground and your remote lead and that all is fine and dandy. Then lets say that you have your gain on the amp matched with the voltage output of your head unit-if you dont know the voltage that your head unit supplies to the rca outputs then you can look up your decks model number online and check that out easily enough.If it all looks good from there turn your system on half volume without eq setings maxed out just kep the bass and treble in the middle areas sub volume level if it has one at half as well- let it play that way for a few minutes and see if it stays on.If the amp shuts down still at that low of a volume setting then disconnect your speakers from the amp and turn the system off and then on again.This is to check if its the speakers shutting the amp down or if its a problem with the amp itself. If the amp stays on then likely one of your speakers is partially blown and is causing the amp to go into protect mode.Make sure that your speakers resistance measured in ohms are compatible with the specified range set by the manufacturer.IE. the amp is made to run bridged @ 4 ohms-you cant run a pair of 4 ohm speakers in parallel to the amp bridged because the amp will see the parralleled load as a 2 ohm load and will overheat and shut itself down.Try checking that stuff out and good luck to ya

Posted on May 11, 2009

Ad
  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 40 Answers

Sounds like the amp is going into Protection Mode. Does yours have green LED light then RED LED on it? The green is power and the red is Protection. You will need to either change the OHMS wiring or Put A Fan on it to Keep it Cool Inside.

Posted on May 11, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Suddenly stops working and have to wait for a few minutes for it to work again.


Probably a component in the power supply is overheating, You need to take it to the repair shop.

Apr 26, 2015 | Behringer Ultratone K3000fx 300w Keyboard...

1 Answer

Our 2003 gmc yukon xl will completely stop running after driving it for an hour or so. after letting it rest for a few minutes, it will start and run again for awhile then stop again. the longer it rests...


With numerous shop visits,I don't like
to even suggest anything --BUT --

I would be almost certain, that the fuel pump
is worn & binding up & the shops, as strange &
sad as it sounds,do not know how to test it

Jun 29, 2011 | 2003 GMC Yukon XL

1 Answer

Hi i have a mtx jackhammer JH202 amp and a mtx jackhammer jJH5510D sub and every so often when a song is playing there will be bass and al of a sudden it will shut off and after a few minutes it will come...


The problem was caused by you trying to run a 2OHM load on an amplifier which is designed to run only on 4OHM when it is bridged, the amplifier is most definatley cooked. An authorized MTX technician should take a look at it, to determine just how wide spread the damage is.
dreamsystems.

Feb 11, 2011 | MTX JackHammer JH202 Car Audio Amplifier

3 Answers

Marshall MB4410 - Dies and comes back to life every few minutes..


Our bassplayer had the same problem with his mb4410. As it turned out, the fan was not working when the amp got hot. It did turn when cold - go figure! Swap the fan for a good quality (Pabst, Sunon) 80mm pc fan with 2-wire connection. Three or four wire fans will not work w/out modding. See your local pc guy and ask for an unregulated, silent 24/7 fans. He will know. Our bassplayer sold the P.O.S. while still in warranty. HTH.

Apr 26, 2010 | Marshall MB4410 Bass Combo Amplifier

1 Answer

Lincoln 135 PRO MIG Welder feed stops after a few minutes


1/4" plate with a 135 amp machine is probably beyond it's duty cycle abilites. If you are using a mixed gas, and pushing the max on the settings, it will be cutting out because it is designed to.
You might want to get a higher amperage welder for consistent welding of 1/4"
The 140 Pro maxes out at 5/16" using inner shield wire. and 1/8", or 10 guage with gas.

Mar 19, 2010 | Welding Tools

2 Answers

My kenwood kfcw3011 stopped working. Amp indicator still on.


here is what you would do. the next time that your speakers cut out. leave everything running goto the speaker and slightly push on it. if the speaker starts to work again you have blown the coils loose and they are not making contact all of the time. you need to replace your speakers, or they could do more damage to your amp or head unit

if i have helped you in your issue, please leave a good rating. If you have further ?'s you can contact me at mega_muzik@yahoo.com

Oct 27, 2009 | Kenwood KFC-W3011 Car Subwoofer

1 Answer

No LED power lights go on


the light with the power light(middle) is a blue/purple faint light try checking it out at night.The squiggy(as heat waves) will only light when the amps shuts down due to thermal protection(wait for it to cool). The bolt/yellow (short circuit) will light when there is an electrical overload in any of the wires(check +ve leads).

May 26, 2009 | MTX JackHammer JH202 Car Audio Amplifier

2 Answers

Mtx audio jh202 amp


my amp is blowing fuses?? any hints?

Feb 03, 2009 | MTX JackHammer JH202 Car Audio Amplifier

1 Answer

Protection light won't stop blinking/ Subs don't work


The amp probably has shorted output transistors to eliminate other possible causes, read through the following page. Let me know if you have any other questions.

Amp in Protect Mode - Troubleshooting

Oct 07, 2008 | Kicker 06ZX750.1 Car Audio Amplifier

Not finding what you are looking for?
MTX JackHammer JH202 Car Audio Amplifier Logo

294 people viewed this question

Ask a Question

Usually answered in minutes!

Top MTX Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

yadayada
yadayada

Level 3 Expert

76132 Answers

Are you a MTX Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...