Question about Aprilaire 600 Humidifier

2 Answers

Aprilaire 600 humidifier solonoid valve chattering in sync with d10 led

I turned on my furnace today and heard a noise from the basement.  It turns out it is the humidifer and it appears to be coming from the actual control panel in increase or decrease the humidity level.  When I turn the dial completely off - a led inside the panel labeled D10 flashes.  If I turn the humidity on - it chatters - in sync with what I believe is the solonid valve.  I disconnected power to the solonoid valve and it still flashes but does not click.  I took apart the solonod valve and inspected it, but it seems ok.

Posted by on

  • 4 more comments 
  • mjbeeler Nov 17, 2007

    I have an Aprilaire 700 humidifier relay chattering. There's no call for heat on the system, but the relay is chattering and the D10 LED is flashing at the same rate - any ideas what is wrong?

  • rstpeter Nov 23, 2007

    I installed Aprilaire 600 two years ago. This week when I turned furnace on, I found the same problem as you guys described above. Is any one can help with this? The problem is control panel or solenoid?

    Thanks.

  • Anonymous Jan 02, 2008

    I have the same exact problem as the two previously mentioned. We have had our 600 since 2002 and have had no problems until this past fall.

  • jasonsimms Nov 23, 2008

    Same problem here.  The red LED on the inside of the control panels chatters at the same rate as the what I think is the solenoid.  If I put it on test, it kinda goes away.  Put it on normal setting and it chatters.  Water is flowing during all of this, however.  I'll keep poking around....

  • kingofbytes Nov 23, 2008

    I have the exact same problem except this is with the Aprilaire Model 400 unit. Exact same problem. "Test" works with no problems. Turning it off shows D10 red light blinking. Properly turning it on yields the clicking noise. I will purchase the MFG#: 56 Humidifier control for $84 at IAQsource and see if that works.

  • foscaldo58 Jan 18, 2009

    I have the same problem on my Aprilaire 600 unit. I took a shot and replaced solenoid and it was wrong. The new solinoid is doing the same chattering when on. I am going to buy a new control panel as that seems to be the only thing left to replace.

×

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I fixed my problem by ordering a new control unit (model 56) from IAQSOURCE. Installing the control unit took a few mintues, and once the new control module was installed, I've had no more problems. The URL is as follows: http://www.iaqsource.com

Posted on Jan 22, 2008

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have exactly the same problem and the only thing that helps is to turn the control to "off" for several hours, then turn it back on to a low setting (2 or 3). This helps for a few weeks before the problem comes back.

Posted on Jan 20, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My aprilaire 600 continues to have water running down the drain at all times, whether the furnace is running or not.


Hello, usually when a humidifier continues to run with the furnace off it means that the solenoid valve is stuck open and must be replaced.

Feb 19, 2011 | Aprilaire Humidifiers

1 Answer

Will the water only come on going thru the water solenoid only when it calls for water? Or is it suppose to come on at all times when furnace comes on?


The water should come thru the solenoid valve when the furnace's blower motor turns on, and turn off when the blower motor turns off.

Jan 04, 2011 | Aprilaire 600 Humidifier

1 Answer

Water runs without furnace running


If this is a new problem, on an existing humidifier, then it is most likely a bad solonoid valve. This is the valve that the water line is connected to, and it controls the flow of water to your humidifier.

If this is a problem on a newly installed humidifier, it is possible to have wired the humidifier directly to the transformer power, and therefore holding the valve open all the time.

Hope this helps

Nov 03, 2010 | Aprilaire 700 Humidifier

1 Answer

Our aprilaire humidifier is only 4 years old and it does not seem to be working. We have static in the house and when I did test mode it never drained water like it was supposed to. Any ideas what I can do...


Hope this helps, check and see if humidistat is set to 35% humidity and that bypass damper on humidifier is in the open position or winter position.(humidistat is usually located on cold air return duct near furnace). Next, replace humidifier media pad, remember to replace media pad (filter) annually, you also may want to clean any lime deposit out of humidifier housing with a solution of warm water and white vinegar before installing your new media filter.Remember to turn power off at side of furnace when cleaning humidifier and replacing media. Before installing new media turn power back on to furnace, set humidistat to the on position, turn furnace thermostat above room temp., and inspect humidifier to see if water is running from top,(you may want to have a bucket under humidifier when checking for water), if you see water running, turn power back off to furnace, properly install new media filter, reconnect humidifier cover & set humidistat to 35%. If you do not see water present, check water supply valve to humidifier and make sure its turned on. If water supply valve is open, then check water supply tubing for blockage.And the last things to check is to make sure all registers through out your home are open and not blocked by any objects, also make sure furnace filter is cleaned, if none of this works refer to installation manual to see if humidifier was sized and installed properly, Good luck.

Mar 03, 2010 | Aprilaire 600 Humidifier

1 Answer

Loud vibrating noise when the furnace blower starts up.


Try closing damper slightly between humidifier and furnace????

Feb 03, 2010 | Aprilaire 550 Humidifier

1 Answer

Aprilaire 600 humidier: water continuously runs


sounds like you may have it wired to a continuous power source vs one that shuts off with the furnace. The most common wiring is red to C & white to W

Jan 08, 2010 | Aprilaire 600 Humidifier

1 Answer

Aprilaire 600: water only runs in "Emergency" Heat mode


When your unit is on normal the outside unit works and the inside only the fan runs. your heat pump does not remove any humidity when it operates so the installation cotractor did not wire it to operate then. you can change the wiring on the humidifier to operate all the time by wiring it to the fan (g) terminal then it should work just turn it all the way to the lowest humidity when you are in cooling mode.

Jan 07, 2009 | Aprilaire 600 Humidifier

1 Answer

Turning on the humidifier shuts off the furnace


It is possible you may have wired it wrong. Make sure your humidifer is not robbing power from your thermostat. This would explain when your humidifer makes a demand to come on it robs power from your t-stat making it lose its call for heat. Wire your humidistat to the "w" terminal and the common terminal so it only runs on a call for heat. With the bypass type of humidifier you purchased it wont do you any good to run when the heat isn't running anyway. If you want an independent operation humidifier you need a steam type.

Dec 02, 2008 | Aprilaire 600 Humidifier

2 Answers

Loud "Glonk" when humidifier turns off


Try turning the water valve going to the soleniod down. There may be too much pressure. You may have to replace solenoid one more time after making the adjustment.

Mar 12, 2008 | Aprilaire 700 Humidifier

3 Answers

Aprilaire 600 - change water panel light stays on


Turn the control knob to the test/reset position untill the change water panel light blinks to reset the change panel timer. Make shure the furnace is running calling for heat.Turn control knob to prior setting after resetting timer. Hope this helps.

Feb 16, 2008 | Aprilaire 600 Humidifier

Not finding what you are looking for?
Aprilaire 600 Humidifier Logo

972 people viewed this question

Ask a Question

Usually answered in minutes!

Top Aprilaire Humidifiers Experts

Paul Carew

Level 3 Expert

3238 Answers

jdthefixer

Level 3 Expert

744 Answers

Mack Baxter

Level 3 Expert

383 Answers

Are you an Aprilaire Humidifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...