Question about Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum

1 Answer

7901 I have a 7901 but will not dispense water and suction is excellent motor is good new belts just need a sequence of troubleshoot procedures

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers
Re: 7901

Does water squirt out of the hose nozzle, if it does, then check the heater inside the handle asm. Make sure that where the tubes hook up to it are not clogged. If water doesn't squirt, check for the seal at the bottom of the tank, it needs to be on the tank, not in the hole. The flow indictor cap is leaking air or maybe is too tight. If you had the top cover off, make sure that the tubes are routed right so as not to get pinched when the cover is put back on, the smart mix knob should be in the water setting and that the piston is on the bottom of the smart mix know. Pump is bad.

Posted on Jan 17, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

2 Answers

Will not **** the dirty water back in.

check for clogs in hoses and head.mine gets clogged up all the time.

Jun 06, 2010 | Bissell 7901-1 ProHeat Scotchgard Upright...

1 Answer

Machine w/not squirt

have you check the spray nozzle or spray line for s clog? only other thing you didn't list? let me know?

Aug 23, 2007 | Bissell 7901-1 ProHeat Scotchgard Upright...

1 Answer

Water wont come out

I have a Proheat 2X and had the same problem. I tried the Water Rinse setting and found water came out and was suctioned properly, but on the Light Clean, Normal Clean, and Heavy Traffic settings, the unit failed to do anything. Problem may be with leaving the soap dispenser in-place, which might scum up the tubing.

SO, an alternative to throwing out my unit and buying something else was to put one capful of the Bissell soap in the water resevoir and keep the unit on Water Rinse. IT WORKS BEAUTIFULLY NOW. Don't know if this will help, but at least I didn't have to buy a new unit. Rinse everything after using and there's been no problem.

Apr 21, 2010 | Bissell 7901-1 ProHeat Scotchgard Upright...

1 Answer

Machine will not dispense water or cleaner

That means that the pump belt is worn, stretched or broken and it needs to be replaced. Here is a link to the belts you need and the manual.

Bissell Proheat Belts and Manual

Dec 29, 2009 | Bissell 7901-1 ProHeat Scotchgard Upright...

1 Answer

Bissell proheat 2x leaves dirty water spots

Your belt for the brush might need to be changed, that or the suction parts is clogged with hair or fuzz, check that clear part of the front of the machine to see if theres anything clogging it

Sep 14, 2009 | Bissell 7901-1 ProHeat Scotchgard Upright...

2 Answers

Need directions for changine belt for brushes

There is a door on the side pop it off remove the old belt and simply slide the new belt on. Over the motor shaft first then the roller brush end.

Apr 12, 2009 | Vacuums

3 Answers

Not dispensing water and no suction

I'm assuming the belts are OK.... Your heater is clogged. Unplug the machine and let it sit for 30 minutes. Take the handle apart, there will be a 4 inch by 8 inch metal box inside. This is the heater. Remember I said to let the machine sit for 30 minutes? If you didn't, the heater may be EXTREMELY hot!! Disconnect the two hoses going into it, and clean the metal pieces out (that the hoses connected to) with a needle or very small drill bit. You may want to remove the 6 or 8 screws holeding the heater together and remove the cover to clean it out. Reassemble and fill both tanks with VERY hot water ONLY and run the machine to rinse the entire system.

To prevent future reoccurences... use only Bissell extraction shampoos. Never put anything in the detergent tank except shampoo. (And only water in the water tank) Mixing chemicals with anything else turns the water/detergent mix to sludge. Also, when finished shampooing, put ONLY water in both tanks, and run the machine until one of the tanks run out of solution. Doing this rinses the hose lines out and prevents hardening of the solution in the heater ports.

I've fixed these machine for years. No dispensing is almost always the heater clogged.

Sep 29, 2007 | Bissell 7901-1 ProHeat Scotchgard Upright...

2 Answers

Low Suction/No Soap

Check the seal at the bottom of the dispenser, it needs to be on the valve not sitting in the hole, part 2101795 if you need to replace it. If suction is low, check the filter on the bottom of the tank lid, if clogged, suction will be low. Also check window gasket, sits between the tank and the nozzle window, if missing, you won't have any suction part #2104052.

Sep 28, 2007 | Bissell 7901-1 ProHeat Scotchgard Upright...

Not finding what you are looking for?
Bissell 7901-1 ProHeat Scotchgard Upright Wet/Dry Vacuum Logo

64 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bissell Vacuums Experts


Level 3 Expert

18259 Answers

Roger Potts

Level 3 Expert

694 Answers

Brad Brown

Level 3 Expert

13369 Answers

Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides