Question about Subaru 2007 Outback 2.5I Limited A/C Compressor

1 Answer

Acceleration I am having an acceleration problem car will start fine and run at idle fine but when I drive it sometimes won't take power. I see this happening in more wet rainy conditions when driving and I put my foot on the gas it will not accelerate. the check engine light was blinking but not staying on. I did have a full tank of gas at the time. Later today car was running fine no check engine light. I have had this problem before in the rain 40,000 miles before. Outside temp was 50 degrees 100% humidity (foggy)

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,198 Answers

A dirty air filter will be worse when damp.

Posted on Nov 28, 2013

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine cut out


Sounds like you may have fuel filter problem. you may want to check the pump and filters located in or near the fuel tank.
Go directly to the source ( Fuel Tank, Pump, Filters, Fuel Pressure Regulator and Injectors )
You may have water or grit in the fuel
Hope this helps

Mar 22, 2014 | GMC Sonoma Cars & Trucks

1 Answer

My 1997 Jimmy runs fine in idle when I take off the vechile is fine until it reaches 20 mph it won't accelerate and the rpms increase up to 3000 but no speed. What's wrong it's a 4 wheel d


Sounds like 2nd gear in the transmission is slipping. Cars usually shift at 15-20 mph from first to 2nd. First check the trans fluid.

Mar 17, 2013 | 1997 GMC Jimmy

1 Answer

I have a 1996 Isuzu Hombre. Sometimes it won't start and just turn over. It also dies sometimes while driving or just idleing at stop sign. When this happens there is a clicking and buzzing sound


Sounds to me like a bad battery, however the alternator could be bad as well if it's not charging the battery enough to allow for amperage to crank. Auto Parts Forum

Jul 19, 2017 | 1996 Isuzu Hombre

1 Answer

Harley sportster won't accelerate after warm... Idles fine top end is fine


Hi Anonymous, if you have a carburator the usual suspects are:
1. Damaged or restricted fuel tank venting system (gas cap).
2. Inlet system air leak.
3. Vacuum piston malfunction.
4. Accelerator pump leaking or no output.
5. Plugged bowl vent.
6. Fuel level (float chamber) too low.
7. Restriccted fuel supply passages.
8. Plugged jets or passages.
9. Worn or damaged needle or needle jet.
10. Enrichner valve not seated or leaking.
Good luck

Jun 25, 2012 | 2005 Harley Davidson XL 883 Sportster

1 Answer

1995 pontiac bonneville stalls


I just went through lots of troubleshooting and expense on my 1996. Whenever I would lift my foot off the accelerator and was below about 30 mph, the rpm's would starts jumping around and sometimes it would stall. If I gave it a little gas (accelerator), I could sometimes keep it running. It also backfired once in a while. Starts right back up. Also, if I let it idle while in part, it would die after 1-2 minutes.

I ended up finding a hole in the fuel regulator. About a ~$70 part if you get an AC Delco, but very simple to change.

Nov 27, 2008 | 1995 Pontiac Bonneville

3 Answers

944 turbo throttle dropout problem


I would start with the TPS, and if it doesn't solve it then the AFM would be the problem.

Nov 22, 2008 | 1986 Porsche 944

1 Answer

96 GMC Vandura idle problem and sometimes acceleration problem


accelerator pedal position sensor/ throttle position sensor/ motor
idle problem under load could be idle rpms too low
ICT sensor
run the fault codes

Apr 24, 2017 | GMC Vandura Cars & Trucks

Not finding what you are looking for?
Subaru 2007 Outback 2.5I Limited A/C Compressor Logo

92 people viewed this question

Ask a Question

Usually answered in minutes!

Top Subaru Air Tools & Compressors Experts

Lawrence Oravetz

Level 3 Expert

9587 Answers

Joe Garcia
Joe Garcia

Level 2 Expert

205 Answers

Bill Boyd

Level 3 Expert

42042 Answers

Are you a Subaru Air Tool and Compressor Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...