Question about Homelite For Excell - Pressure Washer Pump 2700 Psi 7/8" Shaft

1 Answer

My Excell Pressure Washer XR 2750 won't start. I believe it's a timing problem. How can I solve this problem?

My machine suddenly turned off and won't start again. The exhaust valve was broken. I replaced it with a new one, but it doesn't start. I also replaced the timing belt with a new one. I need to know the exact timing points for the timing belt.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 794 Answers

You'll need to know who manufactured the motor (Honda, Briggs & Stratton, etc) along with the model and serial number. With that information, you can do an online search for small engine repair manuals and retrieve the specs for you particular motor.
You can even call your local outdoor power equipment repair shop, they'll provide you answers to your questions.

Posted on Nov 27, 2013

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Bike is starting and backfireing,cant give any gas or it will die. this is be couse of lack of gas fro secondary ?


Hi, Michael and the usual suspects are:
1. Severely discharged or a damaged battery, should have 12.5 volts or better and be able to pass a load test if necessary.
2. Check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage check for spark leakage in the dark.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
For more information about your issue and valuable "FREE" downloads that you will need please click on the blue links below. Good luck and have a wonderful day.
Won Start Just Turns Over And Backfires Fixed
Engine won start backfires out the exhaust
Bike won start just turns over and backfires Any ideas CBR Forum...
Loud bang backfire when starting cold
my bike backfires but will not start Honda Motorcycles FireBlades org

Mar 16, 2017 | GAS Motorcycles

1 Answer

Backfiring but not starting any sugestions?


Hi, Juandre and the usual suspects are:
1. Severely discharged or a damaged battery, should have 12.5 volts or better and be able to pass a load test if necessary.
2. Check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have a nice day.
Won Start Just Turns Over And Backfires Fixed
my bike backfires but will not start Honda Motorcycles FireBlades org
HELP bike won start
http://www.kiwibiker.co.nz/forums/showthread.php/117473-Engine-won-t-start-backfires-out-the-exhaust

Apr 23, 2016 | Motorcycles

1 Answer

Engine wont start


Hi, Antony and the usual suspects are:
1. Fuel tank empty.
2. Fuel supply valve/petcock turned off.
3. Fouled spark plugs.
4. Engine flooded as a result of overuse of the enricher.
5. Vacuum hose to the fuel supply valve/petcock disconnected, broken, cracked, or pinched.
6. Fuel valve/petcock or filter clogged.
7. Discharged battery, check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
8. Loose or corroded wire connection at the coil, battery or plug between ignition sensor and module.
9. Spark plug cables in bad condition and shorting, cable connections loose, or connected to the wrong cylinders.
10. Ignition timing incorrect due to a faulty ignition coil, ignition module or sensors (MAP, CMP, CKP, O2 and/or BAS).
11. Security alarm needs a reset.
For more information about your issue, please visit the websites below. Good luck and have a nice day.
50CC Scooter Wont start
Startup Troubleshooting Starting Your Scooter 1 7
Fix Chinese 49cc Scooter that won start
http://www.lewisportusa.com/manuals.htm
http://www.betamotor.com/en/support/manuals


Feb 07, 2014 | Beta Motorcycles

1 Answer

1993 Honda CBR backfires & won't start


Hi, Anonymous and the usual suspects are:
1. Severely discharged or a damaged battery should have 12.5 volts or more and be able to pass a proper "LOAD" test if necessary, you may have a preliminary reading of 12.5 volts or more but little or zero amperage the battery is faulty and must be replaced, AGM batteries fail in this scenario more so than lead acid batteries.
2. Check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage check for spark leakage in the dark.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
For more information about your issue and valuable "FREE" downloads that you will need please click on the blue links below. Good luck and have a wonderful day.
Bike won start just turns over and backfires Any ideas CBR Forum...
Won Start Just Turns Over And Backfires Fixed
Honda CBR900RR Service Manual
http://www.partsfish.com/page/oem-parts-for-honda
Honda CBR900RR Fire Blade Owner Manual

Mar 05, 2012 | 1993 Honda CBR 900 RR Fireblade

1 Answer

I have a 91 olds supreme 3.1 v6 it shut off and won't start back .... It starts but won't turn over.... And when turn the key back off it's blows the dis fuse wich mean direct ignition system...


Check the coils that have been replace for bent or broken prongs that plug into the ignition control module and if nothing looks damaged then i would think the ignition control module is faulty.Replace ignition control module.

Jan 21, 2012 | 1991 Oldsmobile Cutlass Supreme

1 Answer

My expresso machine won't steam. Just suddenly stopped. Have tried running vinegar through system, but still won't run through steamer.


Hi, I dont know which brand machine you have, but I should be able to work out what is wrong. If your machine has a press button or turn knob steam tap, then it could be the solenoid which opens the steam flow. The solenoid itself maybe stuck or the coil maybe faulty. You just need to work back from the steam arm to work out which solenoid it is. It should make a clicking sound when activated. Commercial machine solenoids canbe disassembled and cleaned. If its a domestic machine, then just replace the solenoid. Also, some machines have a micro switch that activates the steam valve. If its faulty, then replace it.
If its a domestic machine you have, then another thing that maybe at fault, and that is the thermoblock (small boiler). If it doesn't heat up then no steam canbe made. The thermoblock has an element inside, and they can not be replaced. You have to replace the whole thermoblock. It can be easily checked with a multi meter to see if the circuit is broken. On some thermoblocks, is a thermostat or overload sensor. It is also easily checked with a meter.
So lets break it down a) solenid
b) micro switch
c) Thermoblock
d) thermostat/ thermol overload
Hope this has help you. Id be looking towards the thermoblock. Dazza

Oct 20, 2011 | Krups Gusto 880-42 Espresso Machine

1 Answer

My daughters TOTO toilet kepted running so she turned off the supply line before she went to bed. when she woke up the next moring and turned the water back on, now the tank won't refill. How do I know...


There could be several reasons why it won't refill. It could be the fill valve, which can be replaced with a standard fill valve located at any hardware store. The more likely reason is the stem inside the shut-off of the toilet has broken off inside the valve. This is very common when a valve is older and usually doesn't get shutoff. If this is the case, a new shut-off valve must be soldered on.

Aug 29, 2011 | Toto CST743S Drake Round Toilet

1 Answer

Clothes wet after spin


Hi, if clothes are wet after spinning, check.......
Motor coupler To test the motor coupler, re-start the washer in its spin cycle. Let the machine run for a minute, and then open the lid and notice whether the tub is spinning: If it's spinning when you lift the lid, the coupler is fine. If it isn't spinning--and your machine was produced by Whirlpool you may have a broken coupler. Many Whirlpool-made washers use a small, relatively inexpensive device called a motor coupling. This plastic-and-rubber component is mounted to the shaft of the motor on one side, and to the transmission on the other. Over time, the coupler wears out and fails. When that happens, you need to replace it completely.

Spin cycle If the washer doesn't reach its proper spin speed, the clothes may be too wet at the end of a cycle. Check to be sure the load is properly balanced and run a spin cycle again. If the clothes are still wet, you may have a worn or loose belt (Maytag), a worn clutch (GE/Hotpoint), or a worn motor pulley or tub bearing. Replace the applicable component. Alternatively, there could be clothes caught between the inner and outer tubs. Read the "It spins but won't pump" section of the "It won't drain" section. Also, there could be other things that cause friction on the drive train. Seek the assistance of a qualified appliance repair technician.

Siphoning If the water that pumps from the machine goes right back into the machine after the spin cycle, it may be because your washer is siphoning the water from a laundry tub with a slow drain, back into the washer. Try to improve the draining of the laundry tub. (Is there something stuck in the drain?) Also, be sure the drain hose doesn't reach more than about 4 inches into the laundry tub. If it does, cut off the excess.

Water-inlet valve Water-inlet valves eventually fail. One problem that may develop with a water-inlet valve is that it can no longer completely shut off when the electricity is turned off to it. Then, the valve may leak and drip water into the clothes tub--you may notice that your washer has water in it when you haven't used it for a few days. To fix this, replace the valve.

Apr 13, 2011 | Whirlpool LSR8433K Top Load Washer

1 Answer

Honda accord exi 1992. i was driving about 100kph when all the power suddenly shut down and i wasn't able to start it again and there is no spark on the ignition coil


If it sounds kind of like a sewing machine when you try and start it, the timing belt has probably broken and the cylinder head may have to come to replace bent valves before a new belt can be put on. This is unfortunately a common problem on older Hondas if the belt is not changed on time.

Dec 13, 2010 | 1992 Honda Accord

2 Answers

Chranks hard,won't start


you need to adjust the valves with the cylinder 1/4 inch below top dead center to get the decompression lobe to function right during cranking.

Aug 07, 2009 | Garden

Not finding what you are looking for?
Homelite For Excell - Pressure Washer Pump 2700 Psi 7/8" Shaft Logo

228 people viewed this question

Ask a Question

Usually answered in minutes!

Top Homelite Garden Experts

roeb

Level 3 Expert

473 Answers

Roland W VanLue
Roland W VanLue

Level 3 Expert

486 Answers

Mike Squire

Level 2 Expert

404 Answers

Are you a Homelite Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...