Question about Oreck Vacuums

1 Answer

Forever series hose is clogged - Oreck Vacuums

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Greenhorn:

    A rookie expert who has answered 20 questions on their first day.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

  • Contributor
  • 22 Answers

Turn the sweeper upside down and stand it on the handle then take a screw driver to unclog the nozzle behind the roller brush. If the rest of the hose is clogged then you may have to take it to a sweeper repair store to get it cleaned.
I would try a straightened out coat hanger and CAREFULLY work it around to try to break the clog. If you're not that handy then go to an Oreck store if you have one.

Posted on Dec 30, 2013

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does not my rainbow vacuum will not pick up dirt


Check you belt first. Check for a clogged hose. You can do this by putting the other hose on the exhaust of unit with the crevice tool. Blow air through the other hose to see if anything comes out. This is good to do anyway to ensure clean hoses.

Aug 07, 2014 | Rainbow E series Canister Wet/Dry Vacuum

1 Answer

My rainboe has no suction


<p>The hose could be clogged. <a href="http://www.rainvac.com/rainbow-vacuum-schematics"></a>Check the suction on the main unit without any hoses connected. If that seems good, then connect a hose and check suction again at the end of hose. If suction is still good and you are having issues when using the power nozzle, then open up the bottom of the power nozzle to check for clog.</p>
<p>RainVac </p>
<p><a href="www.rainvac.com">www.rainvac.com</a></p>

Apr 01, 2013 | Rainbow E series Canister Wet/Dry Vacuum

1 Answer

Will not come on electrolux cannister renissance


The Renaissance and a few other models require a series of steps in troubleshooting, done in specific order, to diagnose the problem. The vacuum, hose, wands, and power nozzle need to be taken to an authorized Aerus Electrolux shop for this. The service manual is only available to the service techs, and franchise owner.
If these steps aren't followed, additional problems may result.

Things you can check include:
1. Afterfilter. This is located beneath the on-board tools. Open the access door to the tool holder by pressing latch at front of door. Squeeze clips at the front of the tray and lift to remove. If the filter is dirty, replace it. Turn vacuum on and see if it works.

2. Check for clogs in hose, wands, and power nozzle.
Disconnect hose, hold one end up, and drop a coin in. Lift end of hose so that the coin drops out. If it doesn't there's a clog that needs cleared. You may be able to do this by attaching the hose to the blower hole, placing the other end into intake and holding it there, and turning on the vacuum. If this doesn't work, it will need to be taken to the Aerus shop for clearing.
Visually check wands for a clog. A clog in the wands can be cleared with a broom stick or similar item.
Visually check the power nozzle from the bottom and the wand connection. If no clog is seen, try dropping a coin into the wand connection and seeing if it drops through. A clog here can be cleared using a wooden spoon handle or similar blunt stick.

Feb 15, 2011 | Electrolux Lux 5500 Canister Vacuum

1 Answer

My hond spin sprayer on my Hoover Legacy series


it is clogged. the hose part were it sprays is most likely to be clogged with debree. It happens all the time with hoovers

Sep 11, 2009 | Hoover Vacuums

1 Answer

Rainbow water not spinning


All Rainbows - remove the hose and turn it on without the hose plugged in - if works better - hose is clogged

If it works bad even with the hose out:
E-series Rainbow - take HEPA filter cartridge and try then. If helps - you need new HEPA (you can get it here)

SE Rainbow vacuums - remove exhaust cap
moz-screenshot.jpg9f8f4ab.jpg
and you may find a dirty sponge in there - just remove it and it may help.

If none of that made any difference - you may need it to be checked. If you do not mind shipping - our info is HERE

Feb 15, 2009 | Rainbow E series Canister Wet/Dry Vacuum

1 Answer

Vacuum clogged


If you are talking about the electric hose, try using your none electric hose with the crevice tool attachment to extract the particles from the other one. When using any of the hose please leave it running a few minutes to make sure everything in the hose moves through and does not stop midway through.

Jan 02, 2009 | Rainbow E series Canister Wet/Dry Vacuum

1 Answer

Low suction


Is the suction low at the tank after you disconnect the hose? If it is strong there, then the hose may be clogged. You can unhook the hose from the wands to see if you have suction or not. If you do, then look further down all the way to the brush roll. The other possible is if no clogs, check the filters, on the E series, there is a filter on the back, there is some also had one in the top and you would have to take it apart to get to it. One other is that the motor is not running at top speed and may have to be replaced. It can sound ok, but will have reduced suction. If you suspect the motor, check your owner manual, some of these newer ones had a long warr. period on the motor.

Feb 13, 2008 | Rainbow E series Canister Wet/Dry Vacuum

1 Answer

Rainbow E Series Vacuum


Is there suction at the vacuum, without the hose hooked to it? If there is, then your hose may be clogged, if not, it is possible that the corrugated filter may be clogged up. You would have to remove the top to get to it.

Jan 08, 2008 | Rainbow 75th Anniversary Canister Vacuum

1 Answer

Central vacuum not sucking


Usually when there is no suction, and the main unit is running, then either the hose or somewhere in the piping there is a clog. If you move the hose to another location, is there suction? If not then the hose is clogged. You can unhook the pipe at the unit, flip the switch to manual, if it comes on and there is suction there, then there is a clog in the piping, If in the piping, tear up small strips of paper and mark them by number and insert one in each inlet, run the unit on manual to suck them up, and which ever numbered strip isn't there in the bucket, then that is the inlet that is clogged.

Nov 23, 2007 | M&S Systems AirVac AVP1200 Platinum Series...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

27 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oreck Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18387 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1456 Answers

john h

Level 3 Expert

10986 Answers

Are you an Oreck Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...