Question about Kenmore 22812 Bagged Canister Vacuum

1 Answer

No suction My Kenmore Progressive Cannister Vacuum has no suction. The hose is not clogged and I don't know what to do.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 21 Answers

If the motor is running and is not full of dirt, and the hose is not plugged, the canister must be cracked or open somehow.

Posted on Sep 14, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Loss of suction


Check for clogging along the entire path between the pickup and the cannister

Apr 23, 2013 | Kenmore 25614 / 25615 Progressive Bagged...

2 Answers

Why would the vacuum have no suction?


if the motor is running it could be a belt a clog or a hole somewhere else in the hose

Feb 16, 2012 | Kenmore 23612 Progressive PowerMate Bagged...

1 Answer

My Kenmore Progressive Canister turns on but there is no suction


Hi,
Here is a tip that I wrote about my Bissel but I bet you have the same problem and the hose is clogged...

Bissell Bagless Upright Vacuum not working
http://www.fixya.com/support/r4387950-bissell_bagless_upright_vacuum_not

heatman101

Aug 22, 2010 | Kenmore 23913 Progressive PowerMate Bagged...

2 Answers

Kenmore progressive 360 vacuum cleaner has low suction


Check the tube that leads down to the brush head for clogging as well as any motor or HEPA filters. If that still shows nothing, take the cover off the brush head (like you're changing the belt) and look for obstructions in there. Usually, if you have low suction on the accessory hose, the problem is with a motor filter, HEPA filter, or a clog where the hose goes into the unit. If you have good suction on the accessory hose but none on the floor, it's usually in the brush head (clog or broken belt) Good luck

Feb 28, 2010 | Kenmore 35912 / 35913 Progressive Upright...

1 Answer

Kenmore Progressive with direct drive model 116.36923502 stopped picking up debris and empted it into the floor and is there something you need to do to switch from floor to using the hose. It does not...


sounds like you have a clog in your hose, full bag, or dirty filters. take the bag door off and feel inside at the bottom for suction or air movement. if you have suction there chances are its a clog in the hose. You can use a coat hanger or something similar to reach into the hose just be careful not to puncture the hose. First just try turning the unit on and stretching the hose as far as you can. try to feel for a clog and try to free it with the hose stretched.

Jan 22, 2010 | Kenmore 31913 Progressive Direct Drive...

1 Answer

My Kenmore Progressive is making a noise that sounds as if something is blocking the suction. I have checked the tubes and can't find any obvious blockages


Have you changed out the bag? Checked the air filters? When you run it and hold your hand over the hose opening, do you feel suction?
Check the head for blockages, you said the tubes are good, so check the hose, if no obstructions there, open the canister and check the bag, if it's full change it, if not, pull it out and check the filter that's under the bag, if it's not clogged re-run the above steps but this time look for possible vacuum leaks. Let me know if this helps.

Oct 19, 2009 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

I have a Kenmore Progressive Inteleclean Upright vacuum cleaner (with Bag) . It has good suction only through the hose now and none through the bottom for cleaning carpets. and, there is a noise like it...


Theres a little bendable neck that hose with suction plugs into. Thats the one thats clogged. You will have to fish it out by taking off the roller and clearing the clog.

Sep 22, 2009 | Kenmore Progressive Bagless Upright with...

2 Answers

No suction....performance light stays on...filters replaced


Probably a clog..
Get hose off and straighten it out and look inside.. If not - check both ends where hose connects in the units..

Hope this helps !!

Jul 22, 2009 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

My central kenmore vacuum wont suction


Hello hdd85,
I think you answered your own question when you verified that all the vacuum outlets have vacuum on them and then after you hook up tyhe vac hose, you fail to get vacuum at the other end. I would say that based on your problem description, you have an obstruction in the hose. You may have afriend with an air compressor that you can try forcing air in one end to free up the clog but if that doesn't work, do you know anyone with a wet/dry utility vac that you can try using the vacuum or exaust side to free the hose up ? Lastly, if you know an electrician, they normally have 'snakes' used to fish wires thru wall cavities... If careful, that might get the clog out.. Hope that gives you soem ideas on how to resolve,,,,
Regards,
Rick

Jan 26, 2009 | Vacuums

1 Answer

Kenmore Cannister Vacuum Model 26312


http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=109396&thid=552260
Kenmore Canister Vacuum Model 26312
Posted by Alecia Rojas on Apr 28, 2008
Kenmore 23612 Progressive PowerMate Canister Vacuum
Vacuum is not sucking. It is just over a year old.

Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure.
It sounds like you have a clogged hose or a full bag, or dirty filter. The best way to check your electric hose id to run a marble or steel ball thru the hose and if it goes thru all the way then check the bag and filter, most times it is the vacuum hose. If it id the hose you can try to pull apart the clog from both ends using another central or canister vacuum. If not and the ball stops mid way thru the hose then you can use a broom handle with a round hook on the end so that it does not puncture the hose is any place and the round hook can loosen or break up your clog and then your suction will return, if you poke a hole in the vacuum hose there are repair kits that go on the outside of the hose that will slide over the hose and then you use a heat gun and shrink the hose repair kit down to size therefore plugging the leak. (Hose repair kit). So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.
http://www.sears.com/shc/s/home_10153_12605
National Customer Relations 1-800-549-4505
Home Services & Repairs 1-800-4-MY-HOME
1-800-469-4663
Parts Orders & Inquires 1-800-366-PART
1-800-366-7278
Thanks, Don – The Vac Man
Go Ahead. Use Us.

Apr 28, 2008 | Kenmore 23612 Progressive PowerMate Bagged...

Not finding what you are looking for?
Kenmore 22812 Bagged Canister Vacuum Logo

263 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18408 Answers

kakima

Level 3 Expert

102366 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...