Question about Philips Audio Players & Recorders

Open Question

Philips subwoofer sw090 has no sound.

No sound, only humms, fuses are good, capacitors look good green led light comes on

Posted by Anonymous on

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 50 Answers

SOURCE: No sound comes out of the subwoofer. Sound passes

this may be a dumb question but have you turned up the signal. there should be a dial on the back that you can turn the power up. power light on, signal passing threw, the only other thing it can be is the built in amp itself may be dead.

Posted on Aug 09, 2009

Ad
budmrtn
  • 11361 Answers

SOURCE: JBL PB10 subwoofer sounds distorted and lights on the front flash

More likely to be the Class D power amp module, but you should look through the service manual to make sure all the parts are installed correctly. My PB10 AMP module went out and you cannot get one anymore.
http://manuals.harman.com/JBL/HOM/Service%20Manual/PB10%20sm.pdf

Posted on Nov 10, 2009

  • 19 Answers

SOURCE: the subwoofer just quit working

if the light still comes on then the fuse is still good....

a possiblity exists that either the amplifier or the actual speaker itself went bad....if you like you can dissasemble the the subwoofer to access the insides....a simple test....if you connect the driver to another amp (any amp will do as this is just a test) and it makes sound then chances are your amp is bad or just a loose connection.

Posted on Oct 28, 2010

SOURCE: JBL Venue SUB10. LED light

This usually indicate a power supply rail, failure, and or a main amplifier has "Blown". You need to take this unit into a JBL repair shop, contact a local or head office of JBL, and ask them for a referral to an authorised service center. When in face to face contact here, ask them only and first off for a "Quote" as to the prospective repair costings and go from there?

Posted on Jul 30, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No sound or "green" light


Hi,
Your power supply have a problem. Check the FF:
1. Power cord - might be open due to frequent bending and pulling.
2. Power switch - for open contact.
3. Internal Fuse might be open. If open replaced with exact ratings. If the new fuse blew again this is an indication of shorts in transformer, Rectifier Diode, Main filter capacitor, output IC.
#3 is technical and you must have knowledge in electronics, have tools and test instrument to perform the steps.
Hope it may help you.
Give a thumbs up if you find it useful.
Have a nice day!

Feb 07, 2011 | Philips Audio Players & Recorders

1 Answer

The subwoofer just quit working the green light is on sound comes out (here voices) the subwoofer no bass


if the light still comes on then the fuse is still good....

a possiblity exists that either the amplifier or the actual speaker itself went bad....if you like you can dissasemble the the subwoofer to access the insides....a simple test....if you connect the driver to another amp (any amp will do as this is just a test) and it makes sound then chances are your amp is bad or just a loose connection.

Aug 30, 2010 | Sony SA-VF700ED Speaker

1 Answer

Philips Power supply flashes 5 times


one day not start his open. stan by red led and after switch on ,his green bligkig is not open.sound is ok.(the relay his not click)

Apr 12, 2010 | Philips 50PF7321D 50 in. Plasma HDTV

1 Answer

Philips Brilliance 200w6cs Backlight off Green LED ONN


Check to see at one of the pin on the inverter board has 12vdc feeding it. No bad capacitors? Pictures?

Nov 29, 2009 | Philips Brilliance 200WP7ES - Flat panel...

1 Answer

NAD C352 turns on but no sound


Hello,

The first and easiest things would be to check all connections.
Speaker wires
RCA Cables !!

If you are getting a green light you are getting proper power and ground connection.

Other than that the other possibility's would be internal components, capacitors ect.

I would be willing to bet something has come jarred loose. Post back after you have checked and double checked all connections.

Aug 12, 2009 | American Pro VS-2043 Car Audio Amplifier

1 Answer

Infinity Entra Sub 150 no sound or power


I had the same problem. When I opened it up, the fuse was blown, and it was a pain to find the fuse it needs (3 Amp, 250 V slow-blow fuse, 5x20 mm). Also, the 2 large electrolytics (big purple things near the amp) and one small capacitor were all blown. For 4 fuses, bought seperately from, and the 2 electrolytics and 1 capacitor, it cost about $20, plus almost 20 more in shipping, which still isnt bad considering the original price of the sub. However, the tricky part is that you have to know how to use a soldering iron to take out the old components and put in the new ones.

Jan 01, 2009 | Infinity Entra Sub Subwoofer

1 Answer

Philips HTS 3450 sound


I just blew my subwoofer up. The fuse was blown so I rigged it with something to act as a fuse, and the thing spewd out a volcano of smoke! Oh well..

Sep 21, 2008 | Philips HTS3450 System

2 Answers

Audio control pod


I have a similar issue too, but my problem is that the sub has green light, and my control pod has an 'off' light, but it won't turn on :(

Jun 16, 2008 | Creative Labs Gigaworks S750 Computer...

2 Answers

Philips 42PF7220A 42 in. Plasma


I had a Similar problem where I would turn the tv on and the green light would come on and then the red would follow and blink 7 times. I tried unplugging it and then then replugging it back and it would still do the same. What I did last night was that I unplugged it and then replugged it back, when I saw the green light, I would unplug it again, till the light went out and replugged it, I did that 3 times in a row, and waiting and it came back on. Hope that works. I still don't know what caused the problem to begin with..

Oct 27, 2007 | Philips 42PF7220A 42 in. Plasma Television

1 Answer

No Sound coming out of amp to subwoofer


check the fuse box and make sure there is no loose connection there. also check the wire that feeds power to that amp. good luck

May 23, 2007 | AudioBahn DUB Mag Audio DUB1002 Car Audio...

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

59 people viewed this question

Ask a Question

Usually answered in minutes!

Top Philips Audio Players & Recorders Experts

Gyula Lacz

Level 3 Expert

483 Answers

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5126 Answers

Are you a Philips Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...