Question about Performance Teknique ICBM-892 Car Audio Amplifier

1 Answer

Icbm-892 amp performance teknique on protection mode

My icbm-892 when tested it immediately goes to protection mode tech said small black capasitor inside amp was blown up how do i fix it, if fixable? or where should i take it to get fixed?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 113 Answers

See what the volts and uf are and u can desolder the old one with some solder wick and find a replacement out of some old junk electronics that is the cheapest way I have done this many times and the used one does not have to be black

Posted on Jul 05, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My amplifier keeps on protection always i want to know what can i do to solve the problem or what should be creating it? Someone told me that maybe a capacitor blow up but i opened it a they seem normal,...


Hi,
Amps normally have several kinds of "protection" modes. Common ones are thermal, voltage, and short. Do you know which one you have? If the amp isn't hot, and goes into protection immediately before doing anything, we can rule out thermal protection. The next thing you should do is disconnect the speaker/subwoofer leads from the amp so that it only has power, ground, and remote connected. If the amp comes on with no speaker load, connect the speaker and see if it goes into protection. If it does, then you probably have a short-protection. Hope this helps.

May 14, 2009 | Performance Teknique ICBM-892 Car Audio...

2 Answers

My amp automatically goes into protect mode


There are 4 reasons an amplifier tries to protect itself.

Overheating - thermal shutdown.

Over Impedence - The subwoofers installed are not configured into a load the amplifier can handle.

Output is grounded - a positive wire strand may be touching the ground terminal - a wire may be shorted, or a speaker voicecoil is blown.

Intennal problem - Output on amplifier blown, or some other component has failed.

Check your wiring to the amplifier again - if all is good - disconnect the speakers and try to power on. If the amplifier turns on normally - test the speakers for blown coils.

If the amplifier still goes into protect mode - the problem is internal and needs professional repair.

Thanks for using FixYa - a FixYa rating is appreciated for answering your FREE question.

May 06, 2009 | AudioBahn A2301 2-Channel Class A/B Mosfet...

1 Answer

Amp quit putting out sound


It is probably in the "protect" mode. When this happens, the amp will have power going to it and seem to be turned on, but no sound. Many amplifiers have a LED that is normally red and it lights up when in the protect mode. Check all the LED's on the amp and see if one of them is for the protect mode.

When an amplifier goes into protect there are usually only 2 reasons for it.

1. A bad speaker

2. A channel blown inside the amp.

Disconnect the speakers to the amplifier and see if it makes the amp come out of protect mode. If the amp has an LED to indicate when it is in the protect mode, this LED will shut off, and sometimes they have a relay inside the amp that you will hear click. If you hear the click sound form inside the amp after you disconnect the speakers, you probably have a bad speaker. Take yours to a service center and ask them to check them for you, many shops will do this for free, I know that my shop will do it for free, so I assume that many others will also.

If the amplifier has a blown channel, you need it serviced. There is no quick fix for a blown channel. If you have a multimeter I can tell you how to check some of the components inside to verify if it has a blown channel. Let me know if you are able to do this and I will give you instructions on how to properly test the components. If you do not have a multimeter, there is really no way to figure out what components are bad. Your only choice would be to take it to a service center for repair. They can give you an estimate of what it may cost before you are committed to paying for a repair. Most car amplifiers will cost about $100 to $150 to repair a blown channel. It just depends on how much damage there is, and the rates of the service center.

I hope this is helpful, and if so a good rating would be appreciated. If you need to communicate more with me to determain what the problem is, please wait to give a rating until we are finished. That way I will not get an undeserved bad rating. By the way, the only rating that is good (meaning that it doesn't lower my over-all rating) is a FixYa! rating. The "Helpful" and lower just bring my rating down. After all, the only reason for offering this free help, is to get a good rating.

Dave

Nov 18, 2008 | Jl Audio 500/5 Car Audio Amplifier

1 Answer

Performance teknique icbm 892 1200 watt amp


DD, JL and pioneer in that order. I don't recommend any particular size but 12s are a good compromise.

Sep 21, 2008 | Performance Teknique ICBM-892 Car Audio...

1 Answer

Performance teknique icbm-896 stick on diagnostics


If it's in protect mode, it probably has shorted output transistors. To eliminate other possible problems, read through the following page:

Amp in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Sep 10, 2008 | Performance Teknique ICBM-896 Car Audio...

4 Answers

No response from amp


it sounds like you have a bad ground make sure its on the froame or body and make sure any rust or paint is sanded or scraped off

Feb 09, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

2 Answers

Diagnostic light


Best thing to do is disconnect all the speakers with no input on the amp turn it on and if its still in protection seek help in the repair of said amp at http://performanceteknique.com.. If the protection light goes out then start to put back on each speaker with no volume and the unit off. if you get to a speaker that makes the unit go into protect then leave on that speaker and disconnect all the rest .. If the protect remains then something with that speaker or wiring is bad BUT if after disconnecting the rest of the speakers that you hooked up then theres is still a power issue with your amp

Apr 05, 2006 | Performance Teknique ICBM-782 Car Audio...

Not finding what you are looking for?
Performance Teknique ICBM-892 Car Audio Amplifier Logo

Related Topics:

239 people viewed this question

Ask a Question

Usually answered in minutes!

Top Performance Teknique Car Audio & Video Experts

George Nalley

Level 1 Expert

41 Answers

Radames Pagan
Radames Pagan

Level 3 Expert

196 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

Are you a Performance Teknique Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...