Question about Car Audio & Video

1 Answer

Hi I have a eltax impact 10 and when I turn it on and put music on it cuts straight out power still on just sub stops working can any 1 help into diagnosing the problem ? Cant afford a new 1 and u can't buy these any more.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 75 Answers

Test the voice coil of the sub with a digital multi-meter. Make sure it is within spec. They are usually 4 or 8 ohms. If OK, the plate amp is shot. They are not worth repairing. Good replacement amps can be bought from Parts Express for as little as $100 or less.

Posted on Dec 10, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 113 Answers

SOURCE: my amp turns on then the music cuts in and out

check your main ground, if possible try to read voltage across making sure 12-14v present with load and some signal.

Posted on Aug 08, 2007

  • 113 Answers

SOURCE: Car amp's stopped working. Putting out a heart beat sound through subs but no bass.

could be low current ,disconnect all power including ground for 20min N.B most amps will seem to be shorted at output but this is normal due to damping ratio.

Posted on Aug 09, 2007

  • 631 Answers

SOURCE: SOUND CUTS OFF AT HIGH VOLUME AND POWER LIGHT FLASHED RED

You need to check the DC voltage across the power and ground terminals of the amp. If the voltage drops below ~11v when the amp shuts off, you need to check the power/ground wiring and fuses.

If the voltage remains above 11 volts, you may have a problem with the load on the amp (incorrect ohm load, shorted speaker, shorted speaker wires...).

Posted on Jun 14, 2008

GooFyTiS24
  • 33 Answers

SOURCE: i bought a 500/1 jl audio amp and also a w7 10 sub

if its cutting off and right back on then check your ground and your power wire makes sure both are connected good and none of your fuse's are blown, either that or you got a wire hooked up backwards in the sub.. but my guess is that the sub is hooked up wrong... that sub should be hooked up in a series or in parallel,

ok if your running just one speaker, it should be hooked up like this and 2 speakers are a different way...

this is parallel :pos to pos , neg to neg, then one wire coming from pos on sub to pos on amp then neg on sub to neg on amp but bridge the amp on your amp should be 2 pos and 2 neg in two different channels take the pos off the sub into the pos on 1 channel and then the neg from sub to the neg on the other channel,

this is series : on the sub it will go pos to neg then the other neg and pos will go to the amp, but make sure the pos and neg r on different sides of the sub, dont hook them both to the same coil

if your need more help give me your email and ill send you a pic of how to do it...


Posted on Aug 12, 2008

Devsta
  • 68 Answers

SOURCE: Alpine PDX1.600 amp cuts off

Make sure there's no missmatched impedance. If your sub running 2 ohms then your amp has to be 2 ohms stable. Does the amp blow fuses or get really hot? If it does it can be a fire hazard and I would recommend taking it out of your car. It could be that you don't have sufficient grounding. The grounding needs to be very close to the amp and the paint needs to be thoroughly scratched off. Otherwise could be a blown transistor within the amplifier, you can check this by opening up the amp, running a multimeter and testing the transistors for resistance.

Posted on Aug 05, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ryobi 18-Volt Impact Wrench P260 stop during use


Well I was having the same problem and I found out that the p108 and p109 cut power when to much of the battery power is being used, kind of dumb just to say the new batteries last 4x longer( its because u can't use all the torque of the impact). Fortunately I've found out that the older batteries don't cut power such as the p104 p103 and the black ryobi batteries without the gauge indicator work the 1/2 " impact without cutting power

Mar 19, 2013 | Ryobi 18-Volt Impact Wrench P260

1 Answer

Hi all i have a Denon DRA 455 with Eltax Linear 6.5 wich is 8ohms i have a sub but no sub output, apart from sharing power between them, how can i hook these up please? thanks


You did not state if your sub is a powered sub or not, but if you use the "B" channel for your sub, it should work. This is possible if the denon will work with "A" channel and 'B" channel on together. The back of the Denon should have two sets of speaker outputs. Connect the "B" channel speaker outputs to the sub. The "A" channel will still drive your 6.5's.

Aug 05, 2009 | Audio Players & Recorders

1 Answer

Loud boom when going in standby mode.


i would check your sub connection also make sure the volume isnt set to high. sometimes unplugging the power and cables also helps

May 20, 2009 | Eltax Atomic A-8.2 Subwoofer

1 Answer

Kickers dont beat like they should


try to check and clean the wiring as clean as possible to avoid messing up on your connection. Check the polarity of you subs to yuor amp if you have it connected on the outher way around it would not give you a good result. check the polarity this will solve your problem. Over powering your sub will fry it easily try to tune it a 10" sub wont give you a 15" performance..

Jan 20, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Subs dont beat like they should


you've spent alot of money on **** by the sounds of it!!. you should only ever run multiple subs the same brand, power and resistance you can just connect any old subs to a system you need to wire them depending on the load that the amp needs to see. first thing is to try the amp/s on a individual sub to check your amps still work once done check the subs 1 by 1.

Jan 20, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Constant sound from subs


I Had the Same Problem I just unplugged my amplifier changed the fuse, also i had a fuse in the battery cable and changed that, unconnected the RCA wires and plugged them back in and then put new fuses in and plugged everything back into the amplifier and it worked again. If that doesnt work get back to me i will try to help you.

Jan 09, 2009 | MTX RT2200 Car Audio Amplifier

1 Answer

Subwoofer stops working after awhile, but only one


it sounds like u blew them or the voice coils could be messed up here is one way to check take the woofer out of the box and look at the coils it should be ornge and then smell it if it smells like fire it might be going bad thats the reson it is frezzing like that let me no what happens and please rate me

Apr 07, 2008 | Sony Xplod 1100 Watt Max 10" Subwoofer,...

1 Answer

Car amp's stopped working. Putting out a heart beat sound through subs but no bass.


could be low current ,disconnect all power including ground for 20min N.B most amps will seem to be shorted at output but this is normal due to damping ratio.

Jun 11, 2007 | Jl Audio E1200 Car Audio Amplifier

6 Answers

Speakers cut off when bass goes up...


it might be that your wires from your amp to your subs are too thin. since they were relatively new the first three months, they were probably undamaged, but after pushing them too much, they probably have broken wires, and can't get enough power to the subs when turned up, i suggest getting thicker wires before investing in a capacitor, it could save you money.

Mar 21, 2007 | Sony Xplod 1100 Watt Max 10" Subwoofer,...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

22 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4834 Answers

yadayada
yadayada

Level 3 Expert

75066 Answers

The Knight
The Knight

Level 3 Expert

73647 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...