Question about Car Audio & Video

1 Answer

Blinking light on 600w 4 channel pioneer amp. All connections are clean and correct to my knowledge so far

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 47 Answers

Check your ground make sure it is on metal and not paint. Some amps will blink if the ground is wrong.

Posted on Dec 02, 2013

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 7 Answers

SOURCE: Thumping speakers - no power light is on - wired correctly

the amp is going into protect mode due to something wrong in the amp or some thing in the wiring to it ooh yea if you are getting 18v power to the amp that is way to high it should not be higher then 15v if the amp is in protect mode it will not play at all.

Posted on Nov 02, 2008

  • 631 Answers

SOURCE: Amp Power light will not go on. Protection light is lit- Thump sound in speakers

It probably has shorted output transistors. To eliminate other possible causes, read through the following page.

Amplifier in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Posted on Nov 02, 2008

  • 17 Answers

SOURCE: Getting shocked by my truck

Yes it is..Its only static electricity.. But be careful if you are getting gas.. Do not start pumping gas and then get back in to your truck while pumping and then get back out and grab nozzle WITHOUT touching metal first.. Even a little static can ignite the fumes..Rule #1.. Ground yourself before touching the gas nozzle..

Posted on Nov 11, 2008

  • 1 Answer

SOURCE: troubleshooting amp setup

You probably need your remote wire re-hooked and make sure the ground wire is good and the remote wire is connected to the right wire(the red wire).

Posted on Jan 12, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1200watt amp that's only providing 300watt output with 8ohm Behringer B212 speakers. Is there a resolution and what would it be?


I'd need to know more about the amp, but don't forget, amps are rated as their max power...
So lets take a 300W/channel stereo amp at 8 ohms.
Ok, it's stereo, so there's 600W
But the amp is capable of 4 ohm loads...well, now you can deliver 600W/channel, for a total of 1200W
In this scenario, your amp is doing exactly what it was designed to do with those speakers.
If you wanted to get the full 1200W out of the amp, you'd have to hook up 2 more speakers in parallel to the ones already there. This drops the impedance to 4 ohms per channel = 600W / channel.
Yes, the power is split among the apeakers...300W per speaker into 4 speakers = 1200W
so any way you look at it, there's your 1200W

Feb 27, 2011 | Behringer B212 600watt, 2-Way PA Speaker

1 Answer

Can you run a 1200w pioneer sub and 2x9x9 inch car speakers to a 600w pioneer 4 channell amp??


depends on what the RMS is for the subs because although the subs are 1200 watts, there is a minumim standard you have to follow. If you don't atleast run the lowest wattage thru them, then you will most definately damage the speakers....you should also be aware of the fact that your "600w Pioneer-4 channel amp doesn't even push a true 600 watts... Your best bet is to upgrade ur amp, or add an additional amp to your set-up. And you really need to pay close att to over or under running your power to your stereo system because you'll burn out ur altenator rather quickly. Use proper wattage , and you should also look into getting a power-cell which lessens the chances of destroying your altenator and helps to ensure that your stereo system sounds to its full potential.....

Feb 15, 2011 | Pioneer DEH-P6400 CD Player

1 Answer

I haave a sony xplod 600w 3and4 channel amp. all wires are correctly installed and it works for like half a second then the protector light comes on (goes green to red) and stays red. ive checked the...


Well as far as getting a different amp depends on what kind of subs or speakers you are trying to push. Also it depends on how much you are asking the amp to do. If you are asking a 600w amp to try and do 1000w job its just not gonna work and it will shut down.

Jan 04, 2011 | Car Audio & Video

1 Answer

XR 8600 what color wire on the output connects


Peavey XR 8600?? Well it's 600w per ch. at 4 ohms/per side. So, whichever mode you use (Main, or Main/Monitor) you are best to have a 4 ohm total load for each channel of amplification. Ex.--Mains only, one 4ohm speaker per channel will give you 600W per side. Or two 8ohm speakers per channel in parallel, which makes a 4 ohm total load.

Main/Monitor mode---treat it the same way. one 4ohm, or two 8 ohms parallel. per channel.

Your best situation is to have a 4 ohm total load for each channel of amplification to get your 600W.

Parallel-- 8ohms each / 2 speakers = 4 ohm


Feb 20, 2010 | Music

1 Answer

I have a 600watt vibe amp all wires are connected correctly but power light comes on and then goes straight off and repeats this constantly whats wrong??


most amp have a protection feature sounds like somthing is hooked up wrong or u have a short to ground id recheck using a multi meter if all test r good then ur amp needs to be serviced.

Sep 17, 2009 | Lanzar - Vibe: 2 Channel 600W Vibe Series...

1 Answer

I have two xti 2000 amp running with electrovoice speaker 600w


This is most likely to be a heat issue where the amps overheat and shut themselves off then cool down and turn back on. Please check that the amps have proper ventilation and that any air ducts are clean.

Feb 26, 2009 | Crown XTi 2000 2-Channel Amplifier

1 Answer

I am trying to wire and bridge a sony marine 600w sony marine amp


as long as the speakers are wired in parallel it should be ok dont wire them in series as they will overload the amp it is designed to run at 4 ohms

Feb 13, 2009 | Sony XM-2150GSX Car Audio Amplifier

1 Answer

How many speakers can I use?


Hi,
This should work if channel 3 & 4 are bridged at 4 ohm.
channel 1 should be stable at 2ohm
channel 2 should be stable at 2 ohm
You can hook up the right side speakers together ( + with + and - with - ) . same thing with the left side. this will give you 2 ohm each channel. this will cause your amp to run hot (this might be tuff on the amp). It will give you right (2 speakers) and left ( 2 speakers ), no front and rear adjustement if you need to balance your sound. I think you should be better buying another amp for your sub and take your 4 channels for your 4 car speakers. this amp as a rca output that can feed the other amp ( sub amp ). it is possible to do it.

Good luck

Nov 11, 2008 | Alpine MRP-F250 Car Audio Amplifier

1 Answer

Amp. Audiobahn a2300hcx


If the subs are dual 4 ohm voice coils and if your amp is good down to 1 ohm, your best bet is:
  1. Connect the voice coils in parallel ("+"s together, "-"s together). This will make the impedance of each sub 2 ohms.
  2. Connect the subs in parallel.
  3. Bridge the amp to one channel.
This should max the amp out at 2400W, which means about 1200W per sub.

If your subs are single 4 ohm voice coils, do the same steps, but you'll only be able to load the amp to 2 ohms, which means about 600W per sub.

Also keep in mind that box size, type, and quality make a big difference in how subs sound.

Mar 20, 2008 | AudioBahn A2300HCT Car Audio Amplifier

1 Answer

Speakers


Hi Trim God,

 

I do not reccommend that you push the Pioneer speakers over 100 watts.  The jenson will already drown the car with bass through your pioneers so much you will want to turn off the bass boost when playing some low bass hip hop songs. It changes from one venue of song to another, so I just keep the jenson bass boost off and use my head unit to adjsut the sound to fit my listening prefences. I am telling you man, you will be blown away .  Hook up the pioneers straight to the Channels,. do not bridge.  I put Subs in my truck though.  I used the Pass output to send the audio to me Jenson 2 Channel 600W amp. I drive one 10 inch enclosed JBL Class A/B Sub. I bridged the output of the 600 W amp to the 10 inch sub  in my Z28.  The pioneers never get drowned out.  I did smoke my 2 channel Amp one time. and also took out a MTD 10inch sub. I am talk shooting flames and smoked the whole car up. I think if you bride the XA4150 to the pioneers, you will have the flaming smoke problem in no time.  

Oct 02, 2007 | Jensen XA4150 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

29 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4874 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...