Question about Sony Xplod 1200W Class AB Bridgeable 2-Ch. Amplifier w/Variable Low-Pass Crossover

Open Question

Why is my sony xplod amp cutting in and out - Sony Xplod 1200W Class AB Bridgeable 2-Ch. Amplifier w/Variable Low-Pass Crossover

Posted by Anonymous on

Ad

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: sony xplod 1200 watt

i had the same ploblem with my amp then i found out i didnt have a good enough ground. Make sure you groung it to your weel well or some part of the frame. Or you mite be running with a fuse thats pushing to much power i use a 100a fuse 5 gage power cord to power my 1200w xplode and my 2 12" kicker comps. Or if your using two diff kind of subs then you amp is confused in why your asking for 500w on one side and 600w on the other this will also make your amp light come on.

Posted on Mar 07, 2009

Ad
loft404
  • 11 Answers

SOURCE: Settings for a Sony Xplod 1200 watt amp, with two 12 inch subs

What kind of subs are you running? Meaning what brand, what are the ohm, spl and wattage? I'll look up your amp while you get that info to me. Looking forward to helping you:) Thanks!

Posted on Jun 17, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sony Xplod Amplifier Problem


First make sure you are using at least a 12 guage speaker wire for sub connections. Second make sure you have plenty of breathing room in your mounting position, these things need air badly. Third of all, Xplods are not very friendly if they are cranked all the way up on your dB boost knob. Only crank it about 3/4 of the way up, then use your equalizer settings to tweak the thump.

Oct 20, 2009 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Sony xplod amp(XM-1652Z ) power/protect light


if your amp is overheating your sub is needing to much power that the amp doesnt have.
if its cutting out and the red light comes on you need to check the wiring. nothing not even the tinyest speaker wires can be touching.
proper wiring would be your best bet.
but i would upgrade amps.
cheap bang isnt reliable.

Apr 06, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

2 Answers

Can I run 8 speakers and 1 sub through 1 1200watt 2:1 Sony Xplod?


asuming the 8s are 4ohms each; wire two in series and that gives you 8ohms then two more in series then you put those together in parallel and it gives you a 4ohm load. repeat with other four for the other side. you should then be able to bridge the sub


series; posative of one speaker to negative of other speaker and that doubles your ohms

parallel; posative to posative negative to negative and that cuts the ohms in half

Apr 06, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Sony Xplod Amp


well you might want to try using 30 amp atc fuses instead of 10 amp fuses on your amp, because you are getting an overcurrent from your alternator then from your battery. I have the same amp and you will find that your subbs will hit better too. also check on your ground wire from your amp as this also will cause the RED light to come on. :)

Mar 24, 2009 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Sony Xplod 1000W workign strangely


need a bigger gauge hot wire going to your amp ,maybe a battery cap. amp isnt getting enough power to perform so it cuting out.

Mar 01, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Sony xplod 1200 watt


i had the same ploblem with my amp then i found out i didnt have a good enough ground. Make sure you groung it to your weel well or some part of the frame. Or you mite be running with a fuse thats pushing to much power i use a 100a fuse 5 gage power cord to power my 1200w xplode and my 2 12" kicker comps. Or if your using two diff kind of subs then you amp is confused in why your asking for 500w on one side and 600w on the other this will also make your amp light come on.

Jan 19, 2009 | Sony Xplod 1200W Class AB Bridgeable 2-Ch....

1 Answer

Sony Xplod Amp


Disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If it still shuts down, the amp likely has blown output transistors.

Jan 11, 2008 | Sony XM-504Z Car Audio Amplifier

2 Answers

Sony Xplod XM-1652Z Car Audio Amplifier cuts out when turned up loud


The best thing to do is to get a amp that is more watts than your subs, not the other way around, speakers are known to handel a lil more power but amps cant produce more power than they are capable of... your ground wire should be thick also, say 6 to 8 mm or so, and its best to put in a cap and an equalizer.
Cheers

Dec 19, 2007 | Sony Xplod XM-1652Z Car Audio Amplifier

Not finding what you are looking for?
Sony Xplod 1200W Class AB Bridgeable 2-Ch. Amplifier w/Variable Low-Pass Crossover Logo

Related Topics:

27 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Audio Players & Recorders Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5158 Answers

Are you a Sony Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...